If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Loop] User can't interact with notifcation bar during call

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Loop
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: SalvadorR, Assigned: albertopq)

Tracking

(Blocks: 1 bug, {regression})

unspecified
2.2 S3 (9jan)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.1S verified, b2g-v2.2 verified)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8519099 [details]
logcat_20141106_1654.txt

[Loop] User can't interact with notifcation bar during call
  
Description:
When user is in a call and attempts to interact with notification bar, the notifcation bar does nothing
   
Repro Steps:
1) Update a Flame device to BuildID: 20141107001205
2) Open loop app and make a call
3) During call attempt to interact with notifcation bar
4) Observe functionality
  
Actual:
Can't use notifcation bar during a call
  
Expected: 
Able to use notifcation bar during a call
  
Environmental Variables:
Device: Flame 2.1 (319mb) KK Shallow Flash
BuildID: 20141107001205
Gaia: 6295f6acfe91c6ae659712747dd2b9c8f51d0339
Gecko: 8c23b4f2ba29
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 3/3
See attached: Video, Logcat
http://youtu.be/0TeLD8d0MHY
Flags: needinfo?(jmitchell)
(Reporter)

Comment 1

3 years ago
This issue also occurs on Flame 2.2

Result: Can't use notification bar

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141107040206
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: 64f4392d0bdc
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0"
------------------------------------------------------------
This issue does not occur on Flame 2.0

Result: Can use notification bar

"Flame 2.0 

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash
BuildID: 20141107000206
Gaia: d3e4da377ee448f9c25f908159480e867dfb13f3
Gecko: 9836e9d81357 
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0"
QA Whiteboard: [QAnalyst-Triage?]
[Blocking Requested - why for this release]: Regression, Broken functionality
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
(Reporter)

Updated

3 years ago
blocking-b2g: 2.1? → ---
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Keywords: regressionwindow-wanted
Summary: [Loop] Loop app will not recognize registered users when user clearly has account set up → [Loop] User can't interact with notifcation bar during call
Re-adding flags, as they should not have been removed
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Keywords: regressionwindow-wanted
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20140830094116
Gaia: c05ee27dd1f39e0f1cceb8bc7706e20f297cd9df
Gecko: 82e1c0a8c589
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140830195315
Gaia: 2be78d83a760fa3b9638fe51c266b442d14597f1
Gecko: 1db35d2c9a2f
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: c05ee27dd1f39e0f1cceb8bc7706e20f297cd9df
Gecko: 1db35d2c9a2f
Broken Gaia / Working Gecko = Repro
Gaia: 2be78d83a760fa3b9638fe51c266b442d14597f1
Gecko: 82e1c0a8c589
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/c05ee27dd1f39e0f1cceb8bc7706e20f297cd9df...2be78d83a760fa3b9638fe51c266b442d14597f1


B2G Inbound
Last working
BuildID: 20140829124900
Gaia: c1625ae6a088ee362b88a2e857147f956f3baea8
Gecko: e43a2d77a921
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140829131701
Gaia: c5e67119b517ad544816bea58bce455374b9b499
Gecko: 72f99f685cc6
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: c1625ae6a088ee362b88a2e857147f956f3baea8
Gecko: 72f99f685cc6
Broken Gaia / Working Gecko = Repro
Gaia: c5e67119b517ad544816bea58bce455374b9b499
Gecko: e43a2d77a921
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/c1625ae6a088ee362b88a2e857147f956f3baea8...c5e67119b517ad544816bea58bce455374b9b499
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
possibly broken by either Bug 1042713, or Bug 1037255

Starting with Bug 1042713 which seems the more likely - Can you take a look Alberto?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(apastor)
QA Contact: ckreinbring
(Assignee)

Comment 6

3 years ago
Sorry, what does exactly mean 'interact with the notification bar'? I'm not sure if we are talking about the attention-indicator, utility-tray or notifications-banner here :S 

Thanks!
Flags: needinfo?(apastor) → needinfo?(jmitchell)
redirecting NI to bug reporter
Flags: needinfo?(jmitchell) → needinfo?(srapanan)
(Assignee)

Comment 8

3 years ago
I guess we are talking about the ambient indicator (showing the utility tray). Not sure what's the expected behavior here. Rob, during attention screens, should the ambient indicator be visible? In case it should, should the utility tray be actionable? Thanks!
Flags: needinfo?(rmacdonald)
Waiting for rob/UX to get back here before making a blocking decision.
Thanks for flagging me on this.

Looking at the video, the status bar, when dragged should reveal the utility tray. This allows users to view their notifications while in a call, whether it be loop or dialer. So this is a valid bug and should block.

The ambient indicator is used when the user tasks away from attention window and is a separate issue. So, if a user tasks away from a call or loop conversation, the ambient indicator appears along the top of the status bar to tell the user that there is an active call. Alive and Etienne worked on this for the dialer and the ux spec is located here - https://mozilla.box.com/s/8z5gr9rds22gh0k7fuyz.

I hope this helps!

Rob
Flags: needinfo?(rmacdonald)
(Assignee)

Comment 11

3 years ago
Mhm, I'm not sure here. My understanding was that the utility tray was only accessible after tapping the home button during a call. Then, the attention indicator is shown (as you were describing) and the utility tray is 'dragable'. The video is showing the attention screen, without pressing the home button. Did I get something wrong? Sorry for flagging again...
Flags: needinfo?(rmacdonald)
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1099004
(Assignee)

Comment 13

3 years ago
Hi Rob,

According to https://mozilla.app.box.com/s/l863mefh21ni92ypglwu/1/2243089765/19326526351/1, the utility tray shouldn't be actionable during the call, only after pressing the home button (and the active ambient indicator is shown). I think the bug here is that the ambient indicator should be hidden during the attention screen.
Hi Alberto...

That wasn't actually the intent although I can understand how one could arrive at that conclusion because the spec focuses solely on the multitasking case and doesn't show that the tray can be accessed from the attention screen. So my response re opening the tray in comment 10 still stands. Sorry for any confusion there. 

- Rob
Flags: needinfo?(rmacdonald)
NI oteo, from Tef, to see if this is something we can fix on the app side.
Flags: needinfo?(oteo)
(Assignee)

Comment 16

3 years ago
This needs to be fixed in the system app.
Assignee: nobody → apastor
Flags: needinfo?(oteo)

Comment 17

3 years ago
Created attachment 8540576 [details] [review]
[PullReq] albertopq:1095677-attention-tray to mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8540576 - Flags: review?(alive)
Comment on attachment 8540576 [details] [review]
[PullReq] albertopq:1095677-attention-tray to mozilla-b2g:master

Better if you explain why.
Attachment #8540576 - Flags: review?(alive) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Comment 19

3 years ago
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Note: Until bug 1095028 lands, the patch *must* have a review by a suggested reviewer. If you are the patch author, you can leave an additional R+ on the attachment for autolander to process it.

Updated

3 years ago
Keywords: checkin-needed

Comment 20

3 years ago
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.

Note: Until bug 1095028 lands, the patch *must* have a review by a suggested reviewer. If you are the patch author, you can leave an additional R+ on the attachment for autolander to process it.
(Assignee)

Comment 21

3 years ago
master: https://github.com/mozilla-b2g/gaia/commit/1913c69336f2e8f8bfd97e3179e862d325aa3a99
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 22

3 years ago
"interact with the notification bar." Meaning that I was unable to have the notifcation bar drop down when connecting to a call.
Flags: needinfo?(srapanan)
Can qa please help verify this bug on a 2.2 build? Alberto, how risky is this uplift for 2.1 at this point ?
blocking-b2g: 2.1? → 2.1+
Keywords: verifyme
(Assignee)

Comment 24

3 years ago
A css 3 liner that allows pointer-events on the utility-tray when in the attention screen. I would recommend uplifting it after verifying.
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S3 (9jan)
(Assignee)

Comment 25

3 years ago
A regression has been found in Bug 1121188, so don't uplift to 2.1 yet
(Assignee)

Updated

3 years ago
Depends on: 1121188
Bug 1121188 has landed, please request v2.1 approval now please.
Flags: needinfo?(apastor)
(Assignee)

Comment 27

3 years ago
Comment on attachment 8540576 [details] [review]
[PullReq] albertopq:1095677-attention-tray to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: User can't interact with the utility tray during a call
[Testing completed]: Added tests in Bug 1121188, which should be uplifted just after this one
[Risk to taking this patch] (and alternatives if risky): given that is a css change and the added integration tests, I would say is save to uplift
[String changes made]:
Flags: needinfo?(apastor)
Attachment #8540576 - Flags: approval-gaia-v2.1?

Updated

3 years ago
Attachment #8540576 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/92aa972f7feabb123b52b86d5ff1549db9402fbb
status-b2g-v2.1: affected → fixed

Updated

3 years ago
status-b2g-v2.1S: --- → fixed
The problem is verified not happen on latest Flame 2.1 and 2.2 build.

Steps:
1) Open loop app and make a call
2) During call attempt to interact with notifcation bar
3) Observe functionality
  
Actual:
You can drag down notifcation bar and turn on/off BT... during a call.

Fail rate:0/5
Loop version:bd8f1c2
See attachment:1228.mp4

Flame 2.1 version:
Gaia-Rev        d98bbe9d2bfdb53e80dc1ab1572bd05938a85526
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/c694578ff69e
Build-ID        20150128001258
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150128.034753
FW-Date         Wed Jan 28 03:48:03 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 version:
Gaia-Rev        cd42b034fd2825c3675ace3a67f5775eb61c2d60
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d824c65a6a2b
Build-ID        20150128002506
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150128.035910
FW-Date         Wed Jan 28 03:59:20 EST 2015
Bootloader      L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+],MGSEI-Triage+
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Created attachment 8556345 [details]
1228.MP4
Hi Vincent,

    Could you please tell me what is your device storage when you fix this bug on 2.1S ?  512M or 256M?

Thank you very much.
Flags: needinfo?(vliu)
Hi Reporter,

    Could you please tell me what is your device MEM when you found this bug on 2.1S ?  512M or 256M?  You can get the "MemTotal" using below command: " adb shell cat /proc/meminfo ".

Thank you very much.
Flags: needinfo?(srapanan)
The problem is verified not happen on latest 2.1s(256m and 512m) build.

Steps:
1) Open loop app and make a video call
2) During call attempt to interact with notifcation bar
3) Observe functionality
  
Actual:
You can drag down notifcation bar and turn on/off BT... during a call.

Fail rate:0/5
Loop version:bd8f1c2

2.1s(256m) version:
Build ID               20150209001232
Gaia Revision          bca70e96979fbd714012dc442a92b9fa156f63f7
Gaia Date              2015-02-03 00:37:47
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/afac5ac46ff6
Gecko Version          34.0
Device Name            scx15_sp7715ga
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.035424
Firmware Date          Mon Feb  9 03:54:36 EST 2015

2.1s(512m) version:
Build ID               20150209001232
Gaia Revision          bca70e96979fbd714012dc442a92b9fa156f63f7
Gaia Date              2015-02-03 00:37:47
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/afac5ac46ff6
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  93
Firmware Date          Thu Jan 22 15:21:20 CST 2015
Flags: needinfo?(vliu)
Flags: needinfo?(srapanan)
status-b2g-v2.1S: fixed → verified
Keywords: verifyme
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.