[System] Status bar is missing all icons when in an application or lockscreen (Clock, Battery, Wifi/Data, Bluetooth, etc)

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: onelson, Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-Daily-Testing][systemsfe])

Attachments

(2 attachments)

Description:
When a user opens any application, they will observe that they lose UI of every status bar icon. These icons include the standard that are always present (clock, battery), settings-specific (Wifi, Data, Bluetooh) and application-specific (alarms). 
They are only present now when at the top of the homescreen as well, when scrolled down a black bar is displayed.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141107073659
2) Observe status bar UI on lockscreen [Actual]
3) Unlock phone.
4) Observe top-of-homescreen UI [Expected]
5) Scroll down on homescreen.
6) Observe status bar UI on homescreen [Actual]
7) Open 'Dialer' app.
8) Observe status bar UI in 'Dialer' [Actual]
  
Actual:
Status bar icons are not visible; empty status bar.
  
Expected: 
Status bar icons are visible.

***************************************************************  
Environmental Variables:
----------------------------------------------

Device: Flame 2.2 Master
BuildID: 20141107073659
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: b62ccf3228ba
Gonk: 
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

===============================================

Issue DOES NOT REPRO on flame KK 2.1 devices:
Results: Status bar icons are visible.

Device: Flame 2.1 (319mb) KK Shallow Flash
BuildID: 20141107001205
Gaia: 6295f6acfe91c6ae659712747dd2b9c8f51d0339
Gecko: 8c23b4f2ba29
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

***************************************************************
  
Repro frequency: 8/8
See attached:
image (5 compiled screenshots)
logcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.2-Daily-Testing]
It looks as if you have the SHB enabled - does this happen without it enabled?
Flags: needinfo?(onelson)
I can confirm this issue occurs on today's Flame 2.2 build both with and without SHB enabled.
Flags: needinfo?(onelson)
Duplicate of this bug: 1096281
[Blocking Requested - why for this release]:

The status bar should always be visible and this is a regression so nominating 2.2?
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Contact: jmercado
This issue no longer occurs in the latest Tinderbox 2.2 Flame KK builds.  I believe this is because of the backout of Bug 1091483 as the results seem to be the same.

Please see: https://bugzilla.mozilla.org/show_bug.cgi?id=1095657#c4

Environmental Variables:
Device: Flame 2.2
BuildID: 20141110053355
Gaia: e02facadb0bc3fe32227b52b31ca47822f7f4322
Gecko: c0d559389a5c
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Striking Regression-window tag - Issue is already resolved in tinderbox-side; We should check Nightly tomorrow morning to verify
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: jmercado
Whiteboard: [2.2-Daily-Testing] → [2.2-Daily-Testing][systemsfe]
Qa-wanted to check this in todays build - verify it is fixed.
Keywords: qawanted
Verified FIXED in today's v2.2.

Device: Flame 2.2 Master KK (319 MB)
BuildID: 20141112040208 (shallow flash)
Gaia: 5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko: 688f821edcd4
Gonk: n/a
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Status bar with icons is visible during all navigation.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: rpribble
resolved fixed
Status: NEW → RESOLVED
Closed: 5 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: rpribble
Resolution: --- → FIXED
blocking-b2g: 2.2? → ---
Flags: in-qa-testsuite? → in-qa-testsuite+
Issue verified fixed on Flame 2.2

Actual Results: Status bar icons are visible at all expected times.

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141113040205
Gaia: be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko: ab137ddd3746
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Removing in-qa-testsuite flag as bug 1100411 has been filed for a test addressing this.
Flags: in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.