[E10S] Firefox restores the last session with at-least 1 empty tab

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: achwaqkhalid, Unassigned)

Tracking

({regression})

36 Branch
x86_64
Windows 8.1
regression
Points:
---

Firefox Tracking Flags

(e10s?)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141107073659
(Reporter)

Updated

4 years ago
Blocks: 516752
Component: Untriaged → Session Restore
Keywords: regression

Updated

4 years ago
tracking-e10s: --- → ?
(Reporter)

Comment 2

4 years ago
Doesn't occur on the beta Chanel so it must be e10s.
Can you please give a little more information on what's going wrong here? I can't figure out from only the bug title.
Flags: needinfo?(achwaqkhalid)
(Reporter)

Comment 4

4 years ago
(In reply to Tim Taubert [:ttaubert] from comment #3)
> Can you please give a little more information on what's going wrong here? I
> can't figure out from only the bug title.

while running in e10s mode and assuming you have 3++ tabs (not necessarily all loaded) restart the browser, look among the tabs you will find at-least one that is blank titled "New Tab"
Flags: needinfo?(achwaqkhalid)

Comment 5

4 years ago
Pretty sure this is a dupe, please un-dupe of you disagree.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1085813
(Reporter)

Comment 6

4 years ago
(In reply to Jim Mathies [:jimm] from comment #5)
> Pretty sure this is a dupe, please un-dupe of you disagree.
> 
> *** This bug has been marked as a duplicate of bug 1085813 ***

No sorry Jim! Totally two different issues :)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to Achwaq Khalid from comment #2)
> Doesn't occur on the beta Chanel so it must be e10s.

For the record, there are many other changes between Nightly and Beta.

None of us can reproduce this here. Achwaq, if you can still reproduce this, can you give explicit steps to reproduce? As things are, we have no way of debugging this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

4 years ago
(In reply to Blake Kaplan (:mrbkap) from comment #7)
> None of us can reproduce this here. Achwaq, if you can still reproduce this,
> can you give explicit steps to reproduce? As things are, we have no way of
> debugging this.

Here are the steps to reproduce it:

- open at-least 220 or more tabs (it doesn't matter if they are loaded or not)
- restart nightly
- result: you will find at-least a tab with blank/empty content
Resolution: WORKSFORME → INVALID
You need to log in before you can comment on or make changes to this bug.