Closed Bug 1095730 Opened 8 years ago Closed 8 years ago

[e10s] First tab in a restored window never gets its title

Categories

(Firefox :: Tabbed Browser, defect)

36 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s ? ---

People

(Reporter: rnewman, Unassigned)

References

(Blocks 1 open bug)

Details

Just noticed this after switching Vertical Tabs back on. I don't think it's VT related.

After a session restore, the first page has been restored (if not loaded), but its tab is still titled "New Tab". Clicking the tab causes it to load and the title to come back. One of my windows actually had the first tab selected, and the page was loaded, but the title was "New Tab" until I reloaded the page.
Something like that Richard 1095726 ?
Yes, unless you ended up with a genuinely empty tab. Mine knew which page to show.
(In reply to Richard Newman [:rnewman] from comment #3)
> Yes, unless you ended up with a genuinely empty tab. Mine knew which page to
> show.

Maybe it's not the same bug then since mine was blank with empty content in it
Blocks: fxe10s
No longer blocks: e10s
Component: General → Tabbed Browser
Is there a good way to reproduce this? WFM all the time.
Flags: needinfo?(rnewman)
If I had to speculate:

* Open nine windows with approximately 10-30 tabs per window. Load content in each. With e10s disabled your RSIZE should be about 1.5GB-2GB.
* Install Darrin's Vertical Tabs add-on. (Who knows, it might make a difference.)
* Relaunch with e10s enabled.
* Wait a few minutes for session restore to finish.
* Quit and relaunch again.
* Observe symptoms in Comment 0.
Flags: needinfo?(rnewman)
(In reply to Richard Newman [:rnewman] from comment #6)
> If I had to speculate:
> 
> * Open nine windows with approximately 10-30 tabs per window. Load content
> in each. With e10s disabled your RSIZE should be about 1.5GB-2GB.
> * Install Darrin's Vertical Tabs add-on. (Who knows, it might make a
> difference.)
Can you try without that addon?
> * Relaunch with e10s enabled.
> * Wait a few minutes for session restore to finish.
> * Quit and relaunch again.
> * Observe symptoms in Comment 0.
Flags: needinfo?(rnewman)
I think someone other than me (probably a developer working on e10s) needs to try to repro this with those steps; I had to turn e10s off after filing a bunch of bugs because I don't have time to work around them, and I don't want to keep tempting the gods of session store data loss.
Flags: needinfo?(rnewman)
(In reply to Brad Lassey [:blassey]s Vertical Tabs add-on. (Who knows, it might make a

> Can you try without that addon?

I still can observe the same behavior even with addon disabled Brad
This works for me and everyone else on the e10s team. If you still see this, please provide exact STR that doesn't include an add-on.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.