Closed Bug 1095778 Opened 5 years ago Closed 4 years ago

e10s: Youtube player feels sluggish/unresponsive

Categories

(Core :: Audio/Video, defect, P5)

36 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s + ---

People

(Reporter: akulle12, Unassigned)

References

(Blocks 2 open bugs)

Details

The Youtube player feels very sluggish when having Electrolysis and Media Source Extensions enabled.
Blocks: e10s
I can confirm that with both VP9 and h264 content
Blocks: MSE
Status: UNCONFIRMED → NEW
tracking-e10s: --- → ?
Ever confirmed: true
(In reply to akulle12 from comment #0)
> The Youtube player feels very sluggish when having Electrolysis and Media
> Source Extensions enabled.

Sluggish how? It's just as slow to react for seeks here (If it actually succeds and doesn't hang)
And when it hangs it becomes totally unresponsive.

What I do notice is that sometimes videos play quite well (both e10s and normal window) for a while but then start to hang all the time on seeks or just by themselves.
(In reply to avada from comment #2)
> Sluggish how? It's just as slow to react for seeks here (If it actually
> succeds and doesn't hang)
> And when it hangs it becomes totally unresponsive.
I mean that it's slow to react, for example when I click on the video to pause it, it can take seconds before it actually reacts to it.
akulle: do you have any add-ons installed, such as Adblock Plus? We had some YouTube performance bugs related to Adblock Plus (bug 1062713), but they should have been fixed.
(In reply to Chris Peterson (:cpeterson) from comment #4)
> akulle: do you have any add-ons installed, such as Adblock Plus? We had some
> YouTube performance bugs related to Adblock Plus (bug 1062713), but they
> should have been fixed.
I disabled all my add-ons and I still could reproduce the bug.
ajones, any ideas here?
Flags: needinfo?(ajones)
MSE does more processing on the main thread than the regular video element. Perhaps this is also the case for e10s.
Flags: needinfo?(ajones)
This blocks e10s not MSE for the purposes of priority at this point.
Priority: -- → P5
I'm going to close this because e10s works swimmingly. Re-open if there are still issues.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
I think youtube itself is heavy and that makes the player and practically everything else also sluggish if you have an older PC.
E10s just makes it somewhat worse, and you get the spinner shoved in your face all the time.
(In reply to avada from comment #10)
> E10s just makes it somewhat worse, and you get the spinner shoved in your
> face all the time.

Does bug 1143575 make a difference?
You need to log in before you can comment on or make changes to this bug.