Closed Bug 1095799 Opened 6 years ago Closed 5 years ago

Startup crash detection doesn't prompt for safe mode in some cases (possibly related to the crash reporter)

Categories

(Toolkit :: Startup and Profile System, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 892885

People

(Reporter: MattN, Unassigned)

References

Details

(Keywords: regression)

Step 5 should be to click the restart button from the crash reporter dialog.

STR:
1) Setup a profile to have a startup crash (e.g. install Force RTL in a profile with E10S on by default)
2) If it's a debug build, make sure to set toolkit.startup.always_use_safe_mode to true since the feature is disabled in debug builds.
3) Make sure the build has crash reporter enabled
4) Startup the browser and crash within 30 seconds of startup
5) Click the restart button from the crash reporter dialog 
6) Repeat steps 4 & 5 four times (larger than toolkit.startup.recent_crashes)

Expected result:
The safe mode dialog should appear

Actual result:
The safe mode dialog never appears despite the pref toolkit.startup.recent_crashes incrementing
Can you point me to a time when this was known to be working correctly? And does this still reproduce with current builds?
Flags: needinfo?(MattN+bmo)
Also, possibly related to/dupe of bug 1012715?
AFAICT, this is a dupe of bug 892885. Feel free to reopen if that's incorrect, however.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(MattN+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 892885
You need to log in before you can comment on or make changes to this bug.