Closed Bug 1096399 Opened 5 years ago Closed 5 years ago

[Loop] Upgrade React to 0.12.2

Categories

(Hello (Loop) :: Client, defect, P2)

defect
Points:
2

Tracking

(Not tracked)

RESOLVED FIXED
mozilla37
Iteration:
37.3 - 12 Jan
Blocking Flags:
backlog Fx38+

People

(Reporter: NiKo, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

Flags: qe-verify-
if we find we need sooner - go ahead and grab bug.
backlog: --- → Fx38+
Priority: -- → P2
0.12.2 is out:

http://facebook.github.io/react/blog/2014/12/18/react-v0.12.2.html
Summary: [Loop] Upgrade React to 0.12.0 → [Loop] Upgrade React to 0.12.2
Attached patch [Loop] Upgrade React to 0.12.2. (obsolete) — Splinter Review
Upgraded React to latests version, and migrated code where wdeprecation arnings were triggered.

*Important:* Note that you *need* to upgrade your local version of react-tools in order to transpile the JSX files using this new version. The ./build-jsx utility will raise an error if your version isn't up to date.
Attachment #8544077 - Flags: review?(standard8)
Unbitrotted patch.
Attachment #8544077 - Attachment is obsolete: true
Attachment #8544077 - Flags: review?(standard8)
Attachment #8544538 - Flags: review?(standard8)
Comment on attachment 8544538 [details] [diff] [review]
[Loop] Upgrade React to 0.12.2.

Review of attachment 8544538 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, r=Standard8
Attachment #8544538 - Flags: review?(standard8) → review+
https://hg.mozilla.org/integration/fx-team/rev/7e69ba4b7dd9
Iteration: --- → 37.1
Points: --- → 2
Target Milestone: --- → mozilla37
https://hg.mozilla.org/mozilla-central/rev/7e69ba4b7dd9
Assignee: nobody → nperriault
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Depends on: 1119485
Iteration: 37.1 → 37.3 - 12 Jan
Depends on: 1185704
You need to log in before you can comment on or make changes to this bug.