Closed Bug 1097768 Opened 7 years ago Closed 4 years ago

[User Story] Contact-centered quick dial & messaging

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

Other
Other
defect
Not set
normal

Tracking

(tracking-b2g:backlog)

RESOLVED WONTFIX
2.2 S3 (9jan)
tracking-b2g backlog

People

(Reporter: wmathanaraj, Unassigned)

References

()

Details

(Keywords: feature)

User Story

As a user I want to be able to add contacts to the home screen so i can quickly and easily initiate communication with my favorite contacts.

Acceptance Criteria:

if contact is deleted then pinned contact should be removed from homecreen
if contact has a picture then that picture should be used when pinned to homescreen
if contact has no picture then placeholder should be used when pinned to homescreen
if there are multiple number I want to be able to choose which number is used.
if a number is deleted in the contact details then that activity should not be possible and user should not be offered the option when he taps the pinned contact

Attachments

(2 files)

No description provided.
User Story: (updated)
Keywords: feature
User Story: (updated)
Wilfred, is there any reason this is in the Gaia::SMS component instead of the Gaia::Contacts component?
Flags: needinfo?(wmathanaraj)
Component: Gaia::SMS → Gaia::Contacts
Flags: needinfo?(wmathanaraj)
First proposal from Carrie attached, already reviewed, some stuff like badges removed in first review.
Attaching an example of visual design for the proposal by Fang
feature-b2g: --- → 2.2+
Target Milestone: --- → 2.2 S3 (9jan)
QA Contact: jlorenzo
Depends on: 1101029
No longer depends on: 1105695
QA Whiteboard: [2.2-feature-qa+]
[Tracking Requested - why for this release]:
feature-b2g: 2.2+ → ---
tracking-b2g: --- → ?
QA Whiteboard: [2.2-feature-qa+]
No longer depends on: 1101029
Is this basically either a dupe of bug 923970 or a bug for the actual implementation doing what that bug was filed for?
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.