Closed Bug 1098024 Opened 7 years ago Closed 7 years ago

[Costcontrol] Navigation error between tabs

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

defect
Not set
normal

Tracking

(b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: mai, Assigned: mai)

References

Details

(Keywords: regression)

Attachments

(2 files)

STR
1. Launch the usage app with a prepaid sim.
2. Press on Internet tab.
3. Open settings, clicking the gear button.
4. Change the plantype
5. Press on Done button.
Expected.
  The setting screen is closed and the App shows the Internet screen
Current behaviour.
  The setting screen is not closed and the navigation is only restored if the user changes the plantype again.
Depends on: 1064507
No longer depends on: 1094753
Keywords: regression
This is a regression introduced by the Bug 1064507 - [Cost Control][Usage] Returning to the Usage app displays a blank screen on a device set to 319MB memory.
Attached file patch v1.0
Hi Salva,
would you mind reviewing the patch?
Regards
Attachment #8521791 - Flags: review?(salva)
Assignee: nobody → marina.rodriguez.iglesias
Comment on attachment 8521791 [details] [review]
patch v1.0

Mmm. A missing initialization... Nice catch! Working fine.
Attachment #8521791 - Flags: review?(salva) → review+
MAster: 50797474ee0f2f4cd17880a65e6865f1866d85f8
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8521791 [details] [review]
patch v1.0

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):  1064507 
[User impact] if declined: High impact for the user, because the user cannot close the settings, and it seems the App is broken
[Testing completed]: Yes, on device
[Risk to taking this patch] (and alternatives if risky): Low risk, only a initialization of a variable.
[String changes made]: No
Attachment #8521791 - Flags: approval-gaia-v2.1?(release-mgmt)
Attachment #8521791 - Flags: approval-gaia-v2.1?(release-mgmt) → approval-gaia-v2.1+
Attached video Verify_video .3gp
This issue has been successfully verified on Flame 2.1, 2.2 See attachment: Verify video.3gp
Reproducing rate: 0/5
Flame 2.1 build:
Gaia-Rev        1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/db893274d9a6
Build-ID        20141125001201
Version         34.0

Flame 2.2 new build:
Gaia-Rev        824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/acde07cb4e4d
Build-ID        20141125040209
Version         36.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.