[Camera][Video] Recorded videos have a distorted aspect ratio, appearing stretched or squashed.

RESOLVED WORKSFORME

Status

Firefox OS
Vendcom
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Marty, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.2-Daily-Testing][POVB], URL)

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8521796 [details]
Video Aspect Screenshot.png

Description:
When the user makes a video recording, the video appears squashed or stretched due to what appears to be a distorted or improper aspect ratio.

The video is saved with a resolution of 720 x 480, but the camera app appears to capture at a resolution of roughly 850 X 480.  Instead of cropping the sides of the video, it is visually distorted into the new aspect ratio.

Notes:
-This is not a playback issue.  The video is distorted if the file is moved to a computer or another device for playback.
-The camera video does not appear distorted while actively recording, but is distorted in the Camera Preview (where you view recent recordings/pictures), and in the Video App
-This issue does not affect photographs taken with the camera, only videos.
-This affects videos recorded with both the front facing and rear facing cameras.

Repro Steps:
1) Update a Flame device to BuildID: 20141112040208
2) Open the Camera app
3) Switch to Video mode.
4) Record a video.
5) View the recorded video
  
Actual:
Landscape videos appear horizontally squashed and Portrait videos appear horizontally stretched.
  
Expected: 
Recorded videos do not appear distorted.
  
Environmental Variables:
Device: Flame 2.2 Master (319MB)
BuildID: 20141112040208 (Shallow Flash)
Gaia: 5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko: 688f821edcd4
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
  
Notes: The attached image highlights the distortion for videos captured in Landscape and in Portrait mode.
  
Repro frequency: 6/6
See attached: screenshot, video clip (URL), logcat

----------------------------------

This issue DOES occur on Flame 2.1.
Video recordings appear distorted.

Environmental Variables:
Device: Flame 2.1 (319MB)
BuildID: 20141112001201 (Shallow Flash)
Gaia: 4c159e75a1568afbbf0c83c1235ec56facfbe87d
Gecko: b9849b3c6aaa
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
(Reporter)

Comment 1

4 years ago
Created attachment 8521797 [details]
logcat-Camera.txt
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Created attachment 8522336 [details]
Screenshot from VID_0005.3gp.png

Confirmed -- this is a framegrab from a video taken of a ring which, needless to say, should be a circle. The frame is 720x480.
Created attachment 8522338 [details]
Screenshot (scaled, rotated) from VID_0005.3gp.png

Scaling the image to 854x480 (the Flame screensize) (and rotating it) results in a circular ring.
[Blocking Requested - why for this release]:
Functional regression of a core feature.

Requesting a window.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression, regressionwindow-wanted
QA Contact: pcheng
2.0 is unaffected.

Device: Flame 2.0
BuildID: 20141112171043
Gaia: ab83632c92f9fc571b11d8468b6901cc4ed905c0
Gecko: e21bf45e6c44
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
status-b2g-v2.0: --- → unaffected
If possible, can you please test this with v2.2 and v184?
Flags: needinfo?(pcheng)
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140916122258
Gaia: d3510be2067ff39ce07e72268ae510279ee7688e
Gecko: 2fbe0c8881d1
Version: 35.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140916123756
Gaia: d3510be2067ff39ce07e72268ae510279ee7688e
Gecko: 6b7ab2f8fc1f
Version: 35.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=2fbe0c8881d1&tochange=6b7ab2f8fc1f

Caused by Bug 1014877.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Caused by Bug 1014877 ? Can you take a look Mike?
Blocks: 1014877
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(mhabicher)
QA Contact: pcheng
I've confirmed we're pushing the correct values to the camera hardware when we start recording:

11-13 15:34:02.410 10786 10811 D CameraParams: dump: mMap.size = 128
11-13 15:34:02.410 10786 10811 D CameraParams: preview-size: 864x480
11-13 15:34:02.410 10786 10811 D CameraParams: video-size: 720x480

This is an issue with the vendor driver. Wesly, can you get them to address this issue in a subsequent build?

Hema, what do you think? -- should be disable the uncoupling until the vendor has had a chance to fix this issue?
Component: Gaia::Camera → Vendcom
Flags: needinfo?(wehuang)
Flags: needinfo?(mhabicher)
Flags: needinfo?(hkoka)
Whiteboard: [2.2-Daily-Testing] → [2.2-Daily-Testing][POVB]
(In reply to Mike Habicher [:mikeh] from comment #6)
> If possible, can you please test this with v2.2 and v184?

Issue is reproducible on v184 + latest 2.2. Recorded video is distorted.

Device: Flame 2.2 Master
BuildID: 20141112125016
Gaia: 65d593cdd9d88648045a30a63fc329b7bb5d340b
Gecko: 66cdb18f36da
Version: 36.0a1 (2.2 Master)
Firmware: V184
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Flags: needinfo?(pcheng)

Updated

4 years ago
Flags: needinfo?(wehuang)
See Also: → bug 1078435

Comment 11

4 years ago
Hi Mike, this seems related to bug 1078435 that I'm following w/ T2M, will include this one together about the 800x480 aspect ratio issue.

@Youlong, pls check this one as well, I've added it into our tracking list, thank you.
Flags: needinfo?(hkoka) → needinfo?(youlong.jiang)
(In reply to Wesly Huang from comment #11)
> Hi Mike, this seems related to bug 1078435 that I'm following w/ T2M, will
> include this one together about the 800x480 aspect ratio issue.
> 
> @Youlong, pls check this one as well, I've added it into our tracking list,
> thank you.

Clearing the nom here since we are tracking there.
blocking-b2g: 2.1? → ---
hi:
  we are couldn't reproduce this promble.please try use other player to play the video. and form log ,I only find it set 720*480, it maybe cause by you player.

Comment 14

4 years ago
Hi Martin:

Per comment#13 and phone discussion w/ vendor they are not able to repro. in based image v188 in their side, and current log is not enough for analysis, would you help

1. confirm this is seen in pure v188 base image? (qawanted)
2. if yes, have a STR (including video of the STR) that is easy to repro. so vendor can follow then investigate
3. if no, attach more log, T2M will add follow up comment for the "requirement" of these log.

Thanks.
Flags: needinfo?(mshuman)
Keywords: qawanted

Comment 15

4 years ago
(In reply to Wesly Huang from comment #14)
> Hi Martin:
> 
> Per comment#13 and phone discussion w/ vendor they are not able to repro. in
> based image v188 in their side, and current log is not enough for analysis,
> would you help
> 
> 1. confirm this is seen in pure v188 base image? (qawanted)
> 2. if yes, have a STR (including video of the STR) that is easy to repro. so
> vendor can follow then investigate
> 3. if no, attach more log, T2M will add follow up comment for the
> "requirement" of these log.
> 
> Thanks.

hi wesly -

what we care is the reproduce step(with video) and logcat info.

tks.
Flags: needinfo?(youlong.jiang)
(In reply to Wesly Huang from comment #14)
> 1. confirm this is seen in pure v188 base image? (qawanted)

This issue does NOT occur with just v188 base image.

This issue ONLY occurs when we flash affected builds on top of v184, v188, or v188-1 base images. For the range of affected builds please refer to comment 7 - all central builds after the First Broken build reproduce the bug.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(mshuman) → needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)

Comment 17

4 years ago
hi wesly -

then, from comment#16, could you pls check difference in gaia/gecko part first.

tks.

Comment 18

4 years ago
NI +
Flags: needinfo?(wehuang)

Comment 19

4 years ago
Hi Martin:

Since this can't be repro. in vendor side w/ pure base image, would you help provide more log as mentioned in comment#15 w/ video of STR? Thank you.
Flags: needinfo?(wehuang) → needinfo?(mshuman)
See Also: → bug 1104739
(Reporter)

Comment 20

4 years ago
Created attachment 8529259 [details]
Video-Aspect-STR-logcat.txt

I've attached a new logcat of the issue.

I've also uploaded another video demonstrating the STR here:
http://youtu.be/THBFUy0DCEE

These are the STR:
1) Update a Flame device to BuildID: 20141126001202
2) Open the Camera app
3) Switch to Video mode.
4) Record a video.
5) View the recorded video

Note: This issue no longer occurs on Flame 2.2. It seems it was fixed on the 2.2 branch with bug 1098660.
Flags: needinfo?(mshuman)
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)

Comment 21

4 years ago
Hi Martin:

Thanks for the news about 2.2 status in commment#20!

Since this is already fixed in 2.2 so ok for development, also not seen in v188 base image which will be fine for Flame normal user, I would suggest not to put more time/effort on this one and move our focus to other issues, how do you think?
status-b2g-v2.2: affected → unaffected
Flags: needinfo?(mshuman)
bug 1098660 got denom'd for 2.1, so this will still be affected (won't be getting that uplift).  need info on qa area lead for decision on how to proceed.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Flags: needinfo?(npark)
Flags: needinfo?(mshuman)
I asked for bhavana and andrew's feedback on bug 1098660
Flags: needinfo?(npark)
According to https://bugzilla.mozilla.org/show_bug.cgi?id=1098660#c24, the fix for bug 1078435 will fix this bug as well in 2.1 .  Peter, once that's uplifted, could you also verify whether it clears this issue as well?

Updated

4 years ago
Flags: needinfo?(pbylenga)
Will do, leaving needinfo on me to check this when bug 1078435 lands.
Marty now that bug 1078435 landed on 2.1 can you recheck your issue?
Flags: needinfo?(pbylenga) → needinfo?(mshuman)
(Reporter)

Comment 27

3 years ago
Resolving as WorksForMe on Flame 2.1
Recorded video has correct aspect ratio

Environmental Variables:
Device: Flame 2.1 (319MB)(Full Flash)
BuildID: 20150120001202
Gaia: 77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko: f05d0a2d2378
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.1: affected → verified
Flags: needinfo?(mshuman) → needinfo?(pbylenga)
Resolution: --- → WORKSFORME
Thank you Marty.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.