[e10s] context menu items show wrong items after detaching tab

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: mgoodwin, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I'm not sure if this is a dupe of bug 1088126; filing separately since the details are different.

Issue:
When I drag a tab from one (e10s) window to another, the context menu items in the dragged tab are wrong (showing whatever the context menu items where last time a context menu was open elsewhere). Dragging the tab back does not fix the issue. Context menus in other tabs seem unaffected.

STR:
Open nightly (I'm using 2014-11-13 on Linux).
Open two windows (with some document in each)
Open a new tab in one window (with some other document)
Select some text in the other window, right click. Observe context menu items
Drag the new tab from one window to the other
Right click a link in the new window. Observe the context menu items are incorrect for this context.
Any errors or warnings in the console?
Flags: needinfo?(mgoodwin)
(Reporter)

Comment 2

4 years ago
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #1)
> Any errors or warnings in the console?

I'm not seeing this behavior any more; I'm now seeing bug 1088126 instead (elt.syncHandler is null / gContextMenu is null). If I see this again, I'll try to grab more info.
Flags: needinfo?(mgoodwin)
WFM according to comment 2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.