[Camera][Flame] Opening user- and away-facing cameras at the same time causes BOTH to close/fail/crash

RESOLVED WONTFIX

Status

Firefox OS
Vendcom
RESOLVED WONTFIX
4 years ago
5 months ago

People

(Reporter: mikeh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [caf priority: p2][CR 734980][POVB])

Attachments

(1 attachment)

Created attachment 8523191 [details]
logcat showing the errors/failure: "mm-camera-intf: mm_camera_event_notify: Camera Event DAEMON DIED received"

+++ This bug was initially created as a clone of Bug #1079543 +++

(Note: the getUserMedia app is attachment 8521527 [details].)

--- Text below copied from bug 1079543 comment 79 ---

I think the problem is related to the difference between front and back camera. I re-tested with the test app using both cameras. Here's the result:

1. Open getUserMedia app > Select Back Camera > Open Camera app > Overlay appears.
2. Open getUserMedia app > Select Front Camera > Open Camera app > Blank camera preview appears (no overlay).

Video: http://youtu.be/tWu1Rm0Iybs

Since the Loop app uses the front camera, I was unable to get the overlay when I opened the Camera app, which has the back camera as default. Both 2.1 and 2.2 display the same behaviors.

Device: Flame 2.1 (319mb, KK, Shallow Flash)
BuildID: 20141113001200
Gaia: 569a299ca446f714cd98d5881cc058fd6f6e257b
Gecko: d188e92aa5a6
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 (319mb, KK, Shallow Flash)
BuildID: 20141113040205
Gaia: be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko: ab137ddd3746
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

--- More Notes ---

1. The logcat shows the Camera app preview failing to start, which due to the pre-init camera hw (which opened!) shows up in the DOM-layer as a setConfiguration() failure, for which there is not callback/promise/event. This needs to be mapped to a suitable onError callback/promise/event. This is why the screen stays black with no error.

2. Shortly after the Camera app preview fails to start, the following occurs in the logcat:

11-14 15:16:40.970   255  1874 E mm-camera: mct_bus_sof_thread_run: SOF freeze; Sending error message
11-14 15:16:40.970   199  1854 E mm-camera-intf: mm_camera_event_notify: Camera Event DAEMON DIED received
11-14 15:16:40.970   199  1917 E mm-camera-intf: mm_camera_event_notify: Camera Event DAEMON DIED received
11-14 15:16:40.970  1758  1875 I PRLog   : 28714296[b2249e00]: OnSystemError : aWhere=0, aArg1=100, aArg2=0
11-14 15:16:40.970  1758  1875 I PRLog   : 28714296[b2249e00]: New preview state is 'stopped'
11-14 15:16:40.970  1758  1875 I PRLog   : 28714296[b2249e00]: CameraControlImpl::OnSystemError : aContext='Camera Service' (0), aError=0x80004005
11-14 15:16:40.970  1876  1891 I PRLog   : 28703768[b197ed00]: OnSystemError : aWhere=0, aArg1=100, aArg2=0
11-14 15:16:40.970  1876  1891 I PRLog   : 28703768[b197ed00]: New preview state is 'stopped'
11-14 15:16:40.970  1876  1891 I PRLog   : 28703768[b197ed00]: Preview stopped, clearing current frame
11-14 15:16:40.970  1876  1876 I PRLog   : -1225502380[b6a4d080]: DOM OnHardwareStateChange: closed
11-14 15:16:40.970  1876  1891 I PRLog   : 28703768[b197ed00]: CameraControlImpl::OnSystemError : aContext='Camera Service' (0), aError=0x80004005

So the "DAEMON DIED" failures are propagating to the WebAPI, but due to bug 1097835, aren't getting seen/handled.
See Also: → bug 1099381
Comment on attachment 8523191 [details]
logcat showing the errors/failure: "mm-camera-intf: mm_camera_event_notify: Camera Event DAEMON DIED received"

Note:
getUserMedia app: PID=1758
Camera app      : PID=1876

Updated

4 years ago
Keywords: late-l10n

Updated

4 years ago
No longer blocks: 1074290
Depends on: 1099381
See Also: → bug 1113417
See Also: → bug 1102675

Comment 2

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.