TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/folder-display/test-columns.js | test-columns.js::test_persist_columns_gloda_collection

RESOLVED FIXED in Thunderbird 36.0

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mkmelin+mozilla, Assigned: hiro)

Tracking

({intermittent-failure})

35 Branch
Thunderbird 36.0
intermittent-failure

Thunderbird Tracking Flags

(thunderbird36 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

4 years ago
Related/dupes: bug 977253, bug 726770. Filing this now as I don't know if it really is the same.

https://tbpl.mozilla.org/php/getParsedLog.php?id=52773346&tree=Thunderbird-Trunk&full=1#error0
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/folder-display/test-columns.js | test-columns.js::test_persist_columns_gloda_collection
TEST-START | /builds/slave/test/build/mozmill/folder-display/test-columns.js | test_reset_columns_gloda_collection
Test Failure: Found visible column 'locationCol' but was expecting 'accountCol'!
desired list: threadCol,flaggedCol,subjectCol,senderCol,dateCol,accountCol
 actual list: threadCol,flaggedCol,subjectCol,senderCol,dateCol,locationCol
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to Magnus Melin from comment #0)
> Related/dupes: bug 977253, bug 726770. Filing this now as I don't know if it
> really is the same.

This failure is definitely different from those bugs.

The first appearance is on the second run of:
https://treeherder.mozilla.org/ui/#/jobs?repo=comm-central&revision=47be95d387af
The first run of mozmill tests did not fail on this test.

So it's a regression of some changes in mozilla-central.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
After 1081038, the callback (gFolderDisplay.hintColumnsChanged) of MutationObserver has been slightly shifted. So we have to wait for being the callback surely invoked before opening another tab.
Created attachment 8525753 [details] [diff] [review]
Check the updated state on each column change

I think the previous patch will fix the failure on the try but this patch is more robust.
Attachment #8525734 - Attachment is obsolete: true
Comment on attachment 8525753 [details] [diff] [review]
Check the updated state on each column change

Try server results seem good.
Attachment #8525753 - Flags: review?(mkmelin+mozilla)
(Reporter)

Comment 52

4 years ago
Comment on attachment 8525753 [details] [diff] [review]
Check the updated state on each column change

Review of attachment 8525753 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/test/mozmill/folder-display/test-columns.js
@@ +466,5 @@
>  function FakeCollection() {
>    this.items = [];
>  }
>  
> +function plan_for_columns_state_updated() {

should probably be named plan_for_columns_state_update (without the d)

@@ +472,5 @@
> +}
> +
> +function wait_for_columns_state_updated() {
> +  const STATE_PREF = "mailnews.database.global.views.global";
> +  function columns_state_updated() {

in js strict mode this will cause a complaint. you should be able to use the
let columns_state_updated = function() form though
Attachment #8525753 - Flags: review?(mkmelin+mozilla) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Created attachment 8526456 [details] [diff] [review]
Check the updated state on each column change v2

Carrying over review +.

(In reply to Magnus Melin from comment #52)
> Review of attachment 8525753 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: mail/test/mozmill/folder-display/test-columns.js
> @@ +466,5 @@
> >  function FakeCollection() {
> >    this.items = [];
> >  }
> >  
> > +function plan_for_columns_state_updated() {
> 
> should probably be named plan_for_columns_state_update (without the d)

I really appreciate this kinds of collection because you know my English skill is really awful.

> @@ +472,5 @@
> > +}
> > +
> > +function wait_for_columns_state_updated() {
> > +  const STATE_PREF = "mailnews.database.global.views.global";
> > +  function columns_state_updated() {
> 
> in js strict mode this will cause a complaint. you should be able to use the
> let columns_state_updated = function() form though

Thanks again! I did not know it.

I did a try run again for the safety.
https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=6aea1757c08c
Assignee: nobody → hiikezoe
Attachment #8525753 - Attachment is obsolete: true
Attachment #8526456 - Flags: review+
Keywords: checkin-needed
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 36.0

Comment 67

4 years ago
Thanks :)
status-thunderbird36: --- → fixed
You need to log in before you can comment on or make changes to this bug.