Support connecting to a remote ADB host

RESOLVED FIXED in Firefox OS v2.0

Status

Testing
Marionette
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: davehunt, Assigned: davehunt)

Tracking

unspecified
mozilla37
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 fixed, b2g-v2.0M fixed, b2g-v2.1 affected, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(3 attachments, 3 obsolete attachments)

(Assignee)

Description

4 years ago
In order to run tests against remote devices we need to be able to specify the host/port that ADB is listening on. The host will always be the same as the Marionette host, so we can probably just reuse that, but the port will be a unique value.
(Assignee)

Updated

4 years ago
Depends on: 1101655
(Assignee)

Updated

4 years ago
Depends on: 1102140
(Assignee)

Updated

4 years ago
Depends on: 1105995
(Assignee)

Comment 1

4 years ago
Created attachment 8535077 [details] [diff] [review]
Support the ADB server running on an alternate host/port. v1.0

Try:
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=7a2ef7a48799
Attachment #8535077 - Flags: review?(mdas)
Comment on attachment 8535077 [details] [diff] [review]
Support the ADB server running on an alternate host/port. v1.0

Review of attachment 8535077 [details] [diff] [review]:
-----------------------------------------------------------------

r+ provided that this was tested locally against bitbar.
Attachment #8535077 - Flags: review?(mdas) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6468fd2f5aa6
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
(Assignee)

Comment 5

3 years ago
Created attachment 8572001 [details]
Uplift for mozilla-b2g32_v2_0

We need this for mozilla-b2g32_v2_0 so the Marketplace tests can run against our remote device lab. I've tested this using a locally built client and have successfully run the tests on our remote lab.
Attachment #8572001 - Flags: review?(jgriffin)
(Assignee)

Updated

3 years ago
status-b2g-v2.0: --- → affected
(Assignee)

Comment 6

3 years ago
Created attachment 8572054 [details] [diff] [review]
Uplift for mozilla-b2g32_v2_0

Previous patch had an issue when generating the HTML report, which is addressed in this patch.
Attachment #8572001 - Attachment is obsolete: true
Attachment #8572001 - Flags: review?(jgriffin)
Attachment #8572054 - Flags: review?(jgriffin)
(Assignee)

Comment 7

3 years ago
Created attachment 8572055 [details] [diff] [review]
Uplift for mozilla-b2g34_v2_1
Attachment #8572055 - Flags: review?(jgriffin)
(Assignee)

Comment 8

3 years ago
Created attachment 8572060 [details] [diff] [review]
Uplift for mozilla-b2g34_v2_1

Corrected commit message and bumped version number.
Attachment #8572055 - Attachment is obsolete: true
Attachment #8572055 - Flags: review?(jgriffin)
Attachment #8572060 - Flags: review?(jgriffin)
(Assignee)

Updated

3 years ago
status-b2g-v2.1: --- → affected
Comment on attachment 8572054 [details] [diff] [review]
Uplift for mozilla-b2g32_v2_0

Review of attachment 8572054 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8572054 - Flags: review?(jgriffin) → review+
Attachment #8572060 - Flags: review?(jgriffin) → review+
(Assignee)

Updated

3 years ago
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Backed out of b2g32 and b2g34 because it's missing other mozversion and mozdevice stuff:
https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/81bbb1143b88
https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/6054cd825c71
Flags: needinfo?(dave.hunt)
status-b2g-v2.0: fixed → affected
status-b2g-v2.1: fixed → affected
(Assignee)

Updated

3 years ago
Depends on: 1139461
status-b2g-v2.0M: --- → affected
(Assignee)

Comment 13

3 years ago
Created attachment 8580627 [details] [diff] [review]
Uplift mozbase changes to mozilla-b2g32_v2_0

Updated patch to include necessary uplifts from bug 1101655, bug 1102140, and bug 1101497.

Try:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=40434762b8b7

I'm not expecting a completely clear try run. The Gip tests will fail because of the marionette-client package name change (which will land at the same time as this patch). Also see bug 1139461 comment 27 and the response regarding other expected failures.
Attachment #8572054 - Attachment is obsolete: true
Flags: needinfo?(dave.hunt)
Attachment #8580627 - Flags: review?(jgriffin)
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1139461
(Assignee)

Comment 15

3 years ago
(In reply to Dave Hunt (:davehunt) from comment #13)
> I'm not expecting a completely clear try run. The Gip tests will fail
> because of the marionette-client package name change (which will land at the
> same time as this patch). Also see bug 1139461 comment 27 and the response
> regarding other expected failures.

Please ignore the Gip failure comment, I was mixing this up with bug 1141590. I am expecting the Gip tests to pass on try.
(Assignee)

Comment 16

3 years ago
RyanVM: Would you mind looking over https://treeherder.mozilla.org/#/jobs?repo=try&revision=40434762b8b7 and comment if there are any concerns? I see some jobs haven't completed yet...
Flags: needinfo?(ryanvm)
lgtm
Flags: needinfo?(ryanvm)
Comment on attachment 8580627 [details] [diff] [review]
Uplift mozbase changes to mozilla-b2g32_v2_0

Review of attachment 8580627 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm, thanks to ryan for blessing the try run :)
Attachment #8580627 - Flags: review?(jgriffin) → review+
(Assignee)

Comment 19

3 years ago
Landed in:
https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/8e0185659915

Build:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-b2g32_v2_0&revision=8e0185659915

I'll watch Treeherder, and once I can confirm no bustage I will re-release the Python package.
Flags: needinfo?(dave.hunt)
https://hg.mozilla.org/releases/mozilla-b2g32_v2_0m/rev/8e0185659915
status-b2g-v2.0: affected → fixed
status-b2g-v2.0M: affected → fixed
You need to log in before you can comment on or make changes to this bug.