Closed Bug 110152 Opened 18 years ago Closed 13 years ago

Offer CSS2 "paged media" for people who print the show_bug page

Categories

(Bugzilla :: User Interface, enhancement, P4)

enhancement

Tracking

()

RESOLVED FIXED
Bugzilla 3.0

People

(Reporter: roland.mainz, Assigned: LpSolit)

References

()

Details

(Keywords: css2)

Attachments

(1 file, 1 obsolete file)

RFE: BugZilla use CSS2 "paged media" styles for it's pages instead of offering
the seperate "format for printing"-link.
Keywords: css2
Priority: -- → P4
Target Milestone: --- → Bugzilla 2.18
Does Mozilla or any other browser support the CSS2 paged media properties at
this time?
Myk Melez wrote:
> Does Mozilla or any other browser support the CSS2 paged media properties at
> this time?

AFAIK IE>=5.5 and Opera (for example, look at
http://webmail.nic.fi/~tapio1/Teaching/CSSTableProp.php3) support this stuff.
Mozilla5 is the only browser which does not implement it... ;-((
Summary: Make BugZilla use CSS2 "paged media" instead of the seperate "format for printing"-link → Make BugZilla use CSS2 "paged media" instead of the separate "format for printing" link
The User Interface component now belongs to Gerv.  Reassigning all UNCONFIRMED
and NEW (but not ASSIGNED) bugs currently owned by Myk (the previous component
owner) to Gerv.
Assignee: myk → gerv
Reassigning back to Myk.  That stuff about Gerv taking over the User Interface
component turned out to be short-lived.  Please pardon our confusion, and I'm
very sorry about the spam.
Assignee: gerv → myk
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
RFE: BugZilla use CSS2 "paged media" styles for its pages instead of offering
the separate "format for printing"-link.

How should the css2 @media print {...} display a bug ?
Like 'Format For Printing' ?
Like something else ?
Attached patch Study: don't print the footer (obsolete) — Splinter Review
This is a hack that works at least on Firefox, IE and Opera, showing what can
be done quite comfortably, especially with the great work Svetlana Harisova and
Vitaly Harisov are doing in bug 245924 and others: when printing, the Bugzilla
footer is omitted. (Is this something for an enhancement bug of its own?)

Using similar ways, I'd say it's possible to have media-wise hybrid bug and bug
list pages.
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: Bugzilla 2.22 → ---
Depends on: 330600
Attached patch patch, v1Splinter Review
Never print the header nor the footer, for all pages.
Assignee: myk → LpSolit
Attachment #158109 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #243022 - Flags: review?(bugzilla-mozilla)
No longer depends on: 330600
Target Milestone: --- → Bugzilla 3.0
Attachment #243022 - Flags: review?(bugzilla-mozilla) → review+
Flags: approval?
ok, does this 
Flags: approval? → approval+
Summary: Make BugZilla use CSS2 "paged media" instead of the separate "format for printing" link → Offer CSS2 "paged media" for people who print the show_bug page
Checking in skins/standard/global.css;
/cvsroot/mozilla/webtools/bugzilla/skins/standard/global.css,v  <--  global.css
new revision: 1.27; previous revision: 1.26
done
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: relnote
*** Bug 161535 has been marked as a duplicate of this bug. ***
Keywords: relnote
Whiteboard: relnote
Has been checked in in 2.23.4 but never relnoted. It's a bit late now.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.