"+" symbol is shown on the wrong side of phone numbers

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Dialer
P1
normal
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: drs, Assigned: Nefzaoui)

Tracking

unspecified
2.2 S5 (6feb)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [planned-sprint c=1])

Attachments

(7 attachments)

(Reporter)

Description

4 years ago
Created attachment 8526109 [details]
Screenshot

The "+" symbol is currently shown on the wrong side of phone numbers in RTL mode.

Bug 1080828 should provide us with some useful guidance here.
(Reporter)

Comment 1

4 years ago
Created attachment 8526128 [details]
Screenshot 2
(Reporter)

Updated

4 years ago
Target Milestone: --- → 2.2 S1 (5dec)
See Also: → bug 1058790
(Reporter)

Updated

4 years ago
Assignee: nobody → gsvelto
Whiteboard: [planned-sprint c=?] → [planned-sprint c=1]
(Assignee)

Comment 2

3 years ago
Sorry for bugging Doug, but I need to know if someone's working on this? :)
Thanks!
Flags: needinfo?(drs.bugzilla)
(Reporter)

Comment 3

3 years ago
(In reply to Ahmed Nefzaoui [:Nefzaoui] from comment #2)
> Sorry for bugging Doug, but I need to know if someone's working on this? :)
> Thanks!

Nope, feel free to take it.
Flags: needinfo?(drs.bugzilla)
Created attachment 8542518 [details] [review]
[PullReq] anefzaoui:bug-1102340 to mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8542518 - Flags: review?(drs.bugzilla)
(Reporter)

Comment 5

3 years ago
Comment on attachment 8542518 [details] [review]
[PullReq] anefzaoui:bug-1102340 to mozilla-b2g:master

Three unit tests are failing here, so please fix them, but the approach looks good.
Attachment #8542518 - Flags: review?(drs.bugzilla) → review+
(Reporter)

Updated

3 years ago
Assignee: gsvelto → nefzaoui
Target Milestone: 2.2 S1 (5dec) → 2.2 S3 (9jan)
Carrying over blocking/priority from similar bug 1058790.
blocking-b2g: --- → 2.2+
Priority: -- → P1
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/27061

The pull request could not be applied to the integration branch. Please try again after current integration is complete.
(Assignee)

Comment 8

3 years ago
Gaia is now open.
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

3 years ago
Comment on attachment 8542518 [details] [review]
[PullReq] anefzaoui:bug-1102340 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Lack of RTL support
[User impact] if declined: attachment 8526109 [details]
[Testing completed]: Yes, Device: Flame
[Risk to taking this patch] (and alternatives if risky): No risks, tests passing
[String changes made]: No string changes made
Attachment #8542518 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8542518 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: 2.2 S3 (9jan) → 2.2 S5 (6feb)
Flags: in-moztrap+

Comment 12

3 years ago
Hi Doug, 
   On Flame 2.2&3.0, I verify this issue in Call log view and Call information view, "+" symbol is shown on the left side(Verify_RTL_Call Information.png and Verify_RTL_Call log.png).But in dialing view,it is sitll shown on the right side, please see attachments:Verify_RTL_Dailing.png.Did it verify failed? Could you help me to confirm it? Thanks.
Reproduce rate:5/5
Foundtime:11:35
Attachment:Verify_RTL_Call Information.png,Verify_RTL_Call log.png, Verify_RTL_Dailing.png,logcat_1135.txt

Flame 2.2 build:

Gaia-Rev        6e494f1d2676d231abba7dcc2e2822d1170d2d02
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5e6fac01a72f
Build-ID        20150129003432
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150129.042943
FW-Date         Thu Jan 29 04:29:53 EST 2015
Bootloader      L1TC000118D0

Flame 3.0 build:

Gaia-Rev        9d2378a9ef092ab1fc15c3a9f7fc4171aab59d57
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/6bfc0e1c4b29
Build-ID        20150129010239
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150129.043711
FW-Date         Thu Jan 29 04:37:21 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(drs.bugzilla)

Comment 13

3 years ago
Created attachment 8556901 [details]
logcat_1135.txt

Comment 14

3 years ago
Created attachment 8556902 [details]
Verify_RTL_Call Information.png

Comment 15

3 years ago
Created attachment 8556903 [details]
Verify_RTL_Call log.png

Comment 16

3 years ago
Created attachment 8556904 [details]
Verify_RTL_Dailing.png

Updated

3 years ago
QA Whiteboard: [MGSEI-Triage+]
(Reporter)

Updated

3 years ago
Depends on: 1129339
(Reporter)

Updated

3 years ago
Depends on: 1131246
(Reporter)

Comment 17

3 years ago
(In reply to Coler from comment #12)

Thanks, good catch. I've filed bug 1131246 for this issue.
Flags: needinfo?(drs.bugzilla) → needinfo?(liuyong)

Comment 18

3 years ago
(In reply to Doug Sherk (:drs) (use needinfo?) from comment #17)
> (In reply to Coler from comment #12)
> 
> Thanks, good catch. I've filed bug 1131246 for this issue.

Thanks, Doug!
Flags: needinfo?(liuyong)
Summary: "+" symbol is shown on the wrong side of phone numbers → [Nexus 5]"+" symbol is shown on the wrong side of phone numbers
This issue was reproduced on the Flame initially.
Summary: [Nexus 5]"+" symbol is shown on the wrong side of phone numbers → "+" symbol is shown on the wrong side of phone numbers
According to comment 12 & comment 17, this bug is fixed, new bug is tracked on bug 1131246, so close this bug.
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.