[Telephony] Should set hangUpLocal on calls when we use hangUpForground and hangUpBackground

RESOLVED FIXED

Status

Firefox OS
RIL
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aknow, Assigned: aknow)

Tracking

(Blocks: 1 bug)

unspecified
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M+, b2g-v2.0M fixed, b2g-v2.2 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Comment hidden (empty)
(Assignee)

Updated

3 years ago
Summary: [Telephony] Should also set hangUpLocal on calls when we use hangUpForground and hangUpBackground → [Telephony] Should set hangUpLocal on calls when we use hangUpForground, hangUpBackground, and udub
(Assignee)

Updated

3 years ago
Summary: [Telephony] Should set hangUpLocal on calls when we use hangUpForground, hangUpBackground, and udub → [Telephony] Should set hangUpLocal on calls when we use hangUpForground and hangUpBackground
(Assignee)

Comment 1

3 years ago
Created attachment 8527493 [details] [diff] [review]
Set hangUpLocal correctly

Patch is rebased on Bug 1093014
Attachment #8527493 - Flags: review?(htsai)

Updated

3 years ago
Attachment #8527493 - Flags: review?(htsai) → review+
(Assignee)

Comment 2

3 years ago
try looks good
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=d06f95586485
(Assignee)

Comment 3

3 years ago
https://hg.mozilla.org/integration/b2g-inbound/rev/d65ddae6f151
https://hg.mozilla.org/mozilla-central/rev/d65ddae6f151
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

3 years ago
Created attachment 8539915 [details] [diff] [review]
(2.0m) Set hangUpLocal correctly
Attachment #8539915 - Flags: review+
(Assignee)

Comment 6

3 years ago
Created attachment 8539916 [details] [diff] [review]
(2.0m) Set hangUpLocal correctly. r=hsinyi
Attachment #8539915 - Attachment is obsolete: true
Attachment #8539916 - Flags: review+
(Assignee)

Updated

3 years ago
Blocks: 1108966

Updated

3 years ago
Blocks: 1054172
blocking-b2g: --- → 2.0M?

Comment 7

3 years ago
HI Kai-Zhen,
Can you help to land on 2.0M? Thanks!
blocking-b2g: 2.0M? → 2.0M+
Flags: needinfo?(kli)
https://hg.mozilla.org/releases/mozilla-b2g32_v2_0m/rev/1d24d02b6ce6
status-b2g-v2.0M: --- → fixed
status-b2g-v2.2: --- → fixed
Flags: needinfo?(kli)

Updated

3 years ago
Duplicate of this bug: 1108966
Does this need to land on v2.1? If so, please request b2g34 approval on the patch.
Flags: needinfo?(szchen)
(Assignee)

Comment 11

3 years ago
Hi Josh,
Do we need this for v2.1 as well?
Flags: needinfo?(szchen) → needinfo?(jocheng)
(Assignee)

Comment 12

3 years ago
If the calls are hungup by user, the disconnected cause for them should be "normal call clearing". That means there will be no error prompt shown on the screen.

However, there are some corner cases we didn't handed well and this patch fixed the issue. Without this fix, sometimes, when user hangup the conference call, the phone may display an incorrect error prompt.

Comment 13

3 years ago
Hi Bhavana,
I think this is severe issue fix in 2.0M and 2.1. I think we should also fix this in 2.1 or maybe 2.0. 

If you agree, bug 1089534 is also needed to work with this one. 
Please help to make the decision. Thanks!
Flags: needinfo?(jocheng) → needinfo?(bbajaj)
looks like a huge change to me, so unless we have partners filing bugs against this or qa reporting it, i'd not uplift
Flags: needinfo?(bbajaj)
You need to log in before you can comment on or make changes to this bug.