Closed Bug 1108966 Opened 7 years ago Closed 7 years ago

[FFOS2.0][Woodduck][MPTY]The MS behavior abnormal when end the MPTY call.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.0M+, b2g-v2.0 unaffected, b2g-v2.0M affected, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

RESOLVED DUPLICATE of bug 1089534
blocking-b2g 2.0M+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.0M --- affected
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected

People

(Reporter: wudduc, Assigned: aknow)

References

Details

(Whiteboard: partner_lab_only)

Attachments

(2 files)

DEFECT DESCRIPTION:
 The MS behavior abnormal when end the MPTY call.
 
  REPRODUCING PROCEDURES:
 Precondition:Insert a SIM card support MPTY call.
 ->Make an MO/MT call and establish it.
 ->Make another MO/MT call and establish it.
 ->Merge the two calls.
 ->End the MPTY call by press the end button.
 >The call screen still exist.-KO1
 >Press home key, the status bar disappear, reaccess dialer, the call screen always exist.-KO
 Remark:It is ok on sw7G18+zz. not ok on sw7G19+zz.
 
  EXPECTED BEHAVIOUR:
 MS  should behavior normal.
 >TEL:0752-2611945(61945)
No repro on:
Gaia-Rev        856863962362030174bae4e03d59c3ebbc182473
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/e40fe21e37f1
Build-ID        20141207160203
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Blocks: Woodduck
blocking-b2g: --- → 2.0M?
Keywords: qawanted
OS: Windows XP → Gonk (Firefox OS)
Hardware: x86 → ARM
Unable to repro on Flame 2.2, 2.1 and 2.0 and 2.0 base on engineering with shallow flash.
Actual result: After hanging up in a conference call, the call screen disappears.

Flame 2.2
BuildID: 20141210035415
Gaia: e17c5656dbf517d48fb61ac9bc92119e023fd717
Gecko: be1f49e80d2d
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Flame 2.1
BuildID: 20141210030111
Gaia: 4b5f2113c5f224bcd0b23187769bcaf75d52eef3
Gecko: 2db94edf4d5d
Platform Version: 34.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0
BuildID: 20141210075212
Gaia: 4887744f873c8aa1ddadd9618e9b79dac259d27d
Gecko: dec2fdd8c4fe
Platform Version: 32.0
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.0 Base
BuildID: 20141021162107
Gaia: 8c5c956ee6909408e29f375cc7d843a03d92f3d8
Gecko: 
Platform Version: 32.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
re-tagging QA-Wanted as the Woodduck device check has not yet been completed.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Blocks: Woodduck_P2
Flags: needinfo?(fan.luo)
Hi Norry, Can you try repo on Woodduck? Thanks!
Attached video Verify.mp4
The bug can't repro on Woodduck 2.0M, after tapping end call button, the call screen disappears.

Woodduck build:
Gaia-Rev        ead3b72a84512750bc5faff4e9e8faa1715c0d05
Gecko-Rev       8d40d6480ee0e628b0f7655dcd6ff79a2f2fbcfc
Build-ID        20141210050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1418159130
FW-Date         Wed Dec 10 05:05:54 CST 2014
Flags: needinfo?(fan.luo)
Hi reporter,

Please check the verify video, and confirm whether there is any different STR to repro this bug.

Thank you.
Flags: needinfo?(wudduc)
Keywords: qawanted
Hi Reporter,
We cannot repo this issue on our side. Can you try repo the issue with Mozilla Gaia/Gecko? Thanks!

Link:  http://pan.baidu.com/s/1ntBOIX7
Password:  m5s3
unzip password:  erT14moz
Flags: needinfo?(sync-1)
Priority: -- → P2
woodduck, do you still see this problem in latest build? We cannot reproduce, so could you please help test on mozilla build? You can find mozilla build in following link:

Link:  http://pan.baidu.com/s/1ntBOIX7
Password:  m5s3
unzip password:  erT14moz
Hi, I can reproduce this PR on your build and the image I test is 20141216050313.zip.
Something wrong after call telephony.conferenceGroup.hangUp() in callscreen/js/calls_hanlder.js.

I/Gecko   ( 6694): TelephonyService: handleCallDisconnected: {"state":0,"callIndex":1,"toa":129,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"10010","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isEmergency":false,"isOutgoing":true,"isConference":true,"started":1418792400172,"failCause":"UnspecifiedError"}

I/Gecko   ( 6694): TelephonyService: listener for notifyError threw an exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsITelephonyListener.notifyError]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: jar:file:///system/b2g/omni.ja!/components/TelephonyService.js :: TelephonyService.prototype._notifyAllListeners :: line 185"  data: no]
I/Gecko   ( 6694): TelephonyService: listener for notifyError threw an exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsITelephonyListener.notifyError]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: jar:file:///system/b2g/omni.ja!/components/TelephonyService.js :: TelephonyService.prototype._notifyAllListeners :: line 185"  data: no]
Attached file 1108966.log
Hi Shawn,
Can you help to check the problem per comment 11? Thanks!
Flags: needinfo?(wudduc)
Flags: needinfo?(sync-1)
Flags: needinfo?(sku)
   function endConferenceCall() {
-    var callsToEnd = telephony.conferenceGroup.calls;
-    CallScreen.setEndConferenceCall();
-    for (var i = (callsToEnd.length - 1); i >= 0; i--) {
-      var call = callsToEnd[i];
-      call.hangUp();
-    }
+    return telephony.conferenceGroup.hangUp().then(function() {
+      CallScreen.setEndConferenceCall();
+    }, function() {
+      console.error('Failed to hangup Conference Call');
+    });
   }

Don't know why this PR can't be reproduced at your side, maybe something wrong in the new added telephony.conferenceGroup.hangUp() interface in gecko/ril. And I wonder if we can revert codes above
as a temp solution for this issue.
Hi Aknow:
 Per offline talk, please help check why telephony service throw exception for NotifyError.

Thanks!!
Shawn
Flags: needinfo?(szchen)
please update status, thanks
Depends on: 1102671
Flags: needinfo?(szchen)
Not yet found the root cause, but I will suggest to land Bug 1102671 on 2.0m. The patch sets the flag "hangUpLocal" correctly when using hangUpConference.
Hi Reporter,
Can you try our patch of Bug 1102671 per comment 16 and see whether the problem is solved?
Thanks!
Flags: needinfo?(jz.zhangjin)
Whiteboard: partner_lab_only
Hi woodduck

We suspect that the root cause is Bug 1089534. I have provided a 2.0m version of patch there [1]. Could you please try the patch and let us know if it resolves the issue.

Thank you.

[1] https://bugzilla.mozilla.org/attachment.cgi?id=8540518
Assignee: nobody → szchen
Flags: needinfo?(sku)
blocking-b2g: 2.0M? → 2.0M+
(In reply to Szu-Yu Chen [:aknow] from comment #16)
> Not yet found the root cause, but I will suggest to land Bug 1102671 on
> 2.0m. The patch sets the flag "hangUpLocal" correctly when using
> hangUpConference.

Hi aknow,
   this issue seems fixed after I landed 1102671.
Flags: needinfo?(jz.zhangjin)
I'll suggest to have the patch of Bug 1089534, which is likely to be the root cause here.
(In reply to Szu-Yu Chen [:aknow] from comment #20)
> I'll suggest to have the patch of Bug 1089534, which is likely to be the
> root cause here.

Thank you Aknow,
Already make bug 1089534 2.0M+.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1102671
Duplicate of bug: 1089534
You need to log in before you can comment on or make changes to this bug.