[SIM PIN] SIM PIN dialog is not shown on startup when Lock Screen is off

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: apastor, Assigned: apastor)

Tracking

unspecified
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
On a Screen lock disabled device:

STR:

1.- Restart the phone via the Sleep menu


Expected:

The SIM PIN dialog is shown

Actual:

SIM PIN dialog is not shown

The cardstatechange events are not handled properly on restart. In case of the lockscreen, we try to show the dialog again on every unlock, so the problem is solved, but in case that is not enabled, we need to properly handle those events.
(Assignee)

Updated

5 years ago
Whiteboard: [systemsfe]
(Assignee)

Updated

5 years ago
Depends on: 1090859
(Assignee)

Comment 1

5 years ago
I forgot to mention that you need to apply this, for reproing 100% of times -> https://bug1090859.bugzilla.mozilla.org/attachment.cgi?id=8524631
(Assignee)

Updated

5 years ago
blocking-b2g: --- → 2.2?
(Assignee)

Updated

5 years ago
Assignee: nobody → apastor
Comment on attachment 8529135 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/26482

Thanks, I think it's my regression; better having unit test next time. Much better this time!
Attachment #8529135 - Flags: review?(alive) → review+
(Assignee)

Comment 4

5 years ago
Unit tests included ;)

master:https://github.com/mozilla-b2g/gaia/commit/874575b01cb7d7c9d79400406df4c499e59eac9f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 5

4 years ago
Verified the issue is fixed on 2.2 Flame

SIM PIN dialog appears for two SIM cards after rebooting when the screen is unlocked

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141202040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
==================================================================
2.1 is still affected.
Only one SIM PIN dialog appears on two SIM cards

"Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141202001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
===================================================================  
Adding "verifyme" for 2.1 patch uplift
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Depends on: 1107172
Should this be blocking v2.1 given that bug 1090859 was?
Flags: needinfo?(apastor)
(Assignee)

Comment 7

4 years ago
I'll create a 2.1 patch that includes this on Bug 1090859 (as neither of these bugs can be applied directly on the 2.1 codebase)
Flags: needinfo?(apastor)
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1098334

Comment 9

4 years ago
Posted video verify_v2.1.MP4
This issue has been verified pass on Flame v2.1
STR:
Prerequisite:Insert a SIM card with PIN.
1. Restart the phone via the Sleep menu.
**The SIM PIN dialog is shown.
See attachment:verify_v2.1.MP4
Rate:0/5

Flame 2.1 build:
Gaia-Rev        d98bbe9d2bfdb53e80dc1ab1572bd05938a85526
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/c694578ff69e
Build-ID        20150128001258
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150128.034753
FW-Date         Wed Jan 28 03:48:03 EST 2015
Bootloader      L1TC000118D0

Updated

4 years ago
You need to log in before you can comment on or make changes to this bug.