[FFOS2.0][Woodduck][costcontrol] data usage does not consider dual SIM scenario while switch sim card

VERIFIED FIXED in Firefox OS v2.0M

Status

P2
normal
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: sync-1, Assigned: mai)

Tracking

unspecified
2.2 S2 (19dec)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M+, b2g-v2.0 wontfix, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(9 attachments)

(Reporter)

Description

4 years ago
DEFECT DESCRIPTION:
 >When switching sim card, all founction on data usage settings page doesn't work.
 
  REPRODUCING PROCEDURES:
 >1)Insert two sim card and power on the phone;
 >2)Enter data usage,and click "settings" on top right corner;
 >3)Modify the setings and click "Done".It works--OK
 >4)Press "home" and go to "Settings"->SIM Manager->Data,changing to another SIM card.
 >5)Press "home" and go to "Usage",and click "settings" on top right corner;
 >6)Try to operate the fountion on the page
 find that all founction on data usage settings page doesn't work.--KO
 
  EXPECTED BEHAVIOUR:
 >It should work normally when changing sim card.

Comment 1

4 years ago
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Blocks: 1054172
blocking-b2g: --- → 2.0M?
status-b2g-v2.0M: --- → ?
Flags: needinfo?(fan.luo)
(Reporter)

Comment 2

4 years ago
PS:restart usage will be ok
Created attachment 8529564 [details]
logcat.txt

This bug can be repro on Woodduck 2.0M and Flame 2.0/2.1/2.2

Attachment: Verify.mp4 & logcat.txt
Rate: 100%
Found time:14:59

Woodduck build:
Gaia-Rev        d742e375aca6dc1bf3a36638000ad7f5338ef457
Gecko-Rev       d049d4ef127844121c9cf14d2e8ca91fd9045fcb
Build-ID        20141127050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1417035915
FW-Date         Thu Nov 27 05:05:39 CST 2014
------------------
Flame 2.0:
Gaia-Rev        f9d6e3d83c3922e9399a6c27f5ce4cdd27bdfd05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/45112935086f
Build-ID        20141126000203
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141126.032754
FW-Date         Wed Nov 26 03:28:05 EST 2014
Bootloader      L1TC00011880
------------------
FLame2.1 build:
Flame 2.1 new build:
Gaia-Rev        db2e84860f5a7cc334464618c6ea9e92ff82e9dd
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/211eae88f119
Build-ID        20141126001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141126.033519
FW-Date         Wed Nov 26 03:35:30 EST 2014
Bootloader      L1TC00011880
------------------
FLame2.2 build:
Gaia-Rev        41b7be7c67167f367c3c4982ff08651d55455373
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/ff4a63d66806
Build-ID        20141126160201
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141126.193315
FW-Date         Wed Nov 26 19:33:28 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(fan.luo)
Group: woodduck-confidential
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: ? → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected

Comment 5

4 years ago
Triage:
This is feature request which we can consider enhance in the future.

Hi Wesley,
Can you take a look at this bug as feature enhancement in future release?
Thanks!
Blocks: 1080481, 1087874
blocking-b2g: 2.0M? → backlog
feature-b2g: --- → 2.2?
Flags: needinfo?(whuang)
The initiative "Smart Data" might cover this.
NI? to Peter for confirmation of plan.
Flags: needinfo?(whuang) → needinfo?(pdolanjski)

Comment 7

4 years ago
hi guys,
what's the latest status about this PR

Comment 8

4 years ago
(In reply to wei.deng from comment #7)
> hi guys,
> what's the latest status about this PR

Hi DengWei,
This is feature request which we can consider enhance in the future but will not be able to fix in 2.0M Woodduck. Can you postpone this TC?
Flags: needinfo?(wei.deng)

Updated

4 years ago
Blocks: 1107999

Updated

4 years ago
Blocks: 1107670
(Reporter)

Comment 9

4 years ago
dear mozilla,
 
      This is the basic function issue and have bad effect on user expierence.we hope it can be fixed in 2.0M Woodduck if it's not difficult to solve it.

Updated

4 years ago
blocking-b2g: backlog → 2.0M?

Updated

4 years ago
Summary: [FFOS2.0][Woodduck][costcontrol]data usage works abnormally after switch sim card → [FFOS2.0][Woodduck][costcontrol] data usage does not consider dual SIM scenario while switch sim card

Comment 10

4 years ago
Hi Evelyn,
This is feature request per bug 1035568. 
Partner request to fix this in 2.0M. Could you help to assess whether gaia team can implement this at minimum effort?
Flags: needinfo?(wei.deng) → needinfo?(ehung)
See Also: → bug 1035568
(Reporter)

Comment 11

4 years ago
dear mozilla,
 
      i have found the bug reason.in costcontrol/js/settings/settings.js,the variable ConfigManager.configuration is null when switch sim card.i try to fix it by add a condition statement,it can roughly works now.thanks.

Comment 12

4 years ago
Ethan, please check this bug and see if you need Gaia dev's help. Thanks.
Assignee: nobody → ettseng
feature-b2g: 2.2? → 2.2+
I can reproduce this bug on Flame v2.2.

When the SIM card for data network is switched, the value of the mozSettings
|ril.data.defaultServiceId| will be changed. I think usage app should refresh its UI when this change
is observed.

Updated

4 years ago
Group: woodduck-confidential
Hi Salva,

You are much more familiar with the Gaia code in costcontrol app than I am.
Could you help to see if we can have a quick fix for this bug?
Flags: needinfo?(salva)

Comment 15

4 years ago
[Tracking Requested - why for this release]:
feature-b2g: 2.2+ → ---
tracking-b2g: --- → ?

Comment 16

4 years ago
Tzu-lin, could you check comment 13 and see if there is something you can help? Thanks.
Flags: needinfo?(ehung) → needinfo?(tzhuang)
(Assignee)

Comment 17

4 years ago
Created attachment 8534955 [details] [review]
patch v1.0

Hi Salva,
would you mind reviewing the patch?
Regards
Flags: needinfo?(salva)
Attachment #8534955 - Flags: review?(salva)
(Assignee)

Updated

4 years ago
Assignee: ettseng → marina.rodriguez.iglesias
Clear NI since :mai has patch already.
Flags: needinfo?(tzhuang)

Updated

4 years ago
blocking-b2g: 2.0M? → 2.0M+

Comment 19

4 years ago
Dear Salva,
Partner is requesting this fix urgently. Could you kindly help to review in your earliest possible? Thanks!
Flags: needinfo?(pdolanjski)
Comment on attachment 8534955 [details] [review]
patch v1.0

LGTM, but please, read the comments on GitHub and add a regression test case for this.
Attachment #8534955 - Flags: review?(salva)
(Assignee)

Comment 21

4 years ago
Comment on attachment 8534955 [details] [review]
patch v1.0

updated the pr with your comments.
Attachment #8534955 - Flags: review?(salva)
Comment on attachment 8534955 [details] [review]
patch v1.0

The tests you added cover `requestAll()` but they are not regression tests. What it is observed is that after changing the SIM to another from the same carrier, the configuration is not prooperly set. That is what we must test in a regression test. Don't remove the tests from the source code but please, add the regression test.
Attachment #8534955 - Flags: review?(salva)
(Assignee)

Comment 23

4 years ago
Comment on attachment 8534955 [details] [review]
patch v1.0

Hi Salva,
updated the pr with your comments
Attachment #8534955 - Flags: review?(salva)
Comment on attachment 8534955 [details] [review]
patch v1.0

You have a little comment on GitHub. You have the r+ after making the pointed changes. Thank you Mai.
Attachment #8534955 - Flags: review?(salva) → review+
(Assignee)

Comment 25

4 years ago
Master: a143f9e7045f56212137c1dfb0832fe0cc980b28
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Marina, Uplift to v2.0m branch got conflicts in the following files. Could you provide a patch for v2.0m? Thanks!
--
apps/costcontrol/js/app.js
apps/costcontrol/js/config/config_manager.js
status-b2g-v2.2: affected → fixed
Flags: needinfo?(marina.rodriguez.iglesias)
(Assignee)

Comment 27

4 years ago
Created attachment 8540582 [details] [review]
patch for v2.0m
Flags: needinfo?(marina.rodriguez.iglesias)
Marina, Thanks! If v2.1 also need this patch, please request for approval.
(Assignee)

Comment 30

4 years ago
Comment on attachment 8534955 [details] [review]
patch v1.0

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 
[User impact] if declined: after changing the SIM to another from the same carrier, the configuration is not prooperly set
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): Low risk, testing on device and working currently on master
[String changes made]: No
Attachment #8534955 - Flags: approval-gaia-v2.1?(release-mgmt)
Keywords: verifyme
This issue has been failed verified on Flame v2.2.
See attachments: verify_v2.2.MP4 and logcat_v2.2.txt.
Reproduce rate: 4/4.

Repro STR:
1.Power on device with two SIM cards and enable data connection.
2.Enter data usage,and click "Settings" on top right corner.
**User can modify the setings successfully.And "Data Limit(10.00MB)" prompt displays as same as Usage app.
3.Go to "Settings"->SIM Manager->Data,change to SIM2 card.
**But SIM2 card has no data connection.(at 16:41)
4.Tap on "New SIM inserted" after sliding down the notifications bar,and then click "Next".
5.Then tap "Let's go!".
**"Let's go!" button has no response(at 16:42).But user can set "Data use alert"(such as "31MB").
6.Long tap Home button and close it.
7.Open Usage from homescreen.
**SIM2 card's data usage info is shown and usage settings page works normally.
8.Slide down notifications bar.
**It displays "Data Limit(10.00MB)" prompt and inconsistent with Usage(31MB).

Flame 2.2 build:
Gaia-Rev        c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/0532f2509f3f
Build-ID        20141223010202
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141223.043429
FW-Date         Tue Dec 23 04:34:39 EST 2014
Bootloader      L1TC00011880


This issue has been successfully verified on Woodduck v2.0.
See attachment: verified_v2.0m.mp4.
Reproduce rate: 0/4

Woodduck 2.0 build:
Gaia-Rev        afa87cffbd3cd9e2070b26d45dd556a9324bd4d5
Gecko-Rev       911e6cd6aecf8d37d42c203e162847b78a68a8d8
Build-ID        20141224050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1419368730
FW-Date         Wed Dec 24 05:05:52 CST 2014
status-b2g-v2.0M: fixed → verified
Flags: needinfo?(echang)
Sorry to update woodduck's result.
Sometimes,in the step 5,when tap "Let's go!","Let's go!" button has no response(at 18:59) on woodduck 2.0(Rate:2/4).

Please see attachments:woodduck_logcat_1859.txt and verify_2.0m.MP4
status-b2g-v2.0M: verified → fixed
(Assignee)

Comment 35

4 years ago
Hi shally,  
The behavior of the Comment 31 is a different bug. Please, would you mind addressing a new bug for the "let's go" button.
Regards
status-b2g-v2.0M: fixed → verified
Created attachment 8541220 [details]
woodduck_logcat_1859.txt
status-b2g-v2.0M: verified → fixed
status-b2g-v2.0M: fixed → verified
(In reply to Marina Rodríguez [:mai] from comment #35)
> Hi shally,  
> The behavior of the Comment 31 is a different bug. Please, would you mind
> addressing a new bug for the "let's go" button.
> Regards

ok,thanks!
Hi Sally, Please cc or ni me of the new bug, thank you.
Flags: needinfo?(echang) → needinfo?(lixia)
Hi Eric,
  The new bug about "Let's go!" button is 1115509.
Flags: needinfo?(lixia) → needinfo?(echang)
Thanks!
Flags: needinfo?(echang)

Updated

4 years ago
Attachment #8534955 - Flags: approval-gaia-v2.1?(release-mgmt) → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/73be51f998031f06db0cd660c0e388fa621c9f4c
status-b2g-v2.0: affected → wontfix
status-b2g-v2.1: affected → fixed
Target Milestone: --- → 2.2 S2 (19dec)
This issue has been successfully verified on Flame v2.1&2.2.
See attachment: verified_v2.1.mp4.
Reproduce rate: 0/4.

Flame 2.1 build:
Gaia-Rev        73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ea426e47bfc4
Build-ID        20141228001253
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141228.034827
FW-Date         Sun Dec 28 03:48:38 EST 2014

Flame 2.2 build:
Gaia-Rev        3554ea9504046646b4679e3a61317c49fc55ca87
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/67c42c076393
Build-ID        20141228010205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141228.045435
FW-Date         Sun Dec 28 04:54:46 EST 2014
Bootloader      L1TC00011880

Note:The new bug about "Let's go" button still exists.
Status: RESOLVED → VERIFIED
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Keywords: verifyme

Comment 45

4 years ago
Hi Marina,
Per https://bugzilla.mozilla.org/show_bug.cgi?id=1035568#c2 Currently it reports sum up for both cards. Partner feedback that user will not able to identify which card already over his/her budget. Should we revise the behavior to clean old usage data when user switch to new SIM card?
Thanks!
Flags: needinfo?(marina.rodrigueziglesias)
(Assignee)

Comment 46

4 years ago
Hi Josh, 
I think your question is for UX.
NI to Juwei
Flags: needinfo?(marina.rodrigueziglesias) → needinfo?(jhuang)

Comment 47

4 years ago
NI myself for tracking
Flags: needinfo?(jocheng)

Comment 48

4 years ago
Dear Juwei,
Could you please provide spec for what is the correct behavior for usage app?
Thanks!

Comment 49

4 years ago
Hi Josh,
I used to memorize that when people switch SIM card, the app should report the data usage of one SIM only instead of a sum up for all SIM cards?
As you said,revise the behavior to clean old usage data would be make more sense.
Flags: needinfo?(jhuang)

Comment 50

4 years ago
Dear Marina,
Can you confirm this is the current behavior as described by JuWei?
Thank you very much!
Flags: needinfo?(jocheng) → needinfo?(marina.rodrigueziglesias)
(Assignee)

Comment 51

4 years ago
Hi Josh,
Currently costcontrol shows always the traffic of the selected data sim and the wifi traffic. I thought that your question is about how identify which card is the active. If the user see the sum of both simcards, it's a bug.

Regards
Flags: needinfo?(marina.rodrigueziglesias)

Comment 52

4 years ago
Hi Marina,
According to https://bugzilla.mozilla.org/show_bug.cgi?id=1035568#c2
The current behavior does show sum of both SIM cards as you mention should be a bug. Can you fix this on bug 1117454? Thanks!
Flags: needinfo?(marina.rodrigueziglesias)

Updated

4 years ago
tracking-b2g: ? → ---
(Assignee)

Updated

4 years ago
Flags: needinfo?(marina.rodrigueziglesias)

Updated

3 years ago
Blocks: 1179745

Updated

3 years ago
No longer blocks: 1179745
You need to log in before you can comment on or make changes to this bug.