Can open utility tray and settings app while SIM PIN dialog is open

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mikehenrty, Assigned: mikehenrty)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1089010 +++

This bug is happening on master and v2.1 again, so rather than re-opening bug 1089010, I just cloned it here. I'm going to try and find the regressing patch.

STR:

1.) Enabled SIM PIN on sim card
2.) Open SIM PIN dialog (one way is to lock then unlock the phone)
3.) Pull down utility tray
4.) Click on Settings Icon

Expected result:
Either utility tray should not be opened at all, or the user should not be able to open settings app

Actual result:
The settings app opens in the background underneath the SIM PIN dialog, which can change the color of the statusbar and look really janky.
Yup, indeed this was broken when bug 1062819 landed. I think bug 1062819 just didn't port the fix from bug 1089010 in [1]. I can look into this.
Assignee: nobody → mhenretty
Just to clarify, this is NOT happening on 2.1 as my description suggests. Let's block on this for 2.2.
blocking-b2g: --- → 2.2+
Uh, my fault.. lemme know if you need my help
Is this still happening?
(In reply to Gregor Wagner [:gwagner] from comment #4)
> Is this still happening?

Yes, this is still happening.
Created attachment 8536984 [details] [review]
[Gaia PR] backport bug 1089010
Attachment #8536984 - Flags: review?(alive)
Comment on attachment 8536984 [details] [review]
[Gaia PR] backport bug 1089010

I wonder if we have the same issue if dialer/message is trying to launch themselves by mozApps.getSelf when SIM PIN dialog is opened :/
Attachment #8536984 - Flags: review?(alive) → review+
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #7)
> Comment on attachment 8536984 [details] [review]
> [Gaia PR] backport bug 1089010
> 
> I wonder if we have the same issue if dialer/message is trying to launch
> themselves by mozApps.getSelf when SIM PIN dialog is opened :/

We might, but in this case it is ok for the SIM PIN dialog to stay opened, since both of those apps will open the SIM PIN anyway if the SIM is locked.
master: https://github.com/mozilla-b2g/gaia/commit/d22dfece04fc00457e8369c660c11f945b088d2f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
This issue is verified fixed on Flame 2.2.

Result: The Settings app appears when the user selects the settings icon from the utility tray, instead of opening underneath the SIM PIN screen. However, there is a couple seconds of delay, and the animation issue still exists as filed in bug 1095082.

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141218040201
Gaia: 58734e8a48157f99d5b733412b600c2e04c954fe
Gecko: 5c7a6294b82a
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.