Temporarily disable Unified Complete due to regressions

RESOLVED FIXED in Firefox 36

Status

()

Firefox
Location Bar
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

unspecified
Firefox 36
Points:
1
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

3 years ago
Due to the tracked regressions the locationbar is not very usable in Nightly, we are going to disable unified until these tracked regressions are handled.

We prefer doing this rather than a backout cause most of the unified complete project is blocked by the fixes causing these regressions, and backing those out would have a large cost (easy bitrotting, hard to work on top of long queue of patches, other dependencies...)
(Assignee)

Updated

3 years ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Points: --- → 1
Flags: qe-verify-
(Assignee)

Updated

3 years ago
Flags: firefox-backlog+
(Assignee)

Comment 1

3 years ago
Marco please add this to the current iteration
Flags: needinfo?(mmucci)
Added to IT 37.1
Iteration: --- → 37.1
Flags: needinfo?(mmucci)
(Assignee)

Comment 3

3 years ago
https://hg.mozilla.org/mozilla-central/rev/daf6fc0b0195
Target Milestone: --- → Firefox 36
(Assignee)

Comment 4

3 years ago
follow-up because of bug 1090913 that would have disallowed us to safely merge to Aurora too (it will be lot of fun), plus Bug 1104755 (test timeout), plus browser_autocomplete_autoselect.js not being skipped when unified is disabled, plus browser_urlbarAutoFillTrimURLs.js being wrong when unified is disabled

https://hg.mozilla.org/mozilla-central/rev/ff4a63d66806

I hope now central will be green and we can merge to Aurora...
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Depends on: 1105772

Updated

2 years ago
Depends on: 1254503
(Assignee)

Updated

2 years ago
No longer depends on: 1254503
You need to log in before you can comment on or make changes to this bug.