Search Engine Keywords seems not to work in Nightly 36.0a1 (2014-11-26)

RESOLVED WORKSFORME

Status

()

Firefox
Location Bar
P1
normal
Rank:
4
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Raphy, Unassigned)

Tracking

36 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxsearch][unifiedautocomplete])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141126030207

Steps to reproduce:

I have different search engines given a keyword, such as Google, Wikipedia or Dict. When using them before the today's update they worked correct, after the update the keywords are ignored and instead part of the search term with my active search engine. I searched with those keywords today before and after the update. I also restarted Firefox just in case.


Actual results:

e.g. searching for "G foobar" in the address bar resulted in an Wikipedia search (which is my active standard atm.).


Expected results:

Instead of the Wikipedia result, I should get a Google-search for "foobar".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1105385
do you mean you set a keyword for the search engine in the Search engines management panel?

If so, this may not be a dupe of bug 1105385 that refers to bookmarks keywords afaict.
for now I'm de-duping to be sure we track everything.
Blocks: 995091
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Updated

3 years ago
Component: Untriaged → Location Bar
(Reporter)

Comment 4

3 years ago
> do you mean you set a keyword for the
> search engine in the Search engines
> management panel?
Indeed, that was what I've done. Until now, I didn't set any keywords for any bookmarks I've made so far, just for the search engines in the management panel.

> If so, this may not be a dupe of
> bug 1105385 that refers to
> bookmarks keywords afaict.
As I understand your posted bug, it doesn't seem so. I also reported this bug to Dennis Schubert directly, you may or may not know him. Unfortunately he couldn't reproduce the bug and told me to open up this bug ticket. In the mean time I tried this at my other PC and had the same issue there, with the same Firefox version but on Win8.

Comment 5

2 years ago
Do you by chance you my Keyword Search addon?
Blocks: 1157952
Whiteboard: [fxsearch][unifiedautocomplete]
Priority: -- → P1
Flags: firefox-backlog+
I can't reproduce this one either. I've added the youtube search engine with a keyword of "yt".  If the URLBar has "yt " it offers to search for "yt " using my default provider - but as soon as I add search terms (eg, "yt foo") it changes to "Search with YouTube" and shows the youtube icon. Pressing enter then executes the search on youtube as expected.

(It looks like a minor bug that YouTube isn't offered as soon as "yt" or "yt " is entered, but it waits until a search term is entered, but that doesn't sound like what this bug is about)
(In reply to Mark Hammond [:markh] from comment #6)
> (It looks like a minor bug that YouTube isn't offered as soon as "yt" or "yt
> " is entered, but it waits until a search term is entered, but that doesn't
> sound like what this bug is about)

This is actually expected cause we match a search only if there are search terms, otherwise we "ignore" the alias

Updated

2 years ago
Rank: 4
Just tried again, and it continues to work as expected for me. Please reopen if you believe I've closed this in error.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.