Closed Bug 1105696 Opened 7 years ago Closed 7 years ago

(status-bar-rtl) [RTL] Rocketbar doesn't work on RTL languages

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v2.2 verified, b2g-master verified)

VERIFIED DUPLICATE of bug 1033917
2.2 S1 (5dec)
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: apastor, Assigned: apastor)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

STR:

1.- Set up the phone with a RTL language
2.- Open Settings
3.- Click on the rocketbar

Expected:

The rocketbar should open

Actual

Does nothing
Assignee: nobody → apastor
Comment on attachment 8531685 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/26609

I think we need to check a different element. Re-flag me when ready.
Attachment #8531685 - Flags: review?(kgrandon)
Comment on attachment 8531685 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/26609

Thanks!
Attachment #8531685 - Flags: review?(kgrandon)
Comment on attachment 8531685 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/26609

Seems good to me. Thanks!
Attachment #8531685 - Flags: review?(kgrandon) → review+
master: https://github.com/mozilla-b2g/gaia/commit/f7960774b873997a1178ce46855f6605addff020
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Depends on: 1109539
backout: https://github.com/mozilla-b2g/gaia/commit/350ab351653d77de9030c520aea1108966c1f1d0
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I see Rocketbar working on Flame 2.2, but the "hitbox" stays on default left side (area where Rocketbar was located before RTL). Tapping area to left of Rocketbar (not on search box) will open rocketbar.
NI : Alberto, not sure why this was backed out, if its close to getting done, can we please get this re-landed on master and uplifted on 2.2 as well ? Thanks!
Flags: needinfo?(apastor)
Now that RTL is a priority again, I'll take it next. Should be done this week. Thanks!
Flags: needinfo?(apastor)
It seems that this has been already fixed by 1033917. I tested it in both master and 2.2 and is working fine.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1033917
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15555/
Flags: in-moztrap+
Per comment 10 and my own verification, this bug is fixed now, Click on the rocketbar in Settings, rocketbar is opened and the hit text is right-aligned.
so I mark it as “VERIFIED DUPLICATE”.

Device information:
Flame KK v2.2 build ID:20150730032503
Flame KK V2.5 build ID: 20150730150205
N5 v2.2 build ID:20150730032503
N5 v2.5 build ID:20150730150205
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.