[RTL][FTE] Icons are overlapping text on the "Import contacts" screen

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::First Time Experience
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: sarsenyev, Assigned: autra)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8533285 [details]
log12082014

Description:
in FTE, when selecting RTL language the "Import contacts" icons are overlapping text
   
Repro Steps:
1) Update a Flame device to BuildID: 20141208040202
2) Select "Arabic" language in FTU or pseudo-localization "mirrored English" from "Developer" option
3) Navigate to the "Import contacts" screen
4) Observe the icons
  
Actual:
The icons are overlapping the text
  
Expected: 
The icons are NOT overlapping the text
  
"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141208040202
Gaia: 0e429d970c160e580e19e61ad8ff5612de159f00
Gecko: c4c7442e9113
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0"
  
 
Repro frequency: 100%
See attached: logcat, screenshot
(Reporter)

Comment 1

3 years ago
Created attachment 8533286 [details]
2014-12-08-14-44-35.png

The issue doesn't apply for 2.1 and 2.0
RTL language is target only for 2.2
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
Flags: needinfo?(dharris)
Delphine could you take a look at this for a blocking decision?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?(lebedel.delphine)
Thanks Derek. We just learned that RTL would not block on 2.2 testing, until further notice.
Please do not block on this. thanks
Flags: needinfo?(lebedel.delphine)
Blocks: 906270
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][rtl-impact]
Blocks: 1101112
No longer blocks: 906270
Leaving a NI to check if this is fixed in the latest build, else we must block 2.2.
Flags: needinfo?(lebedel.delphine)
Priority: -- → P1
Created attachment 8552039 [details]
Fixed2.2.png
Flags: needinfo?(lebedel.delphine)
I confirm that this is fixed on 2.2 (attached screenshot)
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5d7497ce4cc7
Build-ID        20150120002507
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880

Current Master (v3.0) looks good as well
Gaia-Rev        a5c5ac093814a80b0627514c3bd5f9e96c096a4b
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/c1c6840d9255
Build-ID        20150120010227
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  40
FW-Date         Tue Oct 21 15:5
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → verified
status-b2g-master: --- → verified
Resolution: --- → WORKSFORME
Wait- so sorry, I wasn't in FTE.
This is still broken during FTE, so reopening Sorry for the noise!
Status: RESOLVED → REOPENED
status-b2g-v2.2: verified → affected
status-b2g-master: verified → ---
Resolution: WORKSFORME → ---
Therefore requesting to block on this one, as it's pretty bad
blocking-b2g: --- → 2.2?
Whiteboard: [systemsfe]
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
blocking-b2g: 2.2? → ---
feature-b2g: --- → 2.2+
Francisco, should this be a contacts bug?
Flags: needinfo?(francisco)
Hi Michael,

sure, we can take care of it in contacts.
Component: Gaia::First Time Experience → Gaia::Contacts
Flags: needinfo?(francisco)
(Assignee)

Comment 12

3 years ago
Created attachment 8556529 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27785

Hi!

This little CSS fix should do the trick :-)
Attachment #8556529 - Flags: review?(francisco)
Assignee: nobody → augustin.trancart
(Assignee)

Comment 13

3 years ago
Btw, I didn't really understand why it is flagged as Gaia::Contacts. This page (and thus the CSS) is in FTE app, so it should be fixed in FTE right?
Flags: needinfo?(francisco)
Hi Augustin,

it's related to contacts cause it's used in both contacts and ftu, and originally come from contacts.
Flags: needinfo?(francisco)
uuups, definitely, after reading carefully the title, it's not about the importing screens, which are shared, but about the screen IN the ftu.

So Augustin, you are totally right, will move this to the ftu component, anyway I can continue with the review :)
Component: Gaia::Contacts → Gaia::First Time Experience
Comment on attachment 8556529 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27785

Nice :)
Attachment #8556529 - Flags: review?(francisco) → review+
Keywords: checkin-needed
Was just going to grab this bug but you beat me to it. LGTM. I dont see a Try run associated with this pull request. :autra can you rebase and force push to see if the hook will pick it up?
Flags: needinfo?(augustin.trancart)
(Assignee)

Comment 18

3 years ago
Hi Sam!

Done. I can't clear the needinfo though (I don't have enough permissions to do so, it seems).
Merged to master: https://github.com/mozilla-b2g/gaia/commit/d4f9aee7fdc2212ce69193eac3caee19bd65adcf
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(augustin.trancart)
Resolution: --- → FIXED
Comment on attachment 8556529 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27785

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): FTU (RTL)
[User impact] if declined: In RTL language, icons and labels are overlapped on import contacts screen
[Testing completed]: On device, Gaia-Try
[Risk to taking this patch] (and alternatives if risky): very low, CSS-only, FTU-only fix
[String changes made]: None
Attachment #8556529 - Flags: approval-gaia-v2.2?
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15472/
Flags: in-moztrap+
status-b2g-master: --- → fixed
Keywords: checkin-needed
Target Milestone: --- → 2.2 S5 (6feb)

Updated

3 years ago
Attachment #8556529 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Duplicate of this bug: 1128446
v2.2: https://github.com/mozilla-b2g/gaia/commit/abdf71838164e11f67427b23eff643bbcbdebc5f
status-b2g-v2.2: affected → fixed

Comment 24

3 years ago
Created attachment 8558882 [details]
verify.png

This issue has been verified successfully on Flame 2.2/3.0
Steps:
1. Select "Arabic" language in FTU
2. Navigate to the "Import contacts" screen
3. Observe the icons
**The icons are NOT overlapping the text.
See attachment:verify.png
Rate:0/5

Flame 2.2 build:
Build ID               20150203162505
Gaia Revision          3161b65189cb1d7d30f01e599d75e190434ad90b
Gaia Date              2015-02-03 14:27:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a4028c388cff
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150203.200315
Firmware Date          Tue Feb  3 20:03:26 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150203055658
Gaia Revision          ae5a1580da948c3b9f93528146b007fc4f6a712b
Gaia Date              2015-02-02 19:50:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ae5d04409cd9
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150203.093120
Firmware Date          Tue Feb  3 09:31:32 EST 2015
Bootloader             L1TC000118D0

Updated

3 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.