Closed Bug 1109001 Opened 5 years ago Closed 5 years ago

[Tablet] Unfocused tab in the tab strip is black

Categories

(Firefox for Android :: General, defect, P1)

37 Branch
All
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 37
Tracking Status
firefox34 --- unaffected
firefox35 --- unaffected
firefox36 --- verified
firefox37 --- verified
fennec 36+ ---

People

(Reporter: u421692, Assigned: lucasr)

References

Details

(Keywords: regression)

Attachments

(2 files)

Environment:
Device: Nexus 5 (Android 5.0.1) ; Asus Transdormer Pad TF300T (Android 4.2.1)
Build: Firefox 37.0a1 (2014-12-08) with the new tablet UI

Steps:
1. Open Firefox
2. Add tab

Expected result:
The tabs look fine

Actual result:
The unfocused tab is black. The same thing in private browsing (See attached screenshot)

Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=5e7d215f4357&tochange=82c71c7d725c

Possible regression from Bug 1107698 - Fix setAlpha in ResizablePathDrawable
Priority: -- → P1
tracking-fennec: --- → ?
Mike, looks like a regression from bug 1107698. Can you have a look?
Assignee: nobody → michael.l.comella
Assignee: michael.l.comella → lucasr.at.mozilla
Comment on attachment 8533809 [details] [diff] [review]
Only set alpha on non-transparent colors in shaped drawable (r=mcomella)

Let's skip the alpha update if the shape color is transparent.
Attachment #8533809 - Flags: review?(michael.l.comella)
Comment on attachment 8533809 [details] [diff] [review]
Only set alpha on non-transparent colors in shaped drawable (r=mcomella)

Review of attachment 8533809 [details] [diff] [review]:
-----------------------------------------------------------------

Seems reasonable to me!
Attachment #8533809 - Flags: review?(michael.l.comella) → review+
https://hg.mozilla.org/mozilla-central/rev/e15dfc5e7381
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
Verified as fixed on latest Nightly on Nexus 7 (Android 5.0.1) and Asus Transformer Pad TF300T (Android 4.2.1)
Status: RESOLVED → VERIFIED
tracking-fennec: ? → 36+
I'm reproducing this issue on Aurora if I open a new tab from the context menu.
It's because the fix from this bug was not uplifted to Aurora, and the patch from Bug 1107698 was uplifted to Aurora.

Not Reproducible on Aurora 36.0a2 (2014-12-15)
Reproducible on Aurora 36.0a2 (2014-12-16)
Sounds like this is incorrectly set and we should uplift this.
At the time this bug was fixed an verified on Nightly, this issue wasn't affecting Aurora, the status flag was set correctly.
Comment on attachment 8533809 [details] [diff] [review]
Only set alpha on non-transparent colors in shaped drawable (r=mcomella)

Approval Request Comment
[Feature/regressing bug #]: Bug 1107698
[User impact if declined]: Bad UI
[Describe test coverage new/current, TBPL]: Verified on Nightly
[Risks and why]: Low
[String/UUID change made/needed]: none
Attachment #8533809 - Flags: approval-mozilla-aurora?
Attachment #8533809 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on Firefox 36 Beta 1;
Device: Asus Transformer Tab (Android 4.0.3).
Verified as fixed on build 37.0a2 (2014-01-14);
Device: Asus Transformer Tab (Android 4.0.3).
You need to log in before you can comment on or make changes to this bug.