[EME] Refactor GMPInstallManager.jsm et al to support both GMPs and CDMs

RESOLVED DUPLICATE of bug 1089867

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 1089867
4 years ago
3 years ago

People

(Reporter: Dolske, Assigned: MattN)

Tracking

({meta})

unspecified
Points:
---
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Most of what we want to do for EME/CDM/DRM support is identical to what was implemented for GMP/OpenH264...

  * Install (and update) binary code hosted by a 3rd party, with signatures
    approved/verified by Mozilla.
  * Treat that code as a plugin listed in the addon manager
  * Allow disabling/enabling each item
  * Display associated metadata / links so the user can learn what it is.

We'd basically like to allow CDMs to be another flavor of this, but the existing code appears to be firmly tied to the specifics of OpenH264. We should refactor this code to be a little more generic, so that we can reuse it for both CDMs, OpenH264, and variations thereof.

This is a metabug for tracking that work. Details TBD.

This involves  EME/CDM/DRM user stories in:
  * bug 1089867 (download CDMs)
  * bug 1089868 (update CDMs)
  * bug 1089873, bug 1089882 (user info about EME)
  * bug 1089877 (show installed CDMs)
  * bug 1089879 (disable CDMs)
  * bug 1089876 (globally disable DRM)
  * bug 1089887, bug 1089888 (Mozilla management of CDM metadata)
(Reporter)

Updated

4 years ago
Blocks: 1083662
(Reporter)

Comment 1

4 years ago
(Hmm, it appears bsmedberg's team has already started this in bug 1089867, will talk with him to understand how to split this work.)
Summary: [EME} Refactor GMPInstallManager.jsm et al to support both GMPs and CDMs → [EME] Refactor GMPInstallManager.jsm et al to support both GMPs and CDMs
Did the work splitting here end up getting sorted out?
Flags: needinfo?(dolske)
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Iteration: --- → 38.1 - 26 Jan
Flags: qe-verify-
Flags: firefox-backlog+

Comment 3

4 years ago
Matt, please talk to spohl about this, since I think he has most or all of the work done already in bug 1089867. There may be some addon manager UI pieces to complete, but spohl had to patch the provider to get the GMPs enabled so there may not be much left.
Yes, please don't spend any time on this just yet. I have a massive refactor incoming, but wanted to give it some sanity testing before uploading it to bug 1089867. I'm planning to upload my work in progress tonight to pick up any feedback that there may be already.
Okay, sounds good.
(Reporter)

Updated

4 years ago
Flags: needinfo?(dolske)

Updated

4 years ago
Iteration: 38.1 - 26 Jan → ---
(Reporter)

Comment 6

3 years ago
Update from previous discussion with Matt et al:

Sounds like the work in bug 1089867 largely handles everything that was needed here. So the plan is to let that bug land (which should happen in the next week), dupe this one over, and double-check the user stories from comment 0 here to make sure nothing fell through the cracks. (And if something got missed, we'll file new bugs.)
I filed bug 1129219 for a Learn More link for CDMs in the add-ons manager since bug 1089867 doesn't implement that. Bug 1086668 is also in AOM code but mostly isn't UI related so isn't blocking bug 1083662.

I think bug 1089887 is covered by existing bugs but I needinfo'd spohl to double-check.

Bug 1089873 isn't related to the AOM but should come out of bug 1095734 and implemented in bug 1083662 dependencies.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089867
You need to log in before you can comment on or make changes to this bug.