[e10s] Black Screen on Google Maps

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: cmtalbert, Assigned: jrmuizel)

Tracking

(Blocks 1 bug)

Trunk
x86_64
Windows 8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm5+)

Details

Attachments

(2 attachments)

Posted image blackscreen_maps.png
1. Browse to google maps
2. Do a search for a place, I used: Irving, TX, hit enter
3. I see the place I searched for show up briefly, and then the tab goes black

= Expected = 
Google maps should just work

This is a recent regression. It regressed between Dec 9 and Dec 10 nightlies: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f1f48ccb2d4e&tochange=5b01216f97f8

It happens on a clean profile, every single time.  Here is my about:support graphics info:
Graphics
--------

Adapter Description: Intel(R) HD Graphics Family
Adapter Drivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
Adapter RAM: Unknown
Device ID: 0x0a16
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17111)
Driver Date: 8-5-2014
Driver Version: 10.18.10.3907
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 221417aa
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
I expect this is probably a dup of bug 1109718
Depends on: 1109718
Assignee: nobody → jmuizelaar
Does your machine have an Nvidia card at all?
Flags: needinfo?(ctalbert)
I can only reproduce with e10s ON, AMD Radeon R7 200 Series GPU, 37.0a1 (2014-12-17) Win 7
Can you give the version of your d3d11.dll?
6.2.9200.16570
Jeff, no Nvidia card in my system at all. My d3d11.dll version is: 6.3.9600.17041
Flags: needinfo?(ctalbert)
(In reply to Jeff Muizelaar [:jrmuizel] from comment #1)
> I expect this is probably a dup of bug 1109718

One thing that's interesting about that is that I don't even see the cube on this machine in its current configuration with e10s on. But if I turn *off* e10s, I see both the cube and google maps. So I confirm comment 3 about this only repro'ing with e10s on. 

Looking over the comments in bug 1109718, it looks like these are separate issues because over there Vladan is saying that he has issues when e10s is off.

Because this seems to be related to e10s, marking that in the summary.
Blocks: e10s
Summary: Black Screen on Google Maps → [e10s] Black Screen on Google Maps
Posted file support.txt
I can reproduce this, here's my support doc.
Does this still reproduce on latest trunk?
This was broken yesterday, today it's fixed.

37.0a1 (2014-12-18)
Clint, is it also fixed for you?
Flags: needinfo?(ctalbert)
Duplicate of this bug: 1112685
I am experiencing the same problem - can submit screen shot - and one related; in that scrolling with the mouse wheel also creates a black screen.  I have the latest version of Firefox, running on an ASUS motherboard with an AMD A10-7850 APU, an AMD Radeon 2700 GPU (co-processor enabled), 32 GB RAM and Win7 OS 64-bit.  Thought it was my hardware but I see others are experiencing this too.
I'm getting the Google Maps black screen too.  I also get things like text boxes turning black although this is very intermittent.

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:37.0) Gecko/20100101 Firefox/37.0

Graphics
--------

Adapter Description: AMD Radeon HD 7900 Series
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 3072
ClearType Parameters: D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 50 Enhanced Contrast: 100 ]
Device ID: 0x6798
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17415)
Driver Date: 11-20-2014
Driver Version: 14.501.1003.0
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 00000000
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 7900 Series Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Regression window
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6f49eb8f1ee0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20141209152045
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a790927adb60
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20141209152944
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6f49eb8f1ee0&tochange=a790927adb60
Supect: Bug 1079398


Fixed window
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/358dc1ca192b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20141217113949
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9bfe7b78b4c5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20141217121549
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=358dc1ca192b&tochange=9bfe7b78b4c5
fixed by:
9bfe7b78b4c5	Jeff Muizelaar — Bug 1112728. Temporarily disable keyedmutex usage with ANGLE until we can make it work better. We can turn this back on once we have a proper fix for bug 1109718.


Re-regression  window
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/68aa6c741e27
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20141227210313
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8d5da151b0df
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20141227211230
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=68aa6c741e27&tochange=8d5da151b0df
Regressed by:
  8d5da151b0df	Jeff Muizelaar — Bug 1112780. Recreate the RenderTargetView on demand. r=jgilbert This avoids reusing the RenderTargetView across AcquireSync/ReleaseSync pairs and fixes bug 1109718. It adds a ReleaseSync call to ANGLE that causes it to invalidate the RenderTargetView.

About re-regression, Filed Bug 1117271
Blocks: 1079398
(In reply to Jeff Muizelaar [:jrmuizel] from comment #11)
> Clint, is it also fixed for you?

This is NOT fixed for me in today's Jan 5, 2015 nightly, running in E10S mode. This nightly is built from: https://hg.mozilla.org/mozilla-central/rev/636498d041b5
Flags: needinfo?(ctalbert)
Blocks: 1111396
(In reply to Clint Talbert ( :ctalbert ) from comment #16)
> (In reply to Jeff Muizelaar [:jrmuizel] from comment #11)
> > Clint, is it also fixed for you?
> 
> This is NOT fixed for me in today's Jan 5, 2015 nightly, running in E10S
> mode. This nightly is built from:
> https://hg.mozilla.org/mozilla-central/rev/636498d041b5

Your build does not include the patch yet.

You should try with latest m-c tinderbox build.
Flags: needinfo?(ctalbert)
Thanks for the ping Alice. It does look like the patch in bug 1112780 fixed this for me as well.

Moving this to fixed, and marking the dependency.
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: 1112780
Flags: needinfo?(ctalbert)
Resolution: --- → FIXED
Blocks: e10s-gfx
No longer blocks: 1111396
You need to log in before you can comment on or make changes to this bug.