Integrate Lightning Into Thunderbird by Default

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: rkent, Unassigned)

Tracking

({feature, meta, user-doc-needed})

Trunk
feature, meta, user-doc-needed
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird38+ fixed)

Details

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #401779 +++

(Deferring to the OP of bug 401779)

Integrate Lightning into the shipping configuration of Thunderbird, but disabled by default.

Updated

4 years ago
Depends on: 1130852

Comment 1

4 years ago
Have you considered just adding a more-prominent link to Lightning instead of actually shipping the .xpi? That would make it easier for us to reuse this code for other add-ons we'd like to promote (e.g. Thunderbird Conversations).
We've considered a few options, ranging from full integration to opt-in download. Check out the etherpad and feel free to leave a comment.

https://calendar.etherpad.mozilla.org/thunderbird-integration
(Reporter)

Updated

4 years ago
tracking-thunderbird38: --- → +

Comment 3

4 years ago
Philipp, should this bug be Assigned to somebody? It appeared to me there is some work going on already? The xpi is to be shipped with TB38, just some UI announcing its existence is to be done?
This is mostly the meta bug, we are handling the work in dependencies. Therefore its not needed to assign it to someone.
Keywords: meta
(Reporter)

Comment 5

4 years ago
I'm going to call this done since we just checked all of this in.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-thunderbird38: --- → fixed
Resolution: --- → WORKSFORME

Updated

4 years ago
Blocks: 516026
Keywords: user-doc-needed

Comment 6

3 years ago
I have just updated to TB 38.0.1 release version. My previous setup was:

- Thunderbird 31.7.0
- Lightning 3.3.3
- Lightning Button 1.5.3

After the update the calendar is broken with error message: Mismatching Lightning Version ... You currently have Lightning 4.0.0.1 installed, but you should be using a version from 4.0 series.

I have tried to remove it and install it via Get Add-ons but it offers 3.3.3 version only that is not available for TB 38.0.1. There is a lot of errors in Error Console related to calendar, it looks like the Thunderbird profile is corrupted at all by the update (I have backup).
I've replied via email, lets take care there. I'll post results in case something needs to be done.

Comment 8

3 years ago
Sorry for false report. After rolling back to 31.7.0 and restoring profile I got more descriptive error message, it was permission issue when loading calbasecomps.dll. It is probably related to Software Restriction Policy rule on extensions subfolder allowing to load executable code from user's profile (that's unwanted in most cases). After re-appying the TB update it works now.

Still the message box error was misleading because no version was actually loaded.

Comment 9

3 years ago
I've just updated to 38.0.1 and now Lightning has stopped working. I've tried to remove the add on and re-add it. 
Error console shows a load of errors along the lines of:

Error: 1434621410154	addons.xpi	ERROR	Failure moving C:\Users\xyz\AppData\Roaming\Thunderbird\Profiles\vvwehnt4.default\extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103}\defaults\preferences\lightning.js to C:\Users\xyz\AppData\Roaming\Thunderbird\Profiles\vvwehnt4.default\extensions\trash\{e2fda1a4-762b-4020-b5ad-a41df1933103}\defaults\preferences
Source File: resource://gre/modules/Log.jsm
Line: 749


Is there a solution?
Can you manually remove C:\Users\xyz\AppData\Roaming\Thunderbird\Profiles\vvwehnt4.default\extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103} and C:\Users\xyz\AppData\Roaming\Thunderbird\Profiles\vvwehnt4.default\extensions\trash\{e2fda1a4-762b-4020-b5ad-a41df1933103} in the windows explorer, then start Thunderbird and re-install Lightning? This will likely fix it.

Comment 11

3 years ago
Hi Philipp, I tried removing the files and it didn't work. Tried again and also removed {e2fda1a4-762b-4020-b5ad-a41df1933103}.json and this time it let me resintall. Happily the Google Calendar provider still worked fine as well.

Thanks for you help!
You need to log in before you can comment on or make changes to this bug.