Integrate Lightning Into SeaMonkey by Default and Ship SeaMonkey with Lightning Enabled

VERIFIED FIXED in seamonkey2.46

Status

--
enhancement
VERIFIED FIXED
9 years ago
13 days ago

People

(Reporter: worcester12345, Assigned: adriank)

Tracking

({calendar-integration})

Trunk
seamonkey2.46
calendar-integration
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.44 fixed, seamonkey2.45 fixed, seamonkey2.46 fixed)

Details

User Story

Main Thunderbird work was done in bug 1130854 and dependent bugs
----------------------------------------------------------------
http://logs.glob.uno/?c=mozilla%23seamonkey&a=date&s=Yesterday&e=Today&h=#c641038

12:31	Fallen	Ratty: so in the best case its just a few lines in the mozconfigs to enable calendar and a few lines in package-manifest.in to ship it
12:32	Ratty	Fallen: oh good.
12:32	Fallen	I think you might also have to hook some targets like I did in the locales directory too
12:32	Ratty	Fallen: link to your patches?
12:32	Fallen	but be careful to not hook into the upload target so it doesn't overwrite the Lightning builds from Thunderbird.
12:32	Fallen	yes, sec
12:33	Fallen	main Thunderbird work was done in bug 1130854 and dependent bugs
12:33	Fallen	then there is the locales code at http://mxr.mozilla.org/comm-centra...ce/mail/locales/Makefile.in#200

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090910 SeaMonkey/2.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090910 SeaMonkey/2.0pre

This is the SeaMonkey version of  Bug 401779 -  Ship Thunderbird with integrated Lightning on as default

Reproducible: Always

Steps to Reproduce:
1. Download SeaMonkey
2.
3.
Actual Results:  
No Lightning installed.

Expected Results:  
SeaMonkey with Lightning installed by default or allowed by checkbox at install time.

No additional information at this time.
(Reporter)

Updated

9 years ago
Keywords: meta
Version: unspecified → Trunk

Comment 1

9 years ago
There are no current plans on this, don't expect any movement here. This is no meta bug though, this is neither a current target of the SeaMonkey team nor anything else than a last step that might be possible somewhere in the future.

The real tracker of progress is the query of open bugs in the SeaMonkey integration component in the lightning product.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: meta
OS: Windows XP → All
Target Milestone: --- → Future
(Reporter)

Updated

9 years ago
Flags: wanted1.9.2?
(Reporter)

Updated

9 years ago
Component: Build Config → Lightning: SeaMonkey Integration
Flags: wanted1.9.2?
Product: SeaMonkey → Calendar
Target Milestone: Future → ---
(Reporter)

Updated

9 years ago
Depends on: 313822
(Reporter)

Updated

9 years ago
Keywords: helpwanted
(Reporter)

Updated

9 years ago
Keywords: calendar-integration
(Reporter)

Comment 2

8 years ago
I think it is time this got going again.
Flags: wanted-calendar1.0?

Comment 3

8 years ago
For one thing, this is nothing that should affect Lightning planning at all, and for the other, with the current slow going of the calendar project as a whole, SeaMonkey will not do this any time soon.
Flags: wanted-calendar1.0?
(Reporter)

Updated

6 years ago
Depends on: 322522
(Reporter)

Updated

6 years ago
See Also: → bug 673089

Comment 4

6 years ago
This would be a great new years day resolution for somebody :-)
Every new release of either Lightning and/or Seamonkey does seem to break the integration,
so this would be a perfect candidate for inclusion within Seamonkey (for now).
Of course Seamonkey, in the history of Mozilla Suite, is the classic 
Browser-Mailer-Composer-IRC thing ... 
...but it's 2013 now and this could positively affect Seamonkey adoption...
Cheers, Tom.

Comment 5

6 years ago
I agree with Cheesus (and I miss the calendar bundled with Netscape Communicator). ;-)

Comment 6

6 years ago
I doubt someone on the current, small, all-volunteer team of the SeaMonkey project has time to work on this, same with the even-smaller, also all-volunteer Lightning team.

But feel free to make things smoother and try working with both team towards a possibly future inclusion.

Comment 7

6 years ago
In other words if you want something done here, you need to volunteer (or find/persuade people to volunteer to work on this.
(Reporter)

Comment 8

4 years ago
Just changing bug title to make it consistent with https://bugzilla.mozilla.org/show_bug.cgi?id=401779
Summary: Ship SeaMonkey with integrated Lightning on as default → Integrate Lightning Into SeaMonkey by Default and Ship SeaMonkey with Lightning Enabled
(Reporter)

Comment 9

4 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #6)
> I doubt someone on the current, small, all-volunteer team of the SeaMonkey
> project has time to work on this, same with the even-smaller, also
> all-volunteer Lightning team.

I would say this is PRECISELY the reason for this bug. If this were rolled into the main product, there is less bureaucracy, less builds to maintain, less servers running, and all can concentrate on one product.

Comment 10

4 years ago
Feel free to help the team and do the work.
(Reporter)

Comment 11

4 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #10)
> Feel free to help the team and do the work.

Sorry, my contribution is not in coding, but in testing and reporting bugs.
(In reply to Worcester12345 from comment #9)
> I would say this is PRECISELY the reason for this bug. If this were rolled
> into the main product, there is less bureaucracy, less builds to maintain,
> less servers running, and all can concentrate on one product.
Actually, we've already come to a minimum of all of these even without the integration. Integrating it into Seamonkey and Thunderbird does not mean we have less builds, nor less servers. It might mean a little less support questions though.

Anyway, without making any firm promises, we are attempting to make a form of Integration for Thunderbird happen in Thunderbird 38, and hope to do the same with the respective Seamonkey.

Updated

3 years ago
Depends on: 1130854, 1113183, 1130852

Updated

3 years ago
User Story: (updated)
(Assignee)

Comment 13

3 years ago
Created attachment 8617326 [details] [diff] [review]
calendar_integration_into_sm_v0.1.patch

Attached is a basic patch to integrate Lightning into SeaMonkey, which is based on the Thunderbird work from bug 1130854 and "just made to work", so it is most likely far away from being ready.

Since I could not figure out, how to force the build to take the localized build of Lightning in case of a localized SeaMonkey build, I did just a hack for that by copying the localized lightning xpi file to the l10n-stage dir.

This patch works for me on Windows x64. I didn't try it yet on other platforms nor did I try to see, if it doesn't break building without lightning.

Updated

3 years ago
Attachment #8617326 - Flags: feedback?(iann_bugzilla)
(Assignee)

Comment 14

3 years ago
(In reply to Adrian Kalla [:adriank] from comment #13)
> This patch works for me on Windows x64. I didn't try it yet on other
> platforms nor did I try to see, if it doesn't break building without
> lightning.

In the meantime I had the opportunity to test it on Linux32&64 as well as Windows32&64, where it works without problems so far: builds using that patch can be found e.g. here: https://l10n.mozilla-community.org/~akalla/unofficial/seamonkey/nightly/

BTW. The part of the patch which affects the mozconfigs is already a bit bitrotted, but can easily be fixed.
(Reporter)

Updated

3 years ago
Keywords: mail-integration

Comment 15

3 years ago
Worcester12345, are you bored that you start playing with keywords again?
"mail-integration" is for Thunderbird, which is completely not affected here.
Keywords: mail-integration
(Reporter)

Comment 16

3 years ago
(In reply to rsx11m from comment #15)
> Worcester12345, are you bored that you start playing with keywords again?
> "mail-integration" is for Thunderbird, which is completely not affected here.

I was going by the "official" (whatever that is) description:
mail-integration 	Used for Calendar bugs that would have benefit for Thunderbird (i.e., adding ids, great features that would improve user experience)

Did this somehow not meet that criteria? How so?

Comment 17

3 years ago
> https://bugzilla.mozilla.org/attachment.cgi?id=8617326&action=diff

Because that patch doesn't do anything of those in Calendar or Thunderbird.
The only changes made here affect suite/ and thus are restricted to SeaMonkey.
(Reporter)

Comment 18

3 years ago
Should "product" be changed from "Calendar" to "Seamonkey" then?

Comment 19

3 years ago
Probably, given that this is mostly about building SeaMonkey with Lightning as an extension.
Component: Lightning: SeaMonkey Integration → Build Config
Product: Calendar → SeaMonkey
(Reporter)

Comment 20

3 years ago
How up to date, or out of date, is the existing patch?
Flags: needinfo?(iann_bugzilla)
(Assignee)

Comment 21

3 years ago
(In reply to Worcester12345 from comment #20)
> How up to date, or out of date, is the existing patch?

It is a bit out of date... I keep a working one here: https://bitbucket.org/adrianer/seamonkey-build/raw/default/bug516026_integrate_lightning-installers.patch (the changes to the mozconfigs are separated here: https://bitbucket.org/adrianer/seamonkey-build/raw/default/bug516026_integrate_lightning-mozconfigs.patch as they break pretty often - so this second patch is definitely at least bitrotted).

Updated

3 years ago
Assignee: nobody → akalla
Status: NEW → ASSIGNED
Flags: needinfo?(iann_bugzilla)

Comment 22

3 years ago
Comment on attachment 8617326 [details] [diff] [review]
calendar_integration_into_sm_v0.1.patch

I've tested the latest version, the only issue I found so far was that Lightning was disabled as default. This was with a new profile. Is this expected?
I still need to do some further testing.
Flags: needinfo?(akalla)
(Assignee)

Comment 23

3 years ago
(In reply to Ian Neal from comment #22)
> I've tested the latest version, the only issue I found so far was that
> Lightning was disabled as default. This was with a new profile. Is this
> expected?

No, this is not to be expected. But I've tested it with my today's build from here: https://l10n.mozilla-community.org/~akalla/unofficial/seamonkey/nightly/latest-comm-aurora-linux64/ and it works as expected with a newly created profile: Lightning is activated.

The patch did not change lately... Did you test on c-c? If yes, then maybe something there did break something...
Flags: needinfo?(akalla)
(Assignee)

Comment 24

3 years ago
(In reply to Adrian Kalla [:adriank] from comment #23)
> (In reply to Ian Neal from comment #22)
> > I've tested the latest version, the only issue I found so far was that
> > Lightning was disabled as default. This was with a new profile. Is this
> > expected?
> 
> No, this is not to be expected. But I've tested it with my today's build
> from here:
> https://l10n.mozilla-community.org/~akalla/unofficial/seamonkey/nightly/
> latest-comm-aurora-linux64/ and it works as expected with a newly created
> profile: Lightning is activated.
> 
> The patch did not change lately... Did you test on c-c? If yes, then maybe
> something there did break something...

I see now your observation on c-c - it seems like some extensions (Lightning and the Modern-theme) on c-c are recognized now as being "foreign installed":

1459858905839   addons.xpi-utils        WARN    Disabling foreign installed add-on {e2fda1a4-762b-4020-b5ad-a41df1933103} in app-global
1459858905865   addons.xpi-utils        WARN    Disabling foreign installed add-on modern@themes.mozilla.org in app-global

Does anyone here know which (Firefox-/Core-)bug did introduce this and how to workaround this for our both cases?
(Assignee)

Comment 25

3 years ago
> I see now your observation on c-c - it seems like some extensions (Lightning
> and the Modern-theme) on c-c are recognized now as being "foreign installed"(...)

Looks like this is expected behavior on nightly - see bug https://bugzilla.mozilla.org/show_bug.cgi?id=1159499#c1 .
(Assignee)

Comment 26

3 years ago
Created attachment 8738118 [details] [diff] [review]
calendar_integration_into_sm_part1_v0.2.patch

The latest patch version without the build config changes (will be part of part2)
Attachment #8617326 - Attachment is obsolete: true
Attachment #8617326 - Flags: feedback?(iann_bugzilla)
Attachment #8738118 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 27

3 years ago
Created attachment 8738119 [details] [diff] [review]
calendar_integration_into_sm_part2_v0.2.patch

The mozconfigs patch is also, like the base patch, completely based on the original Tb-patch.
Attachment #8738119 - Flags: review?(iann_bugzilla)
(Reporter)

Comment 28

3 years ago
(In reply to Adrian Kalla [:adriank] from comment #25)
> > I see now your observation on c-c - it seems like some extensions (Lightning
> > and the Modern-theme) on c-c are recognized now as being "foreign installed"(...)
> 
> Looks like this is expected behavior on nightly - see bug
> https://bugzilla.mozilla.org/show_bug.cgi?id=1159499#c1 .

Should it be noted over there that there are SM implications also?
Created attachment 8742064 [details]
Clipboard.jpg

If it's supposed to always be shipped couldn't we just put

>> # Include Lightning
>> MOZ_CALENDAR=1

in confvars.sh instead of 'ac_add_options --enable-calendar'?

In my Windows x64 2.45a1 from today the files 
 calendar-timezones-2.2016c.xpi
 gdata-provider-2.9a1.en-US.win64.xpi

were also compiled and can be found in dist/xpi-stage but are not put into the nsis installer. I think this also happens with Thunderbird. I didn't find any trace of these in TBs build configuration files.

If I press otions in about:addons Seamonkey hangs but this might be a different bug. See screenshot for the location. Using Options button from the Extensions list works.

Comment 30

3 years ago
(In reply to Frank-Rainer Grahl from comment #29)
> If it's supposed to always be shipped couldn't we just put
> 
> >> # Include Lightning
> >> MOZ_CALENDAR=1

There was some opt-out UI added on Thunderbird's side which probably should be ported to SeaMonkey, given that it's installing itself by default and not everybody wants that.

Comment 31

3 years ago
(but then, we don't have an opt-out dialog for ChatZilla either...)

Updated

2 years ago
Attachment #8738118 - Flags: review?(iann_bugzilla) → review+

Updated

2 years ago
Attachment #8738119 - Flags: review?(iann_bugzilla) → review+

Comment 32

2 years ago
(In reply to Frank-Rainer Grahl from comment #29)
> Created attachment 8742064 [details]
> Clipboard.jpg
> 
> If it's supposed to always be shipped couldn't we just put
> 
> >> # Include Lightning
> >> MOZ_CALENDAR=1
> 
> in confvars.sh instead of 'ac_add_options --enable-calendar'?
For the moment we still need to give people a simple way not to build with lightning. We can revisit this at a later point.

> If I press otions in about:addons Seamonkey hangs but this might be a
> different bug. See screenshot for the location. Using Options button from
> the Extensions list works.

Do you see this Adrian?
Flags: needinfo?(akalla)

Comment 33

2 years ago
(In reply to rsx11m from comment #30)
> (In reply to Frank-Rainer Grahl from comment #29)
> > If it's supposed to always be shipped couldn't we just put
> > 
> > >> # Include Lightning
> > >> MOZ_CALENDAR=1
> 
> There was some opt-out UI added on Thunderbird's side which probably should
> be ported to SeaMonkey, given that it's installing itself by default and not
> everybody wants that.

I'm fairly sure I saw an opt-out with a new profile.

Comment 34

2 years ago
(In reply to Ian Neal from comment #33)
> I'm fairly sure I saw an opt-out with a new profile.

Ok, good then. I didn't test it myself.

Comment 35

2 years ago
(In reply to Frank-Rainer Grahl from comment #29)
> In my Windows x64 2.45a1 from today the files 
>  calendar-timezones-2.2016c.xpi
>  gdata-provider-2.9a1.en-US.win64.xpi
> 
> were also compiled and can be found in dist/xpi-stage but are not put into
> the nsis installer. I think this also happens with Thunderbird. I didn't
> find any trace of these in TBs build configuration files.

Is this by design?
Flags: needinfo?(philipp)
I don't know much about the NSIS installer, but Lightning files being in dist/xpi-stage is by design, this is also how other addons built by the build system work. The files should also be in dist/bin/extensions (on non-release builds only), in dist/bin/distribution/extensions (on release builds only), and on mac in dist/Appname.app/Contents/Resources/extensions/

There is an opt-out that should get shown the first time it is installed as a distribution extension.
Flags: needinfo?(philipp)
(Reporter)

Comment 37

2 years ago
(In reply to Frank-Rainer Grahl from comment #29)
> Created attachment 8742064 [details]
> Clipboard.jpg
> 
> If it's supposed to always be shipped couldn't we just put
> 
> >> # Include Lightning
> >> MOZ_CALENDAR=1
> 
> in confvars.sh instead of 'ac_add_options --enable-calendar'?
> 
> In my Windows x64 2.45a1 from today the files 
>  calendar-timezones-2.2016c.xpi
>  gdata-provider-2.9a1.en-US.win64.xpi
> 
> were also compiled and can be found in dist/xpi-stage but are not put into
> the nsis installer. I think this also happens with Thunderbird. I didn't
> find any trace of these in TBs build configuration files.
> 
> If I press otions in about:addons Seamonkey hangs but this might be a
> different bug. See screenshot for the location. Using Options button from
> the Extensions list works.

A small nitpick, but in the screenshot/clip, it says it is a calendar for Thunderbird. I would think the "Thunderbird" should be removed in the wording, since this is a different product. Just putting it out there. Thanks.

Comment 38

2 years ago
(In reply to Worcester12345 from comment #37)
> calendar for Thunderbird.

That's coming from Lightning itself and would have to be changed in their code,
http://mxr.mozilla.org/comm-central/source/calendar/lightning/install.rdf#35

Comment 39

2 years ago
Bug 533984 - Mention SeaMonkey (not only Thunderbird) in the description of the Lightning XPI.
Blocks: 533984
(Assignee)

Comment 40

2 years ago
(In reply to Ian Neal from comment #32)
> (In reply to Frank-Rainer Grahl from comment #29)
> > If I press otions in about:addons Seamonkey hangs but this might be a
> > different bug. See screenshot for the location. Using Options button from
> > the Extensions list works.
> 
> Do you see this Adrian?

Also does not work for me when using the button in location from the screen shot. Using "Options" directly from the addons-list works for me. Nonetheless: this is a Lightning bug and has nothing to do with the default-integration into SeaMonkey here.


IanN: thx for the review. Now we need to check this into c-c and if possible also c-a and c-b (I think this was well enough tested by now to do it this way).
Flags: needinfo?(akalla)
Keywords: helpwanted → checkin-needed

Comment 41

2 years ago
a=me for checkin to c-c, c-a and c-b

Comment 42

2 years ago
http://hg.mozilla.org/comm-central/rev/f32ca0e1adf2
http://hg.mozilla.org/comm-central/rev/e0a3a6065338
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-seamonkey2.44: --- → affected
status-seamonkey2.45: --- → affected
status-seamonkey2.46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.46

Updated

2 years ago
Keywords: checkin-needed

Comment 44

2 years ago
Works for me on trunk (comes with Lightning 5.1a1) and aurora (5.0a2) nightly builds on Linux, and a beta tinderbox build (where SM 2.44 interestingly comes with 4.7.1 bundled, but seems to work).
Status: RESOLVED → VERIFIED

Comment 45

2 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #36)
> There is an opt-out that should get shown the first time it is installed as
> a distribution extension.

BTW: That's a bit subtle and shows up as a notification bar in the message preview pane when opening the Mail & News window, boxed in between thread pane, folder pane, and Lightning's today pane. Just as a heads-up for anyone expecting a large dialog to pop up. ;-)

Updated

2 years ago
Depends on: 1272888

Updated

2 years ago
Blocks: 1276951
(Reporter)

Comment 46

2 years ago
Has anything changed with regards to the status of "Integrate Lightning Into SeaMonkey by Default and Ship SeaMonkey with Lightning Enabled"?

Is this still OK for 2.46 and 2.49?

Comment 47

2 years ago
Yes and no - it's set up and working, except that the build system for the localized (l10n) releases encountered a regression, consequently SeaMonkey 2.46 couldn't be built with /any/ extension bundled (including DOM Inspector and ChatZilla). It may be the same for 2.48, thus we will have to see if a solution for this issue is coming up on the horizon any time soon.
(Reporter)

Comment 48

2 years ago
So, should this bug be reopened, with whatever that bug is as a dependency? Thank you.

Comment 49

2 years ago
No, completely different issue (especially as it affects all bundled extensions).
Bug 1231349 - L10n repacks broken on with SM 2.42 and newer.
(Reporter)

Comment 50

13 days ago
(In reply to rsx11m from comment #30)
> (In reply to Frank-Rainer Grahl from comment #29)
> > If it's supposed to always be shipped couldn't we just put
> > 
> > >> # Include Lightning
> > >> MOZ_CALENDAR=1
> 
> There was some opt-out UI added on Thunderbird's side which probably should
> be ported to SeaMonkey, given that it's installing itself by default and not
> everybody wants that.

Was this ever done?



(In reply to rsx11m from comment #38)
> (In reply to Worcester12345 from comment #37)
> > calendar for Thunderbird.
> 
> That's coming from Lightning itself and would have to be changed in their
> code,
> http://mxr.mozilla.org/comm-central/source/calendar/lightning/install.rdf#35

I think they were working on something like that for Thunderbird. It should be added here as well.
You need to log in before you can comment on or make changes to this bug.