Closed Bug 1113502 Opened 5 years ago Closed 4 years ago

The caret shows up and then disappers when user taps the character in input field in Messages app

Categories

(Firefox OS Graveyard :: Gaia::System, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: gchang, Unassigned)

References

(Blocks 1 open bug)

Details

### Steps:
1. Open Messages app
2. Click pencil icon on the upper-right corner to create a new message
3. Type some characters in the message body
4. Tap outside to dismiss the keyboard
5. Tap the character in the input field again

### Expected:
1. The caret and the keyboard show up

### Actual:
1. The caret shows up when user taps the field and disappers after Keyboard shows up.

### Reproduce rate
always

### Version:
Gaia-Rev        d22dfece04fc00457e8369c660c11f945b088d2f
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/cb8ad2251c09
Build-ID        20141217160203
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
QA Whiteboard: [textselection]
Hi,
I guess you may help for it?
Flags: needinfo?(tlin)
Flags: needinfo?(tlin)
The touch-caret disappears because the cursor is not visible during the keyboard pops up. Since this does not affect the usability of touch-caret, one can still enable touch-caret after keyboard shows. I'll set a lower priority to this bug.
Priority: -- → P3
Blocks: AccessibleCaret
No longer blocks: CopyPasteLegacy
QA Whiteboard: [textselection] → [COM=Text Selection]
This bug should be fixed after enabling AccessibleCaret in bug 1172382. Feel free to reopen it if you could still reproduce this issue.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(gchang)
Resolution: --- → WORKSFORME
The issue doesn't happen.
Flags: needinfo?(gchang)
You need to log in before you can comment on or make changes to this bug.