spp.se - does not work with Mozilla

VERIFIED FIXED

Status

Tech Evangelism Graveyard
Other
P3
major
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: Per Ångström, Assigned: Tristan Nitot)

Tracking

Details

(Whiteboard: [USERAGENT][PROPRIETARY-DOM] [TOOL][HIERMENU], URL)

(Reporter)

Description

16 years ago
SPP, a big Swedish pension trust company, has display and functionality problems
with Mozilla.

Reproducible: Always
Steps to Reproduce:
1. Enter <URL:http://www.spp.se/>


Actual Results:  As soon as one enters the site with Mozilla, they greet you
with an alert saying "Cannot recognize your browser, strange things may happen".
And indeed, the website looks strange, with blank areas and  unreadable text in
the left column. The three icons in the upper right corner don't work.

The website comes in two versions, one for Internet Explorer and one for
Netscape 4.x. Mozilla is instructed to use the Internet Explorer version, by the
following piece of script:

if (document.layers) {
 if (version>4) {
  window.location="ns/index.asp";
 }
 else {
  alert("Vi rekommenderar att du använder en nyare version av Netscape browser.");
  window.location="ns/index.asp";
 }}
else {
 if (version>=4.0) {
  window.location="ie/index.asp"
 }
 else {
  alert("Vi rekommenderar att du använder en nyare version av Microsoft Internet
Explorer.");
  window.location="ie/index.asp";
 }}

Of course, the NS version doesn't work any better, since it uses layers.
(Reporter)

Updated

16 years ago
Summary: spp.se - site does not work with → spp.se - does not work with Mozilla

Comment 1

16 years ago
Part of the problem is the code you mentioned; another part is the usage of
HeirMenus 3.x as referenced in these files found in the source code of
http://www.spp.se/ie/index.asp

<script language="JavaScript1.2" src="js/menusettings.js"></script>
<script language="JavaScript1.2" src="js/hiermenus.js"></script>
<script language="JavaScript1.2" src="js/halonav2.js"></script>
Blocks: 85104
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [USERAGENT][PROPRIETARY-DOM] [TOOL][HIERMENU]
(Assignee)

Comment 2

16 years ago
contact : +46 8 441 96 21 or e-mail to kundcenter@spp.se.
Setting P3.
Priority: -- → P3
(Reporter)

Comment 3

16 years ago
I'm setting this bug to block bug #100614, since SPP belongs to Handelsbanken.
Blocks: 100614
(Reporter)

Comment 4

16 years ago
The site has been redesigned, and as far as I can tell, it now works fine with
Mozilla.

Comment 5

16 years ago
It almost works fine.
At the lower right corner there are 3 icons that if you pass your mouse pointer
above them a new window opens - like a big tooltip.
In IE this always opens in a place that you can see them.
In mozilla this always opens under the mouse pointer which causes the window to
be partially hidden.
I'm not sure its related to this bug anymore.
Maybe this should be closed as fixed.
(Reporter)

Comment 6

16 years ago
The main problem seems to have been fixed by the redesign.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 7

15 years ago
v
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.