Closed Bug 1114399 Opened 8 years ago Closed 8 years ago

[Stingray][Home] settings button group isn't collapsed consistently while losting focus

Categories

(Firefox OS Graveyard :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: johnhu, Assigned: johnhu)

References

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 file)

settings button group is still opened while focus transferred to app launcher buttons.

STR:
1. focus settings button group
2. press down or right while gear is rotating. <== button group is not closed

actual:
  button group is not closed
expected:
  button group should be closed.

note: the reproduce ratio is not 100%.
No longer blocks: 1067862
No longer depends on: 1109493, 1110652, 1111414, 1114397, 1110045, 1110047, 1111416
The root cause of this issue is the "setTimeout" which is added to work around a gecko css issue. Because of this setTimeout, we may have a opening and closing running at the same time. The sequence of each state are:

Opening States:
closed -> closed + enlarging -> closed + shrinking -> opening -> ''(this is opened)

Closing State:
'' -> closing -> closed

We had use a setTimeout at `closed + shrinking` state. So, while state is in `closed + shrinking` without timeout executed, we call close on menu group. It will run `closing` and `opening` at the same time.

Dwi2,

The is the whole story. Please review the patch. Thanks.
Attachment #8539905 - Flags: review?(tzhuang)
Comment on attachment 8539905 [details] [review]
check before moving on next state

Looks good to me, thanks
Attachment #8539905 - Flags: review?(tzhuang) → review+
You need to log in before you can comment on or make changes to this bug.