Please deploy hotfix release 0.14.3 to loop-server stage

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: alexis+bugs, Assigned: bobm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Please, deploy the 0.14.3 tag to Staging environment.

https://github.com/mozilla-services/loop-server/compare/0.14.2...0.14.3

No configuration changes are needed.

Comment 1

4 years ago
This has been deployed.

{"name":"mozilla-loop-server","description":"The Mozilla Loop (WebRTC App) server","version":"0.14.3","homepage":"https://github.com/mozilla-services/loop-server/","endpoint":"https://loop.stage.mozaws.net","fakeTokBox":false,"fxaOAuth":true,"i18n":{"defaultLang":"en-US","lang":"en-GB"}}
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(rpappalardo)
Resolution: --- → FIXED
------------------
SUMMARY
------------------

Placed few calls successfully between Nightly & DevEd - including tests with room creator logged into FxA to verify hotfix is working on stage:
Bug 1114374 - Unable to join room as link-clicker if the creator is in the room when logged in (regression)

stack validation, quick checks, loadtest look good.
Verifying stage.

------------------
STAGE VALIDATION
------------------

STAGE STACK - NEW:
$ cat /data/loop-server/VERSION.txt
c3db82a Tag 0.14.3
matches:
https://github.com/mozilla-services/loop-server/commit/c3db82ab050961ed6165f8becb0273fd577d7b2e

$ rpm -qa | grep loop
loop-server-svcops 0.14.3-1 x86_64 26661319
puppet-config-loop 20141219121706-1 x86_64 17977


PROCESSES:
Verified processes: loop (node), stackdriver, circus, heka, nginx

------------------
QUICK CHECKS
------------------
$ make test 
unit tests on localhost with 0.14.3 tag all PASS


https://loop.stage.mozaws.net/

{
  "name": "mozilla-loop-server",
  "description": "The Mozilla Loop (WebRTC App) server",
  "version": "0.14.3",
  "homepage": "https://github.com/mozilla-services/loop-server/",
  "endpoint": "https://loop.stage.mozaws.net",
  "fakeTokBox": false,
  "fxaOAuth": true,
  "i18n": {
    "defaultLang": "en-US",
    "lang": "en-US"
  }
}


$ curl -I https://loop.stage.mozaws.net
HTTP/1.1 200 OK
Date: Mon, 22 Dec 2014 19:26:51 GMT
Content-Type: application/json; charset=utf-8
Content-Length: 273
Connection: keep-alive
ETag: W/"111-66cb2a63"


LOADTEST 
This release was already loadtested on 0.14.1.  since 0.14.2 & 0.14.3  only introduce hotfixes,
only doing a reduced loadtest to verify deployment (see below).

As indicated before, the 400 failures are a known issue - Bug 1111655 

Users [80], Agents 5, Duration 1h 
https://loads.services.mozilla.com/run/de859973-7e3c-40a9-bab1-2e6111acd128
Blocks: 1114374, 1114714
Status: RESOLVED → VERIFIED
No longer blocks: 1114374
You need to log in before you can comment on or make changes to this bug.