Closed Bug 1115628 Opened 7 years ago Closed 6 years ago

last name is shown more than once after entering the keywords while searching.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set
normal

Tracking

(blocking-b2g:-, b2g-v2.0 unaffected, b2g-v2.0M affected, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

RESOLVED INVALID
blocking-b2g -
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.0M --- affected
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected

People

(Reporter: selee, Unassigned)

References

Details

Attachments

(1 file)

STR:
1. Go to Contacts app.
2. Click Search bar in the app.
3. Enter some keywords to search contacts.
4. The last name is shown more than once after entering the keywords.

see also bug 1074643 comment 16 .
blocking-b2g: --- → 2.0M?
Company field won't be highlight as well even the keyword is matched to Company field.
We had the same issue on master 2 months ago (bug 1092559). What's the state of the branches? QA wanted for a branch check.
Keywords: qawanted
See Also: → 1092559
Unable to reproduce the bug on Flame 2.0, Flame 2.1, and Flame 2.2 master.

Searching a contact does NOT display duplicate surnames on search result page. Attaching a screenshot showing bug NOT reproducing.

Device: Flame 2.0
BuildID: 20141229091633
Gaia: 01c32dcdc08b3c8fc8b3082870439fa2c1089f4f
Gecko: b4ea79d5c1b2
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.1
BuildID: 20141226091635
Gaia: 73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko: ea426e47bfc4
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master
BuildID: 20141229172835
Gaia: 322ef5116a5827a30c9a3cd9b842449a9c66a5b3
Gecko: 67872ce17918
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Hi Sean,
Is this still exist on Woodduck 2.0M? Thanks!
Blocks: Woodduck
Flags: needinfo?(selee)
See Also: → 1088706
Hi Josh,

I can't reproduce this issue at commit 7e55f20bc0f82397207cac6b5b477948652da62c .
Thanks.
Flags: needinfo?(selee)
Status: NEW → RESOLVED
blocking-b2g: 2.0M? → -
Closed: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.