Selected profile not remembered in profiles.ini (regression)

RESOLVED FIXED in seamonkey2.35

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: michal-ok, Assigned: philip.chee)

Tracking

({regression})

SeaMonkey 2.32 Branch
seamonkey2.35
x86
All
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.31 unaffected, seamonkey2.32 fixed, seamonkey2.33+ fixed, seamonkey2.34+ fixed, seamonkey2.35+ fixed)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:34.0) Gecko/20100101 Firefox/34.0 SeaMonkey/2.31
Build ID: 20141202220728

Steps to reproduce:

Starting SeaMonkey with Profile Manager or switching profiles using Tools -> Switch Profile.


Actual results:

SeaMonkey starts with the selected profile but the choice is not saved to profile.ini and on next start SeaMonkey does not remember the selected profile and uses by default yet previously selected profile.

Happens in SeaMonkey 2.32 Beta 2. Works correctly in 2.31 and earlier.


Expected results:

After startup the selected profile should be marked as "Default=1" in profile.ini so that the profile is used by default on next startup. Interestingly, the choice of the "Default to this profile" checkbox is saved correctly in profile.ini.
Keywords: regression
Confirmed.

"Default=1" does not get set to the last opened Profile, instead remaining.
SeaMonkey 2.31 works correctly.
 
 
For reference, Bug 736893 - Profile Manager Remembers Only Last Selected Profile, Not Last Actually Used Profile
Status: UNCONFIRMED → NEW
Ever confirmed: true
This bug is also present in current 2.33 aurora builds.
> Happens in SeaMonkey 2.32 Beta 2. Works correctly in 2.31 and earlier.
Does this also happen in the latest Firefox 35 Beta?
No, this problem doesn't occur in Firefox 35b8 nor in Firefox Nightly.
Regression window:

2014-10-24-00-30-01-comm-central-trunk/
2014-10-25-00-30-01-comm-central-trunk/
OS: Windows 7 → All
Nothing stands out in comm-central.

mozilla-central: http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2014-10-24&enddate=2014-10-26+00:

Suspect http://hg.mozilla.org/mozilla-central/rev/1416eeab79a2
Bug 1024110 - Change Aurora's default profile behaviour to use channel-specific profiles.
This caused a regression:
Bug 1089694 - Profile manager does not remember last used profile
(How does Alice0775 manage to find all these bugs?)

(From Bug 1089694 comment 6)
> Created attachment 8512046 [details] [diff] [review]
> When selecting a profile in the Profile Manager, mark it with Default=1
> 
> With the introduction of profileService.defaultProfile I missed a spot where
> the equivalence between selectedProfile and defaultProfile used to be
> implicit, but now has to be explicit.

https://hg.mozilla.org/mozilla-central/rev/df5af1c51264#l1.11

At http://mxr.mozilla.org/comm-central/source/suite/common/profile/profileSelection.js?rev=ead55271f364&mark=109-109#107

We should add something like the following:
      gProfileService.selectedProfile = selected.profile;
+     gProfileService.defaultProfile = selected.profile;

> status-firefox35: verified
> status-firefox36: verified
Means that we need to land this fix on SeaMonkey 2.32, 2.33, 2.34, trunk (2.35a).
Ooops we missed 2.32.
Blocks: 1024110
Port Bug 1089694
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8550452 - Flags: feedback?(therubex)
Attachment #8550452 - Flags: feedback?(michal-ok)
Comment on attachment 8550452 [details] [diff] [review]
When selecting a profile in the Profile Manager, mark it with Default=1

Review of attachment 8550452 [details] [diff] [review]:
-----------------------------------------------------------------

Works well for me!
Attachment #8550452 - Flags: feedback?(michal-ok) → feedback+
Attachment #8550452 - Flags: review+
Comment on attachment 8550452 [details] [diff] [review]
When selecting a profile in the Profile Manager, mark it with Default=1

[Approval Request Comment]
Regression caused by (bug #): Bug 1024110
User impact if declined: Selected profile not remembered
Testing completed (on m-c, etc.): The equivalent toolkit patch has been in the tree since firefox35. Plus SM users have confirmed this patch fixes the problem.
Risk to taking this patch (and alternatives if risky): none, bustage fix.
String changes made by this patch: none.
Attachment #8550452 - Flags: feedback?(therubex)
Attachment #8550452 - Flags: approval-comm-beta?
Attachment #8550452 - Flags: approval-comm-aurora?
Attachment #8550452 - Flags: approval-comm-beta?
Attachment #8550452 - Flags: approval-comm-beta+
Attachment #8550452 - Flags: approval-comm-aurora?
Attachment #8550452 - Flags: approval-comm-aurora+
Duplicate of this bug: 1123135
http://hg.mozilla.org/comm-central/rev/fe15b3608980
Target Milestone: --- → seamonkey2.35
Does this mean the bug is fixed in version 2.35?
If so, when will version 2.35 be available for download?
The text above "status-seamonkey2.33: affected → fixed" means it will be fixed in 2.33.
Comment on attachment 8550452 [details] [diff] [review]
When selecting a profile in the Profile Manager, mark it with Default=1

Possible point release 2.32.1
[Approval Request Comment]
Regression caused by (bug #): Bug 1024110
User impact if declined: Selected profile not remembered
Testing completed (on m-c, etc.): The equivalent toolkit patch has been in the tree since firefox35. Plus SM users have confirmed this patch fixes the problem.
Risk to taking this patch (and alternatives if risky): none, bustage fix.
String changes made by this patch: none.
Attachment #8550452 - Flags: approval-comm-release?
Attachment #8550452 - Flags: approval-comm-release? → approval-comm-release+
This status of this issue says "RESOLVED FIXED"
So is there a patch or other file we can download
to update our SeaMonkey 2.32?
(In reply to kodella from comment #17)
> This status of this issue says "RESOLVED FIXED"
> So is there a patch or other file we can download
> to update our SeaMonkey 2.32?
We plan to issue a point release (SeaMonkey 2.32.1) corresponding to Firefox 35.0.1
You need to log in before you can comment on or make changes to this bug.