[Flame][Browser]The device will enter system settings page after you tap "Check settings" button.

RESOLVED DUPLICATE of bug 1137722

Status

RESOLVED DUPLICATE of bug 1137722
4 years ago
4 years ago

People

(Reporter: liuke, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.0M unaffected, b2g-v2.1 unaffected, b2g-v2.1S unaffected, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8543607 [details]
logcat_1551.txt

[1.Description]:
[Flame][v2.2][Browser]The device will enter system settings page after you tap "Check settings" button in Browser.
Found time:15:51
See attachment:1551.mp4 and logcat_1551.txt

[2.Testing Steps]: 
Premise:Device is not connected to any network.
1.Launch Browser.
2.Load a website.
3.Tap the "Check settings" button.
4.Turn on or turn off airplane mode, and tap "Done" button at once.
5.Tap the "Check settings" button again.

[3.Expected Result]: 
5.Device should enter network settings page.

[4.Actual Result]: 
5.Device will enter system settings page.

[5.Reproduction build]: 
Gaia-Rev        698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/57e4e9c33bef
Build-ID        20150103010205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150103.045144
FW-Date         Sat Jan  3 04:51:56 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
occasionally Recurrence,6/10
TCID: Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8543613 [details]
1551.MP4
Definitely a bug, but just not easy to reproduce that, hi Arthur, Could you help to check log, thanks..
QA Whiteboard: [
Flags: needinfo?(arthur.chen)
I tried to reproduce this but this happened rarely with about 1/10 recurrence.

After investigating our code with some console.log, I noticed that https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/startup.js#L376 would return false when this bug happened which means we didn't get any message from Gecko.

Because what Settings app do here is to listen to Gecko's message to do following works (show/hide specific menuItems or jump to specific panel), if we can't get this message, we would directly show root panel -> KO

Based on above observations, I think this is Gecko's bug instead of Gaia's. @Eric, do you know who can we ask for help from Gecko side about this ? 

Thanks :)
Flags: needinfo?(arthur.chen) → needinfo?(echang)

Comment 4

4 years ago
Hi Vincent, can you help to take a look if this is in your plate? Thanks.
Flags: needinfo?(vchang)
I don't think it's related to wifi.
Flags: needinfo?(vchang)

Updated

4 years ago
QA Whiteboard: [
I cannot reproduce it even once. Does it require any specific additional steps?
Adjusting RAM to 319MB might be easier to reproduce this.
https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/Flame/Updating_your_Flame#RAM_adjustment
Flags: needinfo?(echang)
Created attachment 8571885 [details]
logcat

Hi Eric,
This problem cannot be repro on latest build of Woodduck 2.0/Flame 2.0/Flame 2.1/Flame 2.1s. But it can be repro on Flame 2.2/Flame 3.0, I find a new STR to reproduce this problem more easily. Could you please help with it? thanks!
New STR:
Premise:Device is not connected to any network.
1. Launch Settings app.
2. Press Home button and go back to Homescreen.
3. Launch Browser.
4.Load a website.
5.Tap the "Check settings" button.
**Device will enter system settings page. 
(If step 5 is pass, operation step 6)
6.Tap "Done" and tap "Check settings" button again.
**Device will enter system settings page. 

See attachments: logcat_0543.txt & Repro_video.MP4
Occurrence time: 05:43
Fail Rate: 3/5

Woodduck 2.0 build (319mb):
Build ID               20150303050313
Gaia Revision          a1b5959728c8bc2a82354e197bb161922d419866
Gaia Date              2015-02-13 09:00:02
Gecko Revision         d9b299dc1087f23c83321b4dccc92e0f52309e8e
Gecko Version          32.0
Device Name            jrdhz72_w_ff
Firmware(Release)      4.4.2
Firmware(Incremental)  1425330308
Firmware Date          Tue Mar  3 05:05:35 CST 2015

Flame 2.0 build (319mb):
Build ID               20150302000457
Gaia Revision          366aaa19ac474dc58b79d62a91cff41756ae9dfe
Gaia Date              2015-02-22 20:25:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/1bd33f5447d2
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150302.034720
Firmware Date          Mon Mar  2 03:47:30 EST 2015
Bootloader             L1TC000118D0

Flame2.1 build (319mb):
Build ID               20150302001220
Gaia Revision          5d3479fdd438412adee4452720856b6b771fe5cd
Gaia Date              2015-02-25 18:20:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/9bf4c663241f
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150302.035532
Firmware Date          Mon Mar  2 03:55:42 EST 2015
Bootloader             L1TC000118D0

Flame 2.2 build (319mb):
Build ID               20150302002504
Gaia Revision          77609916ca5ab721150fab2b7bc5c37f43ee3a5a
Gaia Date              2015-02-27 16:35:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/27ab8aa34201
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150302.042723
Firmware Date          Mon Mar  2 04:27:34 EST 2015
Bootloader             L1TC000118D0

2.1S build (512mb):
Build ID               20150302001206
Gaia Revision          a43d64ae01ef108aa4dcc971c770fecd8416a764
Gaia Date              2015-02-26 09:24:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/2437280c634f
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015

Flame 3.0 build (319mb):
Build ID               20150302010223
Gaia Revision          f34ce82a840ad3c0aed3bfff18517b3f6a0eb37f
Gaia Date              2015-02-27 15:48:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eea6188b9b05
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150302.043726
Firmware Date          Mon Mar  2 04:37:37 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(echang)
status-b2g-v2.0: --- → unaffected
status-b2g-v2.0M: --- → unaffected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.1S: --- → unaffected
status-b2g-master: --- → affected
QA Whiteboard: [MGSEI-Triage+]
Set 2.2? for regression, and reproduce rate with STR in #c8 is 100% for my 5 attemps.
blocking-b2g: --- → 2.2?
Flags: needinfo?(echang)

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+

Comment 11

4 years ago
Candice, is it something in your plate? Can you find someone to take a look? 
Thanks.
Flags: needinfo?(cserran)
Given the new STR reported in comment 8 the bug seems to be a regression of bug 1126119.
There is a similar bug 1140325. Not sure if it is a duplicate.
Blocks: 1126119
since this is a regression of 1126119, this should go back to tpe team
Flags: needinfo?(cserran) → needinfo?(khu)

Comment 15

4 years ago
Kanru, would you mind taking a look on this bug? Thanks.
Flags: needinfo?(khu) → needinfo?(kchen)
Looks like a duplicate of bug 1137722
Flags: needinfo?(kchen)
Fixed on m-c.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137722
You need to log in before you can comment on or make changes to this bug.