[Settings] The "configure" activity does not work properly if the Settings app is launched and in a panel

RESOLVED FIXED in Firefox 39, Firefox OS v2.2

Status

()

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: julienw, Assigned: kanru, NeedInfo)

Tracking

({regression})

unspecified
mozilla39
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5?, firefox37 wontfix, firefox38 wontfix, firefox39 fixed, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

STR:
1. launch the Settings app
2. enter the "Call Settings" panel (I think any panel make the bug appear)
3. press home
4. launch the Messages app
5. press the top right menu button
6. press "Settings"

=> The settings app is launched, but the panel "Messaging Settings" is not selected.
=> There is no way to leave the panel, the user is forced to kill the application.

qawanted for branch checks.
QA Contact: ychung
This issue reproduces on Flame Master and Flame 2.2.

Result: Messages Settings screen does not appear. The main Settings page stays on the screen.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150226184845
Gaia: 7512026a377271a0cade12d70846557f0bc7781c
Gecko: c7968255c1ea
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150226200134
Gaia: eb6a5ac9081d3962198e0f4520b0743d716d7a27
Gecko: c8a38dcfbebc
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
==========================================
This issue reproduces on Flame 2.1.

Result: Messages Settings screen opens after showing the main Settings screen briefly.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150225111642
Gaia: 5d3479fdd438412adee4452720856b6b771fe5cd
Gecko: 0390c73a827b
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: qawanted → regression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
(In reply to Yeojin Chung [:YeojinC] from comment #1)
Correction: This issue DOES reproduce on Flame 2.1.

> Result: Messages Settings screen opens after showing the main Settings
> screen briefly.
> 
> Environmental Variables:
> Device: Flame 2.1
> BuildID: 20150225111642
> Gaia: 5d3479fdd438412adee4452720856b6b771fe5cd
> Gecko: 0390c73a827b
> Version: 34.0 (2.1) 
> Firmware Version: v18D-1
> User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Sorry about the confusion.
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150211012654
Gaia: 462a2ef9e98134255c144e373c7392440e3ee03b
Gecko: 42d960d1f148
Version: 38.0a1 (3.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150211022003
Gaia: 462a2ef9e98134255c144e373c7392440e3ee03b
Gecko: e60f5fee730f
Version: 38.0a1 (3.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Last Working Gaia First Broken Gecko: Issue DOES reproduce 
Gaia: 462a2ef9e98134255c144e373c7392440e3ee03b
Gecko: e60f5fee730f

First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: 462a2ef9e98134255c144e373c7392440e3ee03b
Gecko: 42d960d1f148

http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=42d960d1f148&tochange=e60f5fee730f

Caused by bug 1126119
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
The behavior of settings related to the "configure" activity radically changed in v2.2 so let's not focus on v2.1 here.

Comment 5

4 years ago
Hi Kan-Ru, this regression is caused by bug 1126119, can you help with this? Thank you.
Component: Gaia::Settings → DOM: Device Interfaces
Flags: needinfo?(kchen)
Product: Firefox OS → Core
(Assignee)

Updated

4 years ago
Assignee: nobody → kchen
Flags: needinfo?(kchen)
(Assignee)

Comment 6

4 years ago
Created attachment 8572480 [details] [diff] [review]
Ensure that system message cache is refreshed before openapp

The settings app uses mozHasPendingMessage to determine whether to call mozSetMessageHandler. This patch ensures that when we enqueue a message we also refresh the caches.
Attachment #8572480 - Flags: review?(fabrice)
Attachment #8572480 - Flags: review?(fabrice) → review+
(Assignee)

Comment 10

4 years ago
It turns out the mochitest container app (http://mochi.test:8888/manifest.webapp) on B2G emulator is not installed so when we applied a strict checking in code the test failed.
(Assignee)

Comment 12

4 years ago
Created attachment 8573730 [details] [diff] [review]
Patch v2

I restored the original behavior and opened bug 1140275 to track the manifest issue.
Attachment #8572480 - Attachment is obsolete: true
Attachment #8573730 - Flags: review?(fabrice)
Attachment #8573730 - Flags: review?(fabrice) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/fbc8ebe1adac
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
(Assignee)

Comment 15

4 years ago
Comment on attachment 8573730 [details] [diff] [review]
Patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 1126119
User impact if declined: Inline activities that use mozHasPendingMessage fail to load
Testing completed: Landed on central & manual test
Risk to taking this patch (and alternatives if risky): little, if there is any regression we could backout this patch and the one in bug 1126119
String or UUID changes made by this patch: N/A
Attachment #8573730 - Flags: approval-mozilla-b2g37?
Requesting verification of this patch before we consider uplift. Also any exploratory testing around this good path would be helpful to see if there are any potential fallouts which may block us from taking this and 1126119.
Keywords: verifyme
(Assignee)

Comment 17

4 years ago
Al, could you help to verify this patch on 2.2 branch?
Flags: needinfo?(atsai)

Comment 18

4 years ago
Hermes, could you help on this bug?
Flags: needinfo?(atsai) → needinfo?(hcheng)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1117484
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1140325
I have verified this issue with below master build. Please approve uplifting to v2.2 since it also results in bug 1140325 which is a 2.2+ blocker.

Leaving my NI for 2.2 verification.

Build ID               20150317160205
Gaia Revision          63d6639acd771f548a2613f07f3e335921e4ac87
Gaia Date              2015-03-17 16:53:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e965a1a534ec
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150317.195927
Firmware Date          Tue Mar 17 19:59:39 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
Attachment #8573730 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/04baf3b022bc
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
status-firefox37: --- → wontfix
status-firefox38: --- → wontfix
Duplicate of this bug: 1144801
Verify this issue with below 2.2 build on flame

Serial: e481d88f (State: device)
Build ID               20150319162506
Gaia Revision          4e0633463571377ad4badc680b666771684e862d
Gaia Date              2015-03-19 16:40:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/535ec28fb36f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.200816
Firmware Date          Thu Mar 19 20:08:26 EDT 2015
Bootloader             L1TC000118D0
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(hcheng)
Per Comment 24,clear verifyme
Keywords: verifyme

Updated

3 years ago
Duplicate of this bug: 1141924
You need to log in before you can comment on or make changes to this bug.