[RTL][Settings] Arabic: The "Current Level" string is overlapped with "%" when charging.

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
P3
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: ychung, Assigned: eragonj)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(6 attachments)

Reporter

Description

5 years ago
Posted image TextOverlap.png
Description:
When the device is set to Arabic and being charged, the "Current Level" string is overlapped with the percentage sign.
   
Repro Steps:
1) Update a Flame device to BuildID: 20150105010205.
2) Set the device language in Arabic under Settings > Language.
3) Plug in the device to a power source.
4) Navigate to Settings > Battery.
  
Actual:
The "Current Level" string is overlapped with "%".
  
Expected: 
There is enough space between the strings.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150105010205
Gaia: 613550ddb8a7b96ed6bf2a39b0b2c7547e5dbf9a
Gecko: 636498d041b5
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot
Reporter

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Reporter

Updated

5 years ago
Blocks: 1118864
RTL triage: P3 -- this bug is not prioritized for inclusion in the 2.2 release.
Priority: -- → P3
this can be fixed by bug 1115211 because they are using the same css styles.
Assignee: nobody → ejchen
appid	{3c2e2abc-06d4-11e1-ac3b-374f68613e61}
apptype	b2g
vendor	Mozilla
name	B2G
version	2.2.0.0-prerelease
appbuildid	20150128002506
platformbuildid	20150128002506
platformversion	37.0a2
geckobuildid	20150128002506
geckoversion	37.0a2
changeset	d824c65a6a2b

updating, occurs in this build also
Status: NEW → ASSIGNED
Posted image demo.png
Hey Helen, after applying related patch, this is what this panel looks like right now. Can you help me review this part ? Thanks !
Attachment #8556934 - Flags: ui-review?(hhuang)
Comment on attachment 8556934 [details]
demo.png

It looks good! Thanks!
Attachment #8556934 - Flags: ui-review?(hhuang) → ui-review+
Cool, thanks Helen. This bug should be fixed soon in latest v2.2 build.

Mark this bug as WORKSFORME :)
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15754/
Flags: in-moztrap+

Comment 8

4 years ago
Posted image charging_overlap.png
Hi EJ,
Could you help with it? Thanks!
This issue can be repro on latest build of Flame 2.2/3.0 with the same steps in comment 0. The "Current Level" string is overlapped with "%" when charging.
See attachment:charging_overlap.png
Rate:3/3

Device: Flame 2.2 (affected)
Build ID               20150402002500
Gaia Revision          1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gaia Date              2015-04-01 09:49:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/427b4da96714
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.035057
Firmware Date          Thu Apr  2 03:51:09 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(ejchen)

Updated

4 years ago
Status: RESOLVED → REOPENED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
Resolution: WORKSFORME → ---

Updated

4 years ago
Whiteboard: MGSEI-RTL-3F
Comment on attachment 8588900 [details] [review]
[gaia] EragonJ:bug-1118018 > mozilla-b2g:master

Arthur, can you help me review this simple patch ? This bug was regressed by bug 1130621, so I updated the CSS to make it work. Thanks !
Flags: needinfo?(ejchen)
Attachment #8588900 - Flags: review?(arthur.chen)
Comment on attachment 8588900 [details] [review]
[gaia] EragonJ:bug-1118018 > mozilla-b2g:master

r=me, thank you!
Attachment #8588900 - Flags: review?(arthur.chen) → review+
Thanks Arthur, this patch was merged into Gaia/master : https://github.com/mozilla-b2g/gaia/commit/17ae7477c2f0042c9857b0537611cf5b6f18933d
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Hi Sue,

I just merged this patch into Gaia/master, can you give it a try to see whether it works or not ? Thanks !
Flags: needinfo?(lulu.tian)

Comment 14

4 years ago
Posted image charging.png
This issue has been verified successfully on Flame 3.0 with the same steps in comment 0.
See attachment:charging.png
Rate:0/3

Device: Flame 3.0 (pass)
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.193600
Firmware Date          Tue Apr  7 19:36:12 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(lulu.tian)

Comment 15

4 years ago
Hi EJ,
Could you help to uplift the patch on v2.2? Thanks! :)
Flags: needinfo?(ejchen)
Ahh, it seems that there is no 2.2+ flag on this bug, based on comment 15, mark 2.2? first to see whether this bug would be 2.2+ after triage.

Thanks Sue, I'll keep the ni? on me first and see what's going on later.
blocking-b2g: --- → 2.2?
Hi EJ,
2.2+ Thanks!
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8588900 [details] [review]
[gaia] EragonJ:bug-1118018 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: the text would be overlapped
[Testing completed]: yes, with manual test
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Flags: needinfo?(ejchen)
Attachment #8588900 - Flags: approval-gaia-v2.2?
Attachment #8588900 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 20

4 years ago
This issue has been verified successfully on Flame 2.2 with the same steps in comment 0.
See attachment:v2.2_verified_passed.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.040848
Firmware Date          Sun Apr 19 04:08:59 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+][MGSEI-RTL-3F]
Whiteboard: MGSEI-RTL-3F
You need to log in before you can comment on or make changes to this bug.