[RTL][Settings] 3G appears to the left of the word preferred under network operator

RESOLVED DUPLICATE of bug 1154637

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 1154637
5 years ago
4 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified)

Details

Attachments

(3 attachments)

Description:
3G appears to the left of the word "preferred" under network operator. 

Repro Steps:
1) Update a Flame device to BuildID: 20150106010234.
2) Set the device language in Arabic under Settings > Language.
3) Tap on "Cellular & Data".
4) Tap on "SIM 1".
5) Tap on "Network Operator".
6) Tap on "Network Type" and observe "3G preferred".
  
Actual:
3G appears to the left of the word "preferred".
  
Expected: 
3G appears to the right of the word "preferred".
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150106010234
Gaia: b77e0d56d197e0ee02d801a25c784130d888c9db
Gecko: 2a193b7f395c
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
RTL triage: P2 -- will make a best effort to get this into the 2.2 release.
Priority: -- → P2
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
feature-b2g: --- → 2.2+
Assignee: nobody → arthur.chen
Status: NEW → ASSIGNED
The string is display as what we have in the string file. KTucker, could you confirm whether this is a translation issue?
Flags: needinfo?(ktucker)
This is what it shows in the mercurial document:
259 operator-networkType-prefer3G=تفضيل 3G
<DerekH>    260 operator-networkType-2G=2G فقط
<DerekH>    261 operator-networkType-3G=3G فق

All 3 of these strings currently do not match what is shown on the phone. See the attached screenshot.
Flags: needinfo?(ktucker)
Posted image preferred network
This is the result after I put the LRE and PDF characters. The last two options look fine. But for the first option it seems the number adjacent to the Arabic words is always being rendered on the left. Stas, any ideas on this? This might be a platform bug?
Flags: needinfo?(stas)
Rami, can you help us here, please?

The translation in Pootle has "3G" in the left hand side of the message.  Is this correct?

http://mozilla.locamotion.org/ar/firefoxos/translate/apps/settings/settings.properties.po#search=operator-networkType&sfields=locations&unit=6011996

It also looks like there's something weird going on in hg:

https://hg.mozilla.org/gaia-l10n/ar/file/61c4b0f03e70/apps/settings/settings.properties#l259

Any idea why 3 and G are separated?
Flags: needinfo?(stas) → needinfo?(rami223)

Comment 8

5 years ago
Stas,
I modified the text in locamotion in order to fix the separation between the 3 and G
Flags: needinfo?(rami223)
Assignee: arthur.chen → nobody
Component: Gaia::Settings → ar / Arabic
Product: Firefox OS → Mozilla Localizations
Thanks, Rami!  I moved this bug to the Arabic component and I'm marking it as resolved fixed as per the following changeset:

https://hg.mozilla.org/gaia-l10n/ar/rev/e0a99f1074fb
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED

Comment 10

4 years ago
This issue has been verified successfully on Flame 2.2.
Reproduce rate:0/5.
Attachment:3Gnetwork.png

Flame 2.2 build:
Build ID               20150203002504
Gaia Revision          cd62ff9fe199fb43920ba27bd5fdbc5c311016fc
Gaia Date              2015-02-03 00:56:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/11d93135c678
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150203.041704
Firmware Date          Tue Feb  3 04:17:15 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]

Comment 11

4 years ago
Posted image 3G network.png
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15712/
Flags: in-moztrap+

Updated

4 years ago
See Also: → 1150428
I'm sorry why was this bug closed?
Rami said he fixed the space issue between 3 and G, but I don't see that he answered the part about 3G being on the left of right of the word (see comment 8). 
Also, looking at https://hg.mozilla.org/gaia-l10n/ar/rev/e0a99f1074fb  I see localizer chose to put 3G, 2G etc on the LEFT side of the word, not the right side as it currently appears. 
So this bug is still open and is not an l10n bug. I checked on today's build, issue still repros.
Closing as resolved duplicate of Bug 1154637
Status: VERIFIED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1154637
You need to log in before you can comment on or make changes to this bug.