Closed Bug 1150428 Opened 6 years ago Closed 6 years ago

[RTL][Settings]The text of "3G" and "2G" are displayed at the left side of the word "preferred".

Categories

(Mozilla Localizations :: ar / Arabic, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 affected, b2g-master affected)

RESOLVED INVALID
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: lulu.tian, Unassigned)

References

Details

Attachments

(2 files)

Attached image 3G preferred.png
[1.Description]:
[RTL][v2.2 & v3.0][Settings]When user select the value of "Network Type", the text of "3G" and "2G" are displayed at the left side of the word "preferred".
See attachment:3G preferred.png

[2.Testing Steps]: 
Precondition: Insert SIM cards into device.
1. Set your phone language to Arabic. 
2. Launch Settings app. 
3. Tap "Cellular & Data". 
4. Tap "SIM 1" or "SIM 2". 
5. Tap "Network Operator". 
6. Tap value selector button of "Network Type". 

[3.Expected Result]: 
6. The text of "3G" and "2G" should be displayed at the right side of the word "preferred".

[4.Actual Result]: 
6. The text of "3G" and "2G" are displayed at the left side of the word "preferred".

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150401002624
Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4
Gaia Date              2015-03-31 21:48:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.042225
Firmware Date          Wed Apr  1 04:22:36 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150401160204
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.193001
Firmware Date          Wed Apr  1 19:30:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
15712
QA Whiteboard: [rtl-impact]
Whiteboard: MGSEI-RTL-3F
This is l10n, not RTL. I don't know if it's a bug, because we don't know how native speakers form their sentences. Let's ask Rami for input. If this is not a bug, we can close it as resolved-invalid.
No longer blocks: settings-rtl
Component: Gaia::Settings → ar / Arabic
Flags: needinfo?(rami223)
Product: Firefox OS → Mozilla Localizations
(In reply to Delphine Lebédel [:delphine - in SA for l10n events until April 7th, expect delay in answering] from comment #1)
> This is l10n, not RTL. I don't know if it's a bug, because we don't know how
> native speakers form their sentences. Let's ask Rami for input. If this is
> not a bug, we can close it as resolved-invalid.

This issue had been fixed in bug 1118453, but it can be repro on latest build of Flame 2.2 / 3.0
See Also: → 1118453
This is correct no action is needed
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(rami223)
Resolution: --- → INVALID
Attached image wrong_3G_preferred.png
Hi Rami,
The "3G preferred" is shown as "preferred 3G" in value selector at Network Operator view, but it is shown as "3G preferred" at value select list. Could you help to confirm which one is correct? Thanks!
See attachment:wrong_3G_preferred.png
Flags: needinfo?(rami223)
The correct one is the one in the picture on the right (with black background).
Flags: needinfo?(rami223)
(In reply to Rami Khader from comment #5)
> The correct one is the one in the picture on the right (with black
> background).

Can we reopen this bug to tracing the wrong text of "preferred 3G" in value selector at Network Operator view?
See Also: → 1154637
I have opened a new bug to tracing the wrong text of "preferred 3G" in value selector at Network Operator view. See bug 1154637
QA Whiteboard: [rtl-impact] → [rtl-impact]MGSEI-RTL-3F
Whiteboard: MGSEI-RTL-3F
You need to log in before you can comment on or make changes to this bug.