[RTL][Browser] Settings icon is left-aligned on the error message

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: ychung, Assigned: mikehenrty)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(5 attachments)

Reporter

Description

5 years ago
Posted image IconOnLeft.png
Description:
On the network connection error message, the settings icon is located on the left.
   
Pre-requisite: The device has no data or Wi-Fi network connected. 

Repro Steps:
1) Update a Flame device to BuildID: 20150108010221.
2) Set the device language in Arabic under Settings > Language.
3) Open Browser app.
4) Navigate to any website.
5) Observe the network error message.

Actual:
The settings icon is left-aligned.
  
Expected: 
The setting icon is right-aligned.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150108010221
Gaia: d4dac29613076bdba3cb8adc217deadb08a2ac20
Gecko: 70de2960aa87
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot
Reporter

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
RTL triage: P2 -- will make a best effort to get this into the 2.2 release.
Priority: -- → P2
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
feature-b2g: --- → 2.2+
Flags: in-moztrap+
Assignee: nobody → gmarty
Duplicate of this bug: 1127346
yoink.
Assignee: gmarty → mhenretty
Comment on attachment 8560127 [details] [review]
[PullReq] mikehenrty:bug-1119398-rtl-net-error to mozilla-b2g:master

Kevin, wanna take a look?
Attachment #8560127 - Flags: review?(kgrandon)
While fixing this bug, I noticed some peculiar behavior with buttons and padding in RTL. I filed bug 1130231 to investigate this. If bug 1130231 is indeed a bug, a fix to that would break the layout of the net_error page in RTL mode. So let's wait for an answer in that bug before landing this fix.
Depends on: 1130231
Comment on attachment 8560127 [details] [review]
[PullReq] mikehenrty:bug-1119398-rtl-net-error to mozilla-b2g:master

Seems strange to have selectors that are not under #net-error in this css file, but the code looks fine to me. Nice job.
Attachment #8560127 - Flags: review?(kgrandon) → review+
Comment on attachment 8560127 [details] [review]
[PullReq] mikehenrty:bug-1119398-rtl-net-error to mozilla-b2g:master

This solution won't work once they fix bug 1130231, which is looks like they are actively working on. I'll fix my patch once that bug lands.
Attachment #8560127 - Flags: review+
Target Milestone: --- → 2.2 S6 (20feb)
Comment on attachment 8560127 [details] [review]
[PullReq] mikehenrty:bug-1119398-rtl-net-error to mozilla-b2g:master

Bug 1130231 has landed in master, so I added the -moz-padding-start selector that is the correct fix here to the existing patch.
Attachment #8560127 - Flags: review?(kgrandon)
Comment on attachment 8560127 [details] [review]
[PullReq] mikehenrty:bug-1119398-rtl-net-error to mozilla-b2g:master

lgtm.
Attachment #8560127 - Flags: review?(kgrandon) → review+
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8560127 [details] [review]
[PullReq] mikehenrty:bug-1119398-rtl-net-error to mozilla-b2g:master

Would like to uplift this simple RTL fix.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature implementation.
[User impact] if declined: Poor RTL experience.
[Testing completed]: Manual, simple css patch.
[Risk to taking this patch] (and alternatives if risky): Low risk, simple css change.
[String changes made]: None.
Attachment #8560127 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8560127 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+

Comment 15

4 years ago
This issue has been verified successfully on Flame 3.0.
Reproduce time:0/5.
Attachment:Verify_RTL_Browser.png

Flame 3.0 build:

Gaia-Rev        d5a71cedb37dd45f439f672489db3994b349ac43
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/3094601af679
Build-ID        20150212010213
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150212.042740
FW-Date         Thu Feb 12 04:27:51 EST 2015
Bootloader      L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]

Comment 16

4 years ago

Comment 17

4 years ago
This issue has been verified fial on latest Flame2.2
Verify video:"1110.mp4".
See log:"logcat_1110.txt"

Flame 2.2 build:
Build ID               20150216002503
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.040540
Firmware Date          Mon Feb 16 04:05:52 EST 2015
Bootloader             L1TC000118D0

Comment 18

4 years ago
Posted video Fail video: 1110.mp4
Duplicate of this bug: 1133632
This does not happen with today v2.2. I'm pretty sure it is the same problem we had in bug 1132646: there was a gecko build that had a bug with -moz-padding-start (see comments 4 and following)
Keywords: qawanted
the qawanted is for 2.2. Master is ok.
This issue is verified fixed for 2.2 Flame KK.

Actual Results: The icon is right aligned and does not overlap the text.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150218002515
Gaia: da509caa7395d3d090ce973e8de082b4680a590d
Gecko: 96da179a7d3a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
Keywords: qawanted
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.