Closed Bug 1119633 Opened 6 years ago Closed 6 years ago

[FFOS2.0][Woodduck][STK]"Send message'displayed during "send ss without alpha id".

Categories

(Firefox OS Graveyard :: General, defect, P2)

defect

Tracking

(blocking-b2g:2.0M+, b2g-v2.0 affected, b2g-v2.0M fixed, b2g-v2.1 affected, b2g-v2.1S affected, b2g-v2.2 affected, b2g-master fixed)

RESOLVED FIXED
blocking-b2g 2.0M+
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- fixed
b2g-v2.1 --- affected
b2g-v2.1S --- affected
b2g-v2.2 --- affected
b2g-master --- fixed

People

(Reporter: sync-1, Assigned: selee)

References

Details

Attachments

(3 files)

DEFECT DESCRIPTION:[STK]"Send message'displayed during "send ss without alpha id".
 
  REPRODUCING PROCEDURES:
 1. Load a simcard to the phone which can send stk command;
 2. Execute "send ss->STN02005->without alpha id", "Send message"displayed during "send ss" executed.--ko
 
  EXPECTED BEHAVIOUR:
 2. Execute "send ss->STN02005->without alpha id", "Send ss" should displayed during "send ss"executed but not "Send message".
 
 Reporter's phone number: 0752-2639695
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Hi all,
  find in the log:
  01-08 16:20:03.476   165   630 I Gecko   : RIL Worker: [0] commandNumber = 1 typeOfCommand = 11 commandQualifier = 0
01-08 16:20:03.504   165   165 I GeckoDump: [system] STK Proactive Command for SIM 89441000000400617452: {"commandNumber":1,"typeOfCommand":17,"commandQualifier":0,"rilMessageType":"stkcommand","options":{"text":""},"rilMessageClientId":0}
01-08 16:20:03.505   165   165 I GeckoDump: [system] STK_CMD_SEND_SS:{"text":""}
  see the code handle like that:
at icc_worker 0x11
  options.text = _('icc-alertMessage-defaultmessage');
at system.en-US.properties:
  icc-alertMessage-defaultmessage=Sending message
 
  So, if we need another string stands for "send ss"?
Hi Sean,
Please help to check the problem. Thanks!
blocking-b2g: --- → 2.0M?
Flags: needinfo?(selee)
Assignee: nobody → selee
Flags: needinfo?(selee)
Hi Pengfei,

This seems like only string replacement issue.

Will it be helpful if you modify 
icc-alertMessage-defaultmessage=Sending message
to 
icc-alertMessage-defaultmessage=Send SS
in system.en-US.properties?
Flags: needinfo?(pengfei.huang.hz)
(In reply to Sean Lee [:seanlee] from comment #4)
> Hi Pengfei,
> 
> This seems like only string replacement issue.
> 
> Will it be helpful if you modify 
> icc-alertMessage-defaultmessage=Sending message
> to 
> icc-alertMessage-defaultmessage=Send SS
> in system.en-US.properties?
Dear Sean,
  The string "icc-alertMessage-defaultmessage" is used at 0x12 and 0x13 so I guess they should be different. Follow Mozilla design, maybe we have to tell them and name the key and value in system.en-US.properties.
Flags: needinfo?(pengfei.huang.hz)
Hi Pengfei,

I add Send SS, Send USSD and Send SMS default message.
Please help to try it. Thank you.
Flags: needinfo?(pengfei.huang.hz)
(In reply to comment #5)
 > Comment from Mozilla:Hi Pengfei,
 > 
 > I add Send SS, Send USSD and Send SMS default message.
 > Please help to try it. Thank you.
 > 
 
 Hi Sean,
   Your code wokes well. Pass test.
   thank you.
HI Sean,
Good job. Please process review. Thanks!
Status: NEW → ASSIGNED
blocking-b2g: 2.0M? → 2.0M+
Flags: needinfo?(selee)
Attached file PR for master
Hello Fernando,

Here is my PR for this bug. Please help to review it. Thank you.
Flags: needinfo?(selee)
Attachment #8548705 - Flags: review?(frsela)
Great help, Thanks Sean.
Flags: needinfo?(pengfei.huang.hz)
Duplicate of this bug: 1119135
Comment on attachment 8548705 [details] [review]
PR for master

Thank you !

Only one nit; please, check if the removed string is not used anywhere in Gaia and if not used, we can remove it ;)
Attachment #8548705 - Flags: review?(frsela) → review+
Hi Fernando,

icc-alertMessage-defaultmessage is removed because it won't be used after applying the patch.
Thank you!
Dear Wayne Teng,
   we can close this bug, please see TCL bug896766.
   Thanks.
You need to log in before you can comment on or make changes to this bug.