Closed Bug 1119135 Opened 6 years ago Closed 6 years ago

[FFOS2.0][Woodduck][STK]STK command executed not ok when command with empty alpha id.

Categories

(Firefox OS Graveyard :: General, defect, P2)

defect

Tracking

(blocking-b2g:2.0M?)

RESOLVED DUPLICATE of bug 1119633
blocking-b2g 2.0M?

People

(Reporter: sync-1, Assigned: selee)

References

Details

Attachments

(2 files)

DEFECT DESCRIPTION:[STK]STK command executed not ok when command with empty alpha id. 
 
  REPRODUCING PROCEDURES:
 1. Load a simcard to the phone which can send STK command;
 2. Execute "play tone->5009->empty alpha id", the command executed with alpha id.--ko1;
 3. Execute "send sms->STN01015->empty alpha id", the command executed with alpha id.--ko2;
 4. Execute "send ss->-STN02005->empty alpha id", the command executed with alpha id.--ko3;
 5. Execute "send ussd->-STN10003->empty alpha id", the command executed with alpha id.--ko4;
 
  EXPECTED BEHAVIOUR:
 2. Execute "play tone->5009->empty alpha id", the command executed shoudl without alpha id.
 3. Execute "send sms->STN01015->empty alpha id", the command executed should without alpha id.
 4. Execute "send ss->-STN02005->empty alpha id", the command executed should without alpha id.
 5. Execute "send ussd->-STN10003->empty alpha id", the command executed should without alpha id.
 
 
 Reporter's phone number: 0752-2639695.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Hi Sean,
Can you help to check this issue? Thanks!
Blocks: Woodduck
blocking-b2g: --- → 2.0M?
Flags: needinfo?(selee)
See Also: → 902768
Hi all,
  The Spec 3GPP 6.4.5:
The use of this alpha identifier by the ME is described below:
- If the alpha identifier is provided by the SIM and is not a null data object, the ME shall use it to inform the user. If
 an icon is provided by the SIM, the icon indicated in the command may be used by the ME to inform the user, in
addition to, or instead of the alpha identifier, as indicated with the icon qualifier (see subclause 6.5.4).
- If the alpha identifier is provided by the SIM and is a null data object (i.e. length = '00' and no value part), the ME
 should not give any information to the user.
- If the alpha identifier is not provided by the SIM, the ME may give information to the user concerning what is
 happening.
Dear Sean,
  The case "play tone->5009->empty alpha id" will play a tone and display the alpha id which shouldn't display.
  please check the log.
Assignee: nobody → selee
Flags: needinfo?(selee)
Attached file Alpha_ID_1_12.zip
Other cases log.
Status: NEW → ASSIGNED
Hi Pengfei,

Is this bug very similar to bug 1119633?
Will the patch from comment 6 bug 1119633 be helpful for this bug?


About tone play part, Gaia won't show a dialog if the options.text is null.
Is that acceptable?
Flags: needinfo?(pengfei.huang.hz)
(In reply to Sean Lee [:seanlee] from comment #5)
> Hi Pengfei,
> 
> Is this bug very similar to bug 1119633?
> Will the patch from comment 6 bug 1119633 be helpful for this bug?
> 
> 
> About tone play part, Gaia won't show a dialog if the options.text is null.
> Is that acceptable?
  yes, that's expected. and others case including "sendSS" are the same.
Flags: needinfo?(pengfei.huang.hz)
Could it be marked as duplicate to bug 1119633?
Flags: needinfo?(pengfei.huang.hz)
(In reply to Sean Lee [:seanlee] from comment #7)
> Could it be marked as duplicate to bug 1119633?
Yes, mark it please.
Flags: needinfo?(pengfei.huang.hz)
Per comment 8, marked as duplicate to bug 1119633
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1119633
Dear Wayne Teng,
   please see TCL bug896752 which has been POSTPONED, we can close or postponed this bug, 
   Thanks.
You need to log in before you can comment on or make changes to this bug.