[Text Selection]Send out caret's position for the short cut mode

RESOLVED FIXED in Firefox 38

Status

()

defect
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: pchang, Assigned: mtseng)

Tracking

37 Branch
mozilla38
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(5 attachments, 9 obsolete attachments)

793 bytes, patch
roc
: review+
Details | Diff | Splinter Review
4.73 KB, patch
roc
: review+
Details | Diff | Splinter Review
6.80 KB, patch
Details | Diff | Splinter Review
8.03 KB, patch
Details | Diff | Splinter Review
2.39 KB, patch
Details | Diff | Splinter Review
Reporter

Description

4 years ago
This bug is created based on bug 1117684 comment 3 and I just clone the comment in the following.

1. launch bubble by touchcarettap on column A, then long tap on empty column B, the bubble's position seems incorrect. We need a selectionchanged event from gecko when long tapping column B.
Reporter

Updated

4 years ago
Reporter

Updated

4 years ago
Assignee: nobody → pchang
Reporter

Updated

4 years ago
Priority: -- → P2
Reporter

Comment 1

4 years ago
Un-assign myself. Morris, please check this issue with Jeremy.
Flags: needinfo?(mtseng)
Reporter

Updated

4 years ago
Assignee: pchang → nobody
Reporter

Comment 2

4 years ago
Feel free to assign to others if you are not the right owner
Assignee: nobody → mtseng
Fix build break.
Attachment #8552293 - Attachment is obsolete: true
fix build break again.
Attachment #8552815 - Attachment is obsolete: true
Flags: needinfo?(mtseng)
Rename reason name.
Attachment #8552294 - Attachment is obsolete: true
Rename reason name.
Attachment #8552295 - Attachment is obsolete: true
Attachment #8552903 - Flags: review?(roc)
Attachment #8552929 - Flags: superreview?(bugs)
Attachment #8552934 - Flags: review?(roc)
Attachment #8552296 - Flags: review?(roc)
Attachment #8552929 - Flags: superreview?(bugs) → superreview+
Comment on attachment 8552903 [details] [diff] [review]
Part 1: Move GetSelectionBoundingRect to nsContentUtils v3.

Review of attachment 8552903 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/base/nsContentUtils.h
@@ +2168,5 @@
>                                          int32_t& aOutStartOffset,
>                                          int32_t& aOutEndOffset);
>  
>    /**
> +   * Takes a selection, and return selection's bounding rect.

You need to say what the rect is relative to.
Attachment #8552903 - Flags: review?(roc) → review+
Update to reviewer's comment
Attachment #8552903 - Attachment is obsolete: true

Comment 17

4 years ago
Triage: blocker
blocking-b2g: --- → 2.2+
Attachment #8552931 - Attachment is obsolete: true
Comment on attachment 8559595 [details] [diff] [review]
Part 1: Move GetSelectionBoundingRect to nsContentUtils v5. (carry r+: roc)

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: The position of shortcut bubble for copy/paste would be wrong when it appears.
Testing completed: on master
Risk to taking this patch (and alternatives if risky): low risk.
String or UUID changes made by this patch: none
Attachment #8559595 - Flags: approval-mozilla-b2g37?
Comment on attachment 8552929 [details] [diff] [review]
Part 2: Add taponcaret to SelectionState v2.

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: The position of shortcut bubble for copy/paste would be wrong when it appears.
Testing completed: on master
Risk to taking this patch (and alternatives if risky): low risk.
String or UUID changes made by this patch: none
Attachment #8552929 - Flags: approval-mozilla-b2g37?
Comment on attachment 8552934 [details] [diff] [review]
Part 3: Dispatch taponcaret using selectionstatechanged event v3.

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: The position of shortcut bubble for copy/paste would be wrong when it appears.
Testing completed: on master
Risk to taking this patch (and alternatives if risky): low risk.
String or UUID changes made by this patch: none
Attachment #8552934 - Flags: approval-mozilla-b2g37?
Comment on attachment 8555694 [details] [diff] [review]
Part 4: Remove all touchcarettap event listener v2. (carry r+: roc)

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: The position of shortcut bubble for copy/paste would be wrong when it appears.
Testing completed: on master
Risk to taking this patch (and alternatives if risky): low risk.
String or UUID changes made by this patch: none
Attachment #8555694 - Flags: approval-mozilla-b2g37?
Looks like we have gij failed on try. Clear checkin-needed first.
Keywords: checkin-needed
Looks like my try on gij didn't fetch latest gaia. With latest gaia on my local machine, it looks well. Add checkin-needed again.

try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=68f0c7b0442b
Keywords: checkin-needed
Sorry, but I'd like to see a green Try run that includes the Gaia commit in question.
Keywords: checkin-needed
Attachment #8552929 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Attachment #8552934 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Attachment #8555694 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Attachment #8559595 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Tested it in my local machine.
Landed the bustage fix on b2g-inbound as well to keep the branches in sync.
https://hg.mozilla.org/integration/b2g-inbound/rev/197838b4972e
You need to log in before you can comment on or make changes to this bug.