Open Bug 1121151 Opened 8 years ago Updated 3 months ago

[autoconfiguration] still can't create the account because incoming server already exists (creating two accounts on same server fails)


(Thunderbird :: Account Manager, defect, P5)


(Not tracked)


(Reporter: rkent, Unassigned)



(Whiteboard: [no l10n impact])

+++ This bug was initially created as a clone of Bug #490430 +++

There have been multiple reports of continuing issues with creating a second account with the same server, post bug 490430. For some reason people keep posting there rather than following the suggestion in the comments to open a new bug. So I'll just do it. Here is the new bug!

See bug 490430 for descriptions of current issues, but continue any discussions here.
2 of my PCs was affected from this bug. For me it happens when you do this things:

1. Create new email account
2. Put wrong password and do auto-configure for server. 
3. Then press 'OK'. Cause wrong password cant do forward, so cancel procedure and close thunderbird
4. Reopen  thunderbird, try to re-create previous email account, but with right credential:

"incoming server already exists"

Now edit prefs.js ( do a backup first ) and delete this string related to your new email account:

user_pref("", "C:\\Users\\XXXXX\\AppData\\Roaming\\Thunderbird\\Profiles\\vaasdd3234.default\\ImapMail\\");
user_pref("", "[ProfD]ImapMail/");
user_pref("mail.server.server5.hostname", "");
user_pref("mail.server.server5.max_cached_connections", 5);
user_pref("mail.server.server5.socketType", 2);
user_pref("mail.server.server5.storeContractID", ";1");
user_pref("mail.server.server5.type", "imap");
user_pref("mail.server.server5.userName", "");

PS: V 31.4.0 windows 7 x64
Additional case for your consideration.
1. IMAP account created: (24 months ago)
2. Deleted account after some activity (12 months ago)
3. Create a NEW IMAP account, using the wizard, with the same address

This fails with the "Incoming server already exists."  error.

Closed Thunderbird.
Searched prefs.js and found 'mail.server.server3' (old account) and 'mail.server.server41' (new attempt), with identical info.

I deleted both sets of server information.
Restarted Thunderbird and then successfully created the "NEW" account -
I have successfully read and written mail via the new account.

Windows 7 Home Premium
T'bird ver 31.6.0
Lightning ver 3.3.3
I have encountered this problem as a result of using the addon Master Password+ 1.21.3.  Not sure if this instance of the problem is considered a Thunderbird bug or a Master Password+ bug.

I went to add a new IMAP account (after filling in its server details), but dismissed the Master Password+ password entry box (which popped up in order for me to save the new IMAP account's password) and got stuck with this problem.  Removing the new mail.server.server{x} configuration entries from the configuration editor and restarting Thunderbird solved it.

Thunderbird 37.6.0 x86_64
Gentoo Linux x86_64
This is definitely not fixed. v52 on OSX, adding any mail account is impossible. Tried removing servers from prefs.js, shreding the profile from the Mac user, and removing/reinstalling Thunderbird completely. Still broken.

When adding an account it claims "Password OK" but the form doesn't disappear. I have to close the form either with Cancel or the red button. The account does not appear in the accounts list, but trying to add it again just gives "incoming server already exists".
I just got burned on this under TH 52.2.1 for Windows

I had the same issue with Thunderbird 60.9.0 on Linux when trying to move my account from POP3 to IMAP.
I was able to solve it by:

  1. Closing TB
  2. Editing the prefs.js and deleting all lines referring to the new account
  3. Deleting all files and directories in the ImapMail directory referring to the new account
  4. Moving panacea.dat to panacea.bak
  5. Restarting TB and creating the account with 'Save password' not checked.
Priority: P1 → P5

This still happens with Mozilla Thunderbird 68.3.0 (and I guess current versions) (at least with Microsoft Windows). As the only solution is to delete the profile or to manually edit some profile files, it should be high priority.

Severity: normal → S3

Our support at hosting company is receiving more and more support requests related to this bug lately.

8 years later, this still seems to be a problem. I am now getting this error after having to "cancel" the automatic setup since it was just spinning forever and not going anywhere. Did Thunderbird just wreck my profile? I really don't have the time to set up everything from scratch, this profile has been with me for more than 10 years.

Okay, turns out deleting the "serverN" from prefs.js by hand works. But the entire situation is pretty bad: I basically have one shot at entering the correct password. If I give a wrong password, Thunderbird will just be stuck at "checking password", and if I cancel that then the only way to ever try again to set up this account is to edit the prefs.js by hand or create an all-new profile.

You need to log in before you can comment on or make changes to this bug.