[autoconfiguration] can't create the account because incoming server already exists (creating two accounts on same server fails)

RESOLVED FIXED in Thunderbird 3.0rc1

Status

Thunderbird
Account Manager
P1
normal
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: Usul, Assigned: bwinton)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 3.0rc1
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact])

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

9 years ago
Trying to finish my yahoo.fr configuration. I get an error that the incoming server already exists when I press the create button account. Nothing much in the Error console. 

What should I log to figure out what's going on here David ?
(Reporter)

Updated

9 years ago
Blocks: 422814

Comment 1

9 years ago
does it already exist?
(Reporter)

Comment 2

9 years ago
No - but I still get the error. or if it exist it's not visible in the UI. After a quick grep in my profile dir I have :

prefs.js:user_pref("mail.server.server7.directory-rel", "[ProfD]Mail/pop.mail.yahoo.fr");
prefs.js:user_pref("mail.server.server7.hostname", "pop.mail.yahoo.fr");
prefs.js:user_pref("mail.server.server8.hostname", "pop.mail.yahoo.fr");

Comment 3

9 years ago
yes, that server exists, then. It sounds like we created it and then failed at some point in the verification process, and didn't clean it up. Perhaps it's related to that msgWindow exception in js you saw - that may have prevented us from getting to the code that cleans up the server.

Updated

9 years ago
Summary: [autoconfigration] can't create the account because incoming server already exists → [autoconfiguration] can't create the account because incoming server already exists
(Reporter)

Updated

9 years ago
Component: General → Account Manager
QA Contact: general → account-manager
David, what's the expected behaviour if user creates TWO separate accounts on same server:
1) user1@yahoo.fr AND
2) user2@yahoo.fr 

a) Will TB create:
prefs.js:user_pref("mail.server.server1.hostname", "pop.mail.yahoo.fr");
prefs.js:user_pref("mail.server.server2.hostname", "pop.mail.yahoo.fr");

b) Or will it bundle the same servers (but for different accounts!) in one entry like this:
prefs.js:user_pref("mail.server.server1.hostname", "pop.mail.yahoo.fr");

I had the same problem as Ludovic and it was just because I was trying to setup two different accounts (two different usernames) with the same email provider (one server). Even if a) is expected behaviour, your hypothesis about "not cleaning up something" might still be right, because I might have gone back and forth within autoconfiguration a few times. Although I'm pretty sure I never pressed "Create Account" for the second one yet, and otherwise it's a clean profile.
OS: Mac OS X → All
Hardware: x86 → All
Summary: [autoconfiguration] can't create the account because incoming server already exists → [autoconfiguration] can't create the account because incoming server already exists (creating two accounts on same server fails)
Just had a look at prefs.js and the expected behaviour is obviously a), with account-specific-settings like:
user_pref("mail.server.server1.name", "user1@yahoo.fr");
user_pref("mail.server.server1.num_days_to_leave_on_server", 14);

So just take the above as a note that this bug can occur to everyday user when setting up two accounts on same server.

Comment 6

9 years ago
you can have multiple accounts on the same server - the user name + hostname is what has to be unique. I've set up several gmail accounts, for example, using autoconfig.
Garbage of server.serverX was observed by next test of autoconfiguration.
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090914 Shredder/3.0b4pre

(1) Create a dummy POP3 account. (a1@a.a.a,POP3,hostname=a.a.a,userName=a1)
> mail.server.serverA.hostname = a.a.a / mail.server.serverA.userName = a1
(2) Try to create dummy POP3 account with same hostname/userName(a1@a.a.a).
    Wait for POP3/hostname=a.a.a/userName=a1, [Manual Configuration]/[Cancel].
(3) Click [Manual Creation]
(3-1) Next exception.
> Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE)
> [nsIMsgAccountManager.createIncomingServer]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"
> location: "JS frame :: chrome://messenger/content/accountcreation/createInBackend.js :: createAccountInBackend :: line 60"  data: no]
(3-2) Garbage of sever.serverX was created.
      (X is not equal to A, serverX is not pointed by any accountN.server)  
> mail.server.serverX.hostname = a.a.a / mail.server.serverX.userName = a1
(3-3) No feed back at UI. [Manual Configuration]/[Cancel] panel still remained.
(4) Click [Cancel] => Config Editor still displayed above entries.
(5) Terminate Tb => prefs.js was same as above.
(6) Create new/non-duplicated account.
    Above mail.server.serverX.xxx were replaced by data for the new account.
=> Unable to see "error that the incoming server already exists" by [Manual Configuration]. It's possibly due to exception of (3-1).  

If user changed server name or user name and realhostname/realuserName entry is created, Bug 303542 can occur, and "error that the incoming server already exists" can happen. However, if it's simply Bug 303542, "it's not visible in the UI" in Comment #2 won't occur with Tb 3, because duplicated account is seen at "Account Settings" panel and folder pane if Tb 3.
>(Comment #2 From Ludovic)
> but I still get the error. or if it exist it's not visible in the UI.

Ludovic, check prefs.js entries, please.
1. mail.accountmanager.accounts = accountA, ..., accountN, ...
2. mail.account.accountN.identities = idP
   mail.account.accountN.server     = serverX
3. mail.server.serverX.type = <pop3, imap, none, ...>
   mail.server.serverX.hostname     = <server name, if no realhostname>
   mail.server.serverX.realhostname = <server name used for login>
   mail.server.serverX.userName     = <userid, if no realuserName>
   mail.server.serverX.realuserName = <userid used for login>
Is there duplicated serverX entry?
Is there serverX entry which is not pointed by accountN.server?

Comment 8

9 years ago
I get into this error in a slightly different way. I'm using a shared server, where the user name needs to be "kent@caspia.com" not "kent".

Here's what I have done, twice now (and you would think I would learn!):

1) setup new account in account wizard, in a brand new profile. It scans and suggests "IMAP" with username "kent"
2) edit the account, changing the server type to "POP", and ask to retest.
3) AM spins on the bad username, and after about 5 seconds I get impatient and click "edit account" to fix it, and enter my correct username "kent@caspia.com"
4)I request a retest, at which point it comes back with the error from this bug's description, and I am hosed.

Comment 9

9 years ago
thx for the steps to reproduce, Kent. That definitely sounds like we're not clearing up the server in that case.

Comment 10

9 years ago
I'm going to mark this blocking, since it's easy to get into this state, and very hard to get out of it. Blake, do you think you might have time to look at this?
Flags: blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0rc1
(Assignee)

Comment 11

9 years ago
Yeah.  I've been planning on doing some overhaul of the autoconfig logic as part of bug 515371, so fixing this would slip right in to that work.
Assignee: nobody → bwinton
Status: NEW → ASSIGNED

Updated

9 years ago
Whiteboard: [no l10n impact]
(Assignee)

Updated

9 years ago
Priority: -- → P1
(Assignee)

Comment 12

9 years ago
In https://bugzilla.mozilla.org/show_bug.cgi?id=518171#c3, Magnus said:
> Not this bug but i noticed it flashed "password ok" after clicking finish,
> even though i didn't enter any password.

And this seems like a good bug to fix that in, what with all the other changes I'm making for this one.  :)
(Assignee)

Comment 13

9 years ago
Created attachment 404311 [details] [diff] [review]
A patch to fix the bug in Comment #7.

This patch doesn't fix the bugs in comments #8 or #12.

But since it does fix the bug in comment #7, and since smaller patches are easier to review, I thought I would try to get it in on its own.

Thanks,
Blake.
Attachment #404311 - Flags: superreview?(bienvenu)
Attachment #404311 - Flags: review?(philringnalda)
(Assignee)

Updated

9 years ago
Whiteboard: [no l10n impact] → [no l10n impact][first patch up][needs r/sr]

Comment 14

9 years ago
Comment on attachment 404311 [details] [diff] [review]
A patch to fix the bug in Comment #7.

Can you add a space after the // on these lines? And capitalize the sentence starting with "We"?

this:

+    let username = null;
+    if (outgoing.auth > 0)
+      username = outgoing.username;

can just be:

let username = outgoing.auth > 0 ? outgoing.username : null;

+  //When accounts have already been loaded in the panel then the first
+  //replacement will be overwritten when the accountvalues are written out
Attachment #404311 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 15

9 years ago
(In reply to comment #14)
> (From update of attachment 404311 [details] [diff] [review])
> +  //When accounts have already been loaded in the panel then the first
> +  //replacement will be overwritten when the accountvalues are written out
> Can you add a space after the // on these lines? And capitalize the sentence
> starting with "We"?

Fixed.

> +    let username = null;
> +    if (outgoing.auth > 0)
> +      username = outgoing.username;
> let username = outgoing.auth > 0 ? outgoing.username : null;

Fixed.

I'll wait for the new patch until I hear back from philor.

Thanks,
Blake.
(Assignee)

Updated

9 years ago
Whiteboard: [no l10n impact][first patch up][needs r/sr] → [no l10n impact][first patch up][needs r]
(Assignee)

Comment 16

9 years ago
Created attachment 404377 [details] [diff] [review]
A patch to fix the bug in comment #8.  (Based on top of the patch for comment #7.)

Okay, and this seems to fix the bug in comment 8 for me.

Kent, I would love it if you could apply these two patches, and try to reproduce the bug, just to check that I haven't missed anything.

The theory behind this change is that if the user has hit the "Manual Settings" button, then they kind of want the settings displayed on the screen, so we should just use those.  (The "replaceVariables" line is just cleanup, and I'm happy to revert it, if you'ld rather.)

Thanks,
Blake.
Attachment #404377 - Flags: superreview?(bienvenu)
Attachment #404377 - Flags: review?(philringnalda)
(Assignee)

Updated

9 years ago
Whiteboard: [no l10n impact][first patch up][needs r] → [no l10n impact][first patch up/needs r][second patch up/needs r+sr]

Updated

9 years ago
Attachment #404377 - Flags: superreview?(bienvenu) → superreview+
That's very cunning and probably acceptable reuse of strings, but reuse of strings is still l10n impact.
Whiteboard: [no l10n impact][first patch up/needs r][second patch up/needs r+sr] → [has l10n impact][first patch up/needs r][second patch up/needs r+sr]
On second thought, Blake says he's going to avoid the reused string.
Whiteboard: [has l10n impact][first patch up/needs r][second patch up/needs r+sr] → [no l10n impact][first patch up/needs r][second patch up/needs r+sr]
(Assignee)

Comment 19

9 years ago
Created attachment 404538 [details] [diff] [review]
A new patch to fix the bug in comment #7.

Here's a new patch, without the new error string, so that we can avoid the l10n impact.

In IRC, philor suggested that instead of complaining that the user has entered a previously-existing server, we just go ahead and use the one they asked for, so that's what I'm doing to get rid of the error message.

STR, cause I'm nice like that:
Fire up the autoconfig, and enter values of "a1@a.a.a" for all fields.  Hit the "Continue" button.
When it's done searching, hit "Manual Setup", and "OK".

Fire up the autoconfig again, and again enter values of "a1@a.a.a" for all fields.  Hit the "Continue" button again.  When it's done searching again, hit "Manual Setup", and notice the error.

Hit "OK", change the incoming server to "b.a.a", and hit "Manual Setup" once more.  This time there should be no error, you should have two accounts named "a1@a.a.a" in the account pane, one pointing at the incoming server "a.a.a" and one pointing at the incoming server "b.a.a".  They should both be pointing at the outgoing server "a.a.a".

When you remove the outgoing server "a.a.a", they should then both be pointing at the default outgoing server.


I'll get a new patch for comment 8 out tomorrow morning.

Thanks,
Blake.
Attachment #404311 - Attachment is obsolete: true
Attachment #404377 - Attachment is obsolete: true
Attachment #404538 - Flags: superreview?(bienvenu)
Attachment #404538 - Flags: review?(philringnalda)
Attachment #404311 - Flags: review?(philringnalda)
Attachment #404377 - Flags: review?(philringnalda)
Comment on attachment 404538 [details] [diff] [review]
A new patch to fix the bug in comment #7.

Works fine with my perhaps more common STR, which are "create an account, ..., remove the account and recreate it." Thanks!

Nit:

>-  if (config.incoming.type == "pop3")
>-  {
>+  if (config.incoming.type == "pop3") {

As owner-apparent, there'll certainly come a day when you can declare an end to the current psychotic style-of-the-file for curly brackets, but not yet, and not only for most but not all of them. r=me with all the brackets in the current, wrong-headed and wasteful and silly style-of-the-file.
Attachment #404538 - Flags: review?(philringnalda) → review+

Updated

9 years ago
Attachment #404538 - Flags: superreview?(bienvenu) → superreview+
Philor, what would it take to change these rules that are psychotic but that we claim we can't not follow?
That depends on which rules you mean. The rule I was applying was "we have a lot of different bracket styles which are acceptable in new files, so for patches to existing files you need to follow the existing style rather than adding or changing some things to be different, and if you're in a position to change the whole file, you'll know you are, and you won't do it in a patch for a blocker in between the final beta and the first rc" (where the latter half of that is unwritten), a rule which I don't think is at all psychotic, and for which a change would probably require a total turnover of owners and peers to a new set who enjoy either mixed bracket styles within a file, or reviewing constant bracket-war patches where every other patch changes the style for the entire file.

The psychotic style of createInBackend.js, where functions and ifs have brackets on new lines and trys have brackets on the same line, just needs a branch so we have a trunk again, and to kick this damn 3.0 out the door so we can get back to the part of Mozilla I enjoy, instead of the part that makes my left eye bulge out of my head and my right nostril keep starting to bleed.
(Assignee)

Comment 23

9 years ago
Created attachment 404597 [details] [diff] [review]
Let's stop moving some brackets around
[Checkin: Comment 28]

There you go.

(emailWizard.js already has mixed bracket styles (see onLoad()'s if vs. while, or oninputPassword() vs. onblurPassword()), so I left the brackets at the end of the if-line in my addition to advancedSettings(), as they don't conflict with anything else in that function.)

Thanks,
Blake.
Attachment #404538 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
(Assignee)

Comment 24

9 years ago
Created attachment 404610 [details] [diff] [review]
The previous patch for comment 8, updated to sit on top of the new patch for comment 7
[Checkin: Comment 29]

So, it looks like the previous patch now fixes the bug in comment #8, but I still think that this patch makes the "Manual Setup" button do more of what the user wants, by using the values they see in front of them to create the account.

(philor, let me know if you want me to undo the extra blank line, and/or the joining of the replaceVariables line.)

Thanks,
Blake.
Attachment #404610 - Flags: superreview?(bienvenu)
Attachment #404610 - Flags: review?(philringnalda)
(Assignee)

Updated

9 years ago
Whiteboard: [no l10n impact][first patch up/needs r][second patch up/needs r+sr] → [no l10n impact][first patch up/needs checkin][second patch up/needs r+sr]
Blank can you supply a checkin comment for attachment 404597 [details] [diff] [review] that also explains briefly what it fixes?
(Assignee)

Comment 26

9 years ago
(In reply to comment #25)
> Blank can you supply a checkin comment for attachment 404597 [details] [diff] [review] that
> also explains briefly what it fixes?

Sure, if you promise not to call me "Blank" again.  ;)

How about:
Fixes the first half of bug 490430 by letting the autoconfig find servers without usernames, checking for existing incoming servers in the manual setup, and letting us delete autoconfig-created SMTP servers.
?

Later,
Blake.
(Assignee)

Updated

9 years ago
Duplicate of this bug: 516572

Updated

9 years ago
Attachment #404610 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Updated

9 years ago
Whiteboard: [no l10n impact][first patch up/needs checkin][second patch up/needs r+sr] → [no l10n impact][first patch up/needs checkin][second patch up/needs r]
Comment on attachment 404597 [details] [diff] [review]
Let's stop moving some brackets around
[Checkin: Comment 28]

http://hg.mozilla.org/comm-central/rev/1eba8f892d19
Attachment #404597 - Attachment description: Let's stop moving some brackets around. → Let's stop moving some brackets around. [checked in]
Keywords: checkin-needed
Whiteboard: [no l10n impact][first patch up/needs checkin][second patch up/needs r] → [no l10n impact][second patch up/needs r]
Attachment #404610 - Flags: review?(philringnalda) → review+
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Whiteboard: [no l10n impact][second patch up/needs r] → [no l10n impact][patch for comment 12 needed]
Attachment #404597 - Attachment description: Let's stop moving some brackets around. [checked in] → Let's stop moving some brackets around [Checkin: Comment 28]
Comment on attachment 404610 [details] [diff] [review]
The previous patch for comment 8, updated to sit on top of the new patch for comment 7
[Checkin: Comment 29]


http://hg.mozilla.org/comm-central/rev/e29dda1c74b8
Attachment #404610 - Attachment description: The previous patch for comment 8, updated to sit on top of the new patch for comment 7. → The previous patch for comment 8, updated to sit on top of the new patch for comment 7 [Checkin: Comment 29]
Keywords: checkin-needed
(Assignee)

Comment 30

9 years ago
Created attachment 405532 [details] [diff] [review]
The patch for comment #12.

Since we only verify the logon if the password is set, we should only display the message that the password is ok if the password is set.

And I believe this is about it for this bug, so we can resolve it fixed, after this patch makes it through review.

Thanks,
Blake.
Attachment #405532 - Flags: superreview?(bienvenu)
Attachment #405532 - Flags: review?(philringnalda)

Updated

9 years ago
Attachment #405532 - Flags: superreview?(bienvenu) → superreview+

Updated

9 years ago
Whiteboard: [no l10n impact][patch for comment 12 needed] → [no l10n impact][needs r philor]
Attachment #405532 - Flags: review?(philringnalda) → review+
> we can resolve it fixed, after this patch makes it through review.

That's a pretty powerful bribe.

http://hg.mozilla.org/comm-central/rev/5266c477c044
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [no l10n impact][needs r philor] → [no l10n impact]
Hate to do it, but I just encountered this error, and think we might need to reopen this bug. 

I have been doing some strange things in terms of creating and deleting accounts, but I think this happened as a result of an account not getting completely created properly. 

Anything I can do to help debug?
Here's a more precise process to follow to demonstrate the bug:
1. Create a new profile for good measure.
2. Create an IMAP account using username bob@example.com, and incoming server imap.gmail.com
3. Create a second IMAP account using username alice@example.com, and incoming server imap.gmail.com

Should do the trick, and indeed this is how Google Apps email is set up.

It also appears I'm not alone, though this is from September: http://forums.mozillazine.org/viewtopic.php?f=29&t=1479525
(In reply to comment #33)
> 2. Create an IMAP account using username bob@example.com, and incoming server
> imap.gmail.com
> 3. Create a second IMAP account using username alice@example.com, and incoming
> server imap.gmail.com

Did you modify hostname or userName at Server Settings after account definition via auto-config? If yes, Bug 303542 can happen. Check next in prefs.js.
> user_pref("mail.server.serverN.hostname", "xxx.xxx.xxx");
> user_pref("mail.server.serverN.userName", "xxx");
> user_pref("mail.server.serverN.realhostname", "x3.x.x");
> user_pref("mail.server.serverN.realuserName", "x3");
Yeah, the only way (I know of) to create IMAP accounts with usernames at one domain and incoming servers at another is to modify the username and hostname after the auto-config.

Comment 36

8 years ago
It affects me when having more than 2 accounts.

Comment 37

8 years ago
With Thunderbird 3.1.1
(Reporter)

Updated

8 years ago
Duplicate of this bug: 582369

Comment 39

8 years ago
(In reply to comment #38)
> *** Bug 582369 has been marked as a duplicate of this bug. ***

It's not a duplicate

Comment 40

7 years ago
I tried adding a second IMAP account on the same server today, and I regret to say that this bug is still present, at least in Thunderbird 3.1.9 on MacOS X.

Someone(TM) should reopen the bug, as it evidently is still unresolved.
(In reply to comment #40)
> Someone(TM) should reopen the bug, as it evidently is still unresolved.

No, this bug is long closed and fixed something at the time. Please file a new issue with steps to repeat where we can track what you're seeing separately.

Comment 42

7 years ago
The steps to repeat are already detailed in other comments in this bug report, see e.g. Michael Lissner 2009-10-24 18:09:24 PDT.

If it is necessary to open a new bug with the same description, I will do so in a couple of weeks' time, Apple Mail isn't that horrible to use.

Comment 43

6 years ago
They finally fixed it.  Make certain you are using the newest version!

Click HELP, then ABOUT and let it update.  Then it should work.  I hope that helps anyone else who stumbles upon this bug.


PERSONAL RANT

The email configuration is by far the WORST I have EVER seen in my life.  It's amateurish design primarily focused on the idea that people would only ever have one email account per person, per server.  The reset of the configuration possibilities be damned!  It's taken over 5 years to fix something that should have been fixed on day one!

Comment 44

6 years ago
Guys i'm getting this error with version 12.0.1, I have a customer using thunderbird with there Domain, advised to change as issue with outlook with recent windows update, any ideas?

Comment 45

6 years ago
Thank you HAWK for your words, i feel you, im at wits end here as well... Experiencing the same as Andy Buchan. Tried to do a workaround as official thunderbird page suggests the usage of profiles. Doesnt work with those either, although all the settings are supposed to be saved within the profile!?

Having two mailadresses on the same incoming as well as outgoing server. The only difference is the user name, which holds mail account details itself (info@domain_a.com, bw@domain_b.com). HELP!!

Name: Thunderbird
Version: 12.0.1
User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20120428 Thunderbird/12.0.1
Build-ID: 20120428123112

Comment 46

6 years ago
(In reply to Bettina Winkler from comment #45)
> Thank you HAWK for your words, i feel you, im at wits end here as well...
> Experiencing the same as Andy Buchan. Tried to do a workaround as official
> thunderbird page suggests the usage of profiles. Doesnt work with those
> either, although all the settings are supposed to be saved within the
> profile!?
> 
> Having two mailadresses on the same incoming as well as outgoing server. The
> only difference is the user name, which holds mail account details itself
> (info@domain_a.com, bw@domain_b.com). HELP!!
> 
> Name: Thunderbird
> Version: 12.0.1
> User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20120428
> Thunderbird/12.0.1
> Build-ID: 20120428123112

As referred by HAWK i double checked, but still, Thunderbird says i am using the latest version :-/ what to do??

Comment 47

6 years ago
The problem is, even though you delete the account, it's actually still there.  Hence the error you get.  They are apparently not clearing their variables.  

The work around is to change your email address to something like "thunderbird.config.sucks@email.com", then it will save.  After it saves you can then go back in and change your email address back to what it should be.  This allows you to bypass their broken checks.

Let me know if that helps!

Comment 48

6 years ago
Or try a new thunderbird profile.

Comment 49

6 years ago
Thanks for your swift replies, guys. However, no solution from there :-/

Hawk: why changing just the mailadress? having two different ones at domainA and domainB!? even if i try to trick it during account creation and leave it with the suggested server names, it comes back and tells me that the incoming server is already in use!? (which is not correct...). both mail addys are supposed to work on pop. 

Bastard: Tried the profiles yesterday and it didnt help as promised. it still said the same thing, although tried this for the first time, as i wasnt aware of the profile manager before.

From my perspective, this issue is not resolved. I do have several years experience as a programmer, support consultant and project manager for software products. leaving the horrible usability regarding this of TB behind, it still cant be, that sth so simple means the Mount Everest to users... Im ready to hand in screenshots or whatever else you need to make this work, but this is just painful...

Comment 50

6 years ago
Reproduced this error this morning on Mac OS 10.7.4 with TBird 12.0.1. I have multiple accounts on the same server (for testing). Went to add a new one and got the error: incoming server already exists.

Comment 51

6 years ago
The workaround Hawk proposed worked. I inputted <username>.test@<domain>.com and when the ID/password failed, I was able to remove the .test and create the account.

Comment 52

5 years ago
I stumbled into this same bug with version 17.0.

The workaround works, but the bug is still evidently there. The reason is in mailnews/base/prefs/content/accountcreation/createInBackend.js:

>  // if username does not have an '@', also check the e-mail
>  // address form of the name.
>  if (!existing && !incoming.username.contains("@"))
>    existing = accountManager.findRealServer(config.identity.emailAddress, ...

Someone (Ben Bucksch <ben.bucksch@beonex.com> to be exact, if I'm reading hg log correctly) has deliberately wanted to disable creation of multiple accounts with different usernames, but with the same email address.

This makes no sense. I should be able to use same From: address with different accounts. And, I *am* able to do that, if I just change to address after creating the account. So there is no technical reason for the account manager to prevent me from creating the account.

Please reopen this bug.

Comment 53

5 years ago
17.0.8 Not fixed.

Started TB with -P switch. Created a new profile. Used that profile. Tried to add an existing gmail account. The "Checking password..." would stay there forever. So cancelled and tried again. This time I got "Incoming server already exists" error.

Comment 54

5 years ago
It appears that the Cancel button on the Get the New Mail Account window is broken. You press it, the window disappears but the status bar of the main TB window still shows "Connecting to xxx".

Comment 55

5 years ago
This isn´t fixed. There can still be "old" servers in prefs.js, that don´t show up in the TB config screen.

It´s impossible to get an account to run with the same name, unless you manually fiddle with prefs.js and change to old servers name to something else

Comment 56

4 years ago
Running 24.2.0 this bug still exists.  I have a perfectly good gmail account in Tbird that is using pop.googlemail.com and smtp.googlemail.com.  When I try to add a second account with different email address and username but using those servers, the complaint that the incoming server already exists pops up and makes it impossible to create the account.  This is not a matter of garbage entries in prefs.js as I have looked it over carefully and have actually cleaned up some garbage.  The incoming server DOES already exist, but so what?  Why would Tbird refuse to proceed?

I saw a post somewhere suggesting that one put Tbird in offline mode, then create the account.  This works to the extent that an account is created but no folders (inbox, etc.) are created underneath it and it is not possible to create them manually.  Then, when Tbird is closed and reopened, the account label has become blank and it is impossible to delete the account.  It can only be deleted (AFIK) by editing prefs.js.  So this offline trick is not an effective workaround.

Comment 57

4 years ago
I got so fed up with this I started using eM Client after searching for others hours on end and on more than one occasion. It accepted all 4 email accounts with a little tweaking which Thunderbird wouldn't after hours and hours of attempts and ongoing online searching and forums. But then after a few weeks I got a popup window saying the trial period was ending in 6 days! I only started using it because it said it was free. Well, the free version allows only two email accounts.

So, I then looked for an OLD version of Thunderbird as I never had these issues years ago that I have with the last couple of version/updates which I now for the life of me cannot get Thunderbird to accept more than one email account with the exception of using Imap which is not what I want for these accounts and doesn't always work either. So I downloaded and installed Thunderbird version 17. I setup EVERY email account with absolutely no issues whatsoever and turned the "get update" section off. It worked flawlessly so I later got enough guts up to update it. It still works flawlessly. 

And I tried everything imaginable to set these accounts up with the last couple of versions of Thunderbird even using Mozilla Backup and reinstalling some older backups but still had endless problems trying to send or retrieve emails telling me password not accepted, etc, etc.. I know my passwords like the back of my hand and even logged in on the websites with them just to make sure.

Prior to installing Thunderbird before installing the old one, I went through the directories and deleted all Thunderbird directories. Not sure if that matters or not. I didn't even think about cleaning out the registry so that may not be necessary. I'm running Windows 8.1 btw.

Comment 58

4 years ago
Hmmm.......I just noticed people had the same problems with version 17 as well. Odd....It worked great for me on Windows 8.1. Perhaps, depending on the OS, going back to even an earlier version might resolve this. It only takes a minute to update after setting up all the email accounts. Hope this helps somebody. Worked like a breeze for me
I am getting this error in Thunderbird 31.2.0 for Mac when trying to add another Gmail IMAP account.

Comment 60

3 years ago
Not fixed. Still getting this error trying to create a second account with same IMAP server on tb 31.4.0 , Windows 7

Updated

3 years ago
Blocks: 1121151

Comment 61

3 years ago
I opened bug 1121151 for any continuing discussions of the issues in this bug.
You need to log in before you can comment on or make changes to this bug.