Closed Bug 1121874 Opened 5 years ago Closed 5 years ago

Twitter authorization step fails by showing login or 404 screen

Categories

(Chat Core :: Twitter, defect)

defect
Not set

Tracking

(thunderbird38 fixed, thunderbird39 fixed, thunderbird40 fixed)

RESOLVED FIXED
Tracking Status
thunderbird38 --- fixed
thunderbird39 --- fixed
thunderbird40 --- fixed

People

(Reporter: amsin21, Assigned: aleth)

References

Details

(Whiteboard: [1.6-blocking])

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

Added twitter username, local alias, connect this account automatically - ticked, clicked Finish.

Twitter authorize app window pops up, entered username and password, clicked Authorize app


Actual results:

Twitter authorize app window redirected back to twitter log in screen. But now unable to type in password. Please see the screenshot attachment.


Expected results:

Twitter authorization
Severity: normal → critical
OS: All → Windows 8.1
Hardware: All → x86_64
This seems related to bug 1121874.
Severity: critical → normal
Component: Account manager → Twitter
Product: Instantbird → Chat Core
(In reply to Patrick Cloke [:clokep] from comment #1)
> This seems related to bug 1121874.

You meant bug 1068397.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [1.6-blocking]
(In reply to aleth [:aleth] from comment #2)
> (In reply to Patrick Cloke [:clokep] from comment #1)
> > This seems related to bug 1121874.
> 
> You meant bug 1068397.
(In reply to aleth [:aleth] from comment #2)
> (In reply to Patrick Cloke [:clokep] from comment #1)
> > This seems related to bug 1121874.
> 
> You meant bug 1068397.

What is the solution? Please advise.
Hi,

Still no resolution?
I just tried to reproduce this in a TB daily build and everything seems to work fine there.

I also couldn't reproduce this in Bug 1068397.

Does this problem still occur?
Summary: Twitter authorization → Twitter authorization step fails by showing login screen
OK, so it looks like I can reproduce something like this on Instantbird. But instead of the login page the second page I get is the twitter 404 page with a searchbox.
The difference between IB and TB led me to suspect a cookie issue, and indeed setting network.cookie.cookieBehaviour to 0 made the authorization complete successfully.

It would be very helpful to know if this also works for the reporters of this bug.
Flags: needinfo?(amsin21)
(In reply to aleth [:aleth] from comment #8)
> The difference between IB and TB led me to suspect a cookie issue, and
> indeed setting network.cookie.cookieBehaviour to 0 made the authorization
> complete successfully.

Sorry, it's network.cookie.cookieBehavior. US spelling...
Duplicate of this bug: 1156547
Summary: Twitter authorization step fails by showing login screen → Twitter authorization step fails by showing login or 404 screen
It's been confirmed setting the pref works as as workaround. [https://bugzilla.mozilla.org/show_bug.cgi?id=1156547#c2]
Flags: needinfo?(amsin21)
To fix this, we should probably change the pref (in sync with TB, which would also unblock the Filelink patch) and replace it with removing the cookies after auth is complete, using

http://mxr.mozilla.org/mozilla-central/source/browser/components/preferences/aboutPermissions.js#205
Attached patch twittercookies.diff (obsolete) — Splinter Review
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Attachment #8596175 - Flags: review?(clokep)
Keep explanatory comment.
Attachment #8596175 - Attachment is obsolete: true
Attachment #8596175 - Flags: review?(clokep)
Attachment #8596179 - Flags: review?(clokep)
Comment on attachment 8596179 [details] [diff] [review]
twittercookies.diff v2

Review of attachment 8596179 [details] [diff] [review]:
-----------------------------------------------------------------

r+ assuming you tested this by creating multiple accounts in the same session.
Attachment #8596179 - Flags: review?(clokep) → review+
(In reply to Patrick Cloke [:clokep] from comment #15)
> r+ assuming you tested this by creating multiple accounts in the same
> session.

Yes, that works fine.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
OS: Windows 8.1 → All
Hardware: x86_64 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.6
Comment on attachment 8596179 [details] [diff] [review]
twittercookies.diff v2

[Approval Request Comment]
User impact if declined: Currently TB38 will encounter bug 954308 if you try to add two twitter accounts in the same session. This patch fixes that for TB.
Risk to taking this patch (and alternatives if risky): None, unless someone is relying on twitter.com cookies in TB ;)
Attachment #8596179 - Flags: approval-comm-beta?
Attachment #8596179 - Flags: approval-comm-aurora?
Comment on attachment 8596179 [details] [diff] [review]
twittercookies.diff v2

http://hg.mozilla.org/releases/comm-aurora/rev/7203a728a4c9
http://hg.mozilla.org/releases/comm-beta/rev/ec05ac90e575
Attachment #8596179 - Flags: approval-comm-beta?
Attachment #8596179 - Flags: approval-comm-beta+
Attachment #8596179 - Flags: approval-comm-aurora?
Attachment #8596179 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.