Doorhanger to manually search and copy/paste login credentials when the they're not auto-filled

RESOLVED DUPLICATE of bug 1129528

Status

()

defect
P1
normal
RESOLVED DUPLICATE of bug 1129528
4 years ago
3 years ago

People

(Reporter: ckarlof, Unassigned)

Tracking

(Blocks 1 bug)

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: UI-improvement:passwords)

User Story

As a user, I want an easy way to manually copy/paste my saved login credentials for a site if the password manager fails to auto-fill them.

Attachments

(1 attachment)

Reporter

Description

4 years ago
UX is still in design, but the rough idea would be to add a new "key" doorhanger anchor which appears on "login" pages (i.e., roughly whenever we detect a password field). When the user clicks this key, we will provide an easy way to copy/paste credentials for the current page and search all the credentials, if necessary.
Reporter

Updated

4 years ago
Summary: Breakdown: Breakdown: Add affordance for a user to manually search and copy/paste login credentials when the they're not auto-filled → Breakdown: Add affordance for a user to manually search and copy/paste login credentials when the they're not auto-filled
FWIW, LastPass adds a little icon on a password field that, when clicked, opens up a short list of suggestions below the input.  Clicking on one of the entries auto fills it into the field, or you can right click on it and copy the password to your clipboard.  It seems that it filters by domain to determine which ones should show up in the dropdown directly below the input

This is in addition to a separate search UI that includes all passwords, and a context menu item when right clicking inside of the input that lets you copy or autofill from the same short list that shows up when clicking on the icon in the field.
Reporter

Comment 2

4 years ago
Blocked by UX design.
Whiteboard: [blocked]
Reporter

Comment 3

4 years ago
Even though this is marked as blocked by UX, to get a head start we can still proceed to break this down and start implementation with engineer's UI in a doorhanger.
Android version is bug 1126608.
Reporter

Updated

4 years ago
See Also: → 1126608
Reporter

Comment 6

4 years ago
I've been confused about conventions of breakdown bugs. This is now the meta bug for this work.
Summary: Breakdown: Add affordance for a user to manually search and copy/paste login credentials when the they're not auto-filled → Doorhanger to manually search and copy/paste login credentials when the they're not auto-filled
Reporter

Comment 7

4 years ago
The 5 dependencies I added are Ryan's original breakdown of this work.
Reporter

Updated

4 years ago
Assignee: nobody → paolo.mozmail
I just noticed that the work in bug 1125230 (specifically, the top part of attachment 8569784 [details]) is also doing a subview left/right scroll thing. Seems likely that we're going to want this kind of UX in other doorhangers, so part of the work here may be to come up with a generic mechanism for doing so. (And we already to this in the menu panel's subviews, such as for History and Bookmarks, so maybe that should end up using this too?)
Flags: qe-verify+
Flags: firefox-backlog+

Updated

4 years ago
Assignee: paolo.mozmail → nobody
Blocks: 1167657

Updated

4 years ago
Whiteboard: UI-improvement:passwords
No longer blocks: 1167657
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: login-fill-doorhanger-UX
You need to log in before you can comment on or make changes to this bug.