[Text Selection] Email subject not scrollable

VERIFIED FIXED in Firefox 38

Status

()

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: twen, Assigned: pchang)

Tracking

unspecified
mozilla38
x86_64
Linux
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
### STR
0. Prerequisite: Set up an email account.
1. Open email app.
2. Tap pencil icon to compose a new email.
3. Enter a long message in subject that extends out of screen
4. Tap on subject to bring out caret
5. Drag caret left to the beginning of the line

### Actual
Caret can't scroll to the left  

### Expected
Caret scrolls to the beginning of the subject

Note: scroll to the right will auto select and auto scroll to the end of the line

### Version
Gaia-Rev        d4dac29613076bdba3cb8adc217deadb08a2ac20
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/70de2960aa87
Build-ID        20150107160220
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150105.192724
FW-Date         Mon Jan  5 19:27:36 EST 2015
Bootloader      L1TC00011880
(Reporter)

Comment 1

4 years ago
**Correction 
### Version
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Build-ID        20150118162501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150118.195525
FW-Date         Sun Jan 18 19:55:36 EST 2015
Bootloader      L1TC000118D0
QA Whiteboard: [textselection]

Comment 2

4 years ago
Hi Teri, you said the caret can't scroll to the left, is it caused by the edge gesture? The whole email app also moved to the left of the screen? Thanks.
Flags: needinfo?(twen)
(Reporter)

Comment 3

4 years ago
Posted video MOV_2498.mp4
Yes, I think it's edge gesture. I have recorded a video for better understanding. 
Please see attachment.
Flags: needinfo?(twen)
(Reporter)

Comment 4

4 years ago
Email app did not move, only the scrolling did not happen. Thanks.
(Assignee)

Updated

4 years ago
Assignee: nobody → pchang
Priority: -- → P2
(Assignee)

Comment 5

4 years ago
Based on below log, the touchcaret will be hidden when hits the scrollable frame. This issue could be fixed after enabling touchcaret for scrollable frame.



I/PRLog   (26080): -1225604780[b6a4a080]: TouchCaret (b360a400): SyncVisibilityWithCaret:373 : SyncVisibilityWithCaret
I/PRLog   (26080): -1225604780[b6a4a080]: TouchCaret (b360a400): IsDisplayable:462 : Caret does not show in the scrollable frame!
I/PRLog   (26080): -1225604780[b6a4a080]: TouchCaret (b360a400): SetVisibility:169 : Set visibility hidden
I/PRLog   (26080): -1225604780[b6a4a080]: TouchCaret (b360a400): UpdatePositionIfNeeded:389 : UpdatePositionIfNeeded
(Assignee)

Comment 6

4 years ago
If touchcaret drag mode is active, it is possible that touchcaret becomes visible inside a scrollable frame for next frame.
Attachment #8554430 - Flags: review?(roc)

Comment 7

4 years ago
Triage: feature blocker
blocking-b2g: --- → 2.2+
(Assignee)

Comment 8

4 years ago
Update author name
Attachment #8554430 - Attachment is obsolete: true
Attachment #8555741 - Flags: review+
(Assignee)

Updated

4 years ago
Attachment #8555741 - Flags: approval-mozilla-b2g37?
(Assignee)

Comment 10

4 years ago
Comment on attachment 8555741 [details] [diff] [review]
bypass touchcaret visibility check inside a scrollable frame when drag mode is active

Review of attachment 8555741 [details] [diff] [review]:
-----------------------------------------------------------------

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
User impact if declined: User can't scroll the text in subject filed
Testing completed: Verify the test case passed in local
Risk to taking this patch (and alternatives if risky): no risk
String or UUID changes made by this patch: none
waiting for m-c landing before considering the approval.
https://hg.mozilla.org/mozilla-central/rev/8d3180c7e7cd
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Attachment #8555741 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1120352
QA Whiteboard: [textselection] → [COM=Text Selection]
This issue is verified fixed on Flame Master and 2.2.

Result: The subject scrolls automatically when the user moves the caret to the beginning of the line.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150220010206
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: 1b4c5daa7b7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150220002501
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: b864abe1c6b3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Text Selection] → [QAnalyst-Triage?][COM=Text Selection]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.